• ich hab mir ausm Robotron-Forum die neuen Platinen für den ehemaligen Robotron-Bastelrechner Z1013 besogt:

    https://hc-ddr.hucki.net/wiki/doku.php/z1013/z1013-128


    meine Platine ist bereits "teilbestückt" (hab gestern angefangen)


    allerdings sind mir dabei gleich einige Fehler in der Stückliste ins Auge gefallen: (nur falls jemand von euch auch damit liebäugelt, sich einen zu bauen)

    tokabln ::solder::

    - D2 fehlt?

    - bei D3,D4,D5 und D12= LS93 steht in der Liste 16pol. - sind aber nur 14

    - PS/2-Buchse laut Stückliste: EB-DIOS M 06G (für Grün) - ...aber für ne Tastatur würde ich eher M 06V (Violett) nehmen

    - C2 fehlt ebenfalls


    ...und WO zum Henker kriegt man den B761D her?

    bei Bürklin, Pollin, Reichelt, Conrad, Digikey.... jedenfalls nicht *seufz*

    den 74LS295 hab ich dafür gestern hier in Münchberg im "Bastelladen" gefunden


    bis hierher: Platine 15€ - schon bestückte Bauteile: 0,00€::heilig:: ...weil ausm Lager der Firma geklaut! :ätsch:


    ...bin gespannt, ob darauf SYMBOS läuft...

  • Moin, Moin,


    na das ist ja spannend... dann werde ich meine BOM mal gleich entsprechend ändern.


    PS: ich habe 20 Euronen (und für alle drei Platinen 50 Euronen bezahlt :( der Kurs war da wohl gestiegen).


    Platinen sind auch noch nicht angekommen.

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • Hinsichtlich des gesuchten B761(D), das ist ein Operationsverstärker. Schau mal hier:


    http://www.robotrontechnik.de/…owtopic.php?threadid=2261

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • ja, inzwischen weiss ich auch, dass die Dinger unter TAA 761 zu bekommen sind

    aber ausm Robotron-Forum hat sich auch schon jemand gemeldet, der noch einige übrig hat, er schickt mir eins


    hier dann auch gleich mal der heutige Fortschritt:

    Z80 hatte ich noch vorrätig

    für die Platine hab ich mir extra axial-Elkos besorgt - soll ja auf den Bestückungsdruck passen :)

    so - jetzt dauerts erstmal, bis die Bestellung von Reichelt eintrudelt

    achja - und ich brauch ettliche hübsch farbige Jumper

    ...bin jetzt schon bei 30€ incl. der bisherigen Bauteile - aber soviel zahlen ja andere schon für ne nakte Patin.... *schnell weghusch*

  • :versohl:

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • so - inzwischen ist die Bestellung von Reichelt da - ...ok, jetzt sinds nochmal 32€,xx mehr - also bin ich jetzt auch schon fast bei 100€


    Hinweis noch zum Bestücken: laut dieser Homepage hier:

    http://www.sax.de/~zander/index2h.html


    den Kondensator unten am Monitorausgang auf 22µF erhöhen

    jetzt muss ich erstmal den ATTiny flashen, die Eproms brennen.... und dann hoffen

  • sooo - Update:



    nachdem ich ja extra im Robotron-Forum nachgefragt hatte, ob man den Rechner auch direkt über die Backplane versorgen kann (weil dort ja +5V, -5V, GND und +12V angegeben sind), und ein " Ja" erhielt, hab ich das auch so gemacht


    grosser Fehler!

    Achtung tokabln : bitte NICHT nachmachen!

    Backplane abgeraucht - Netzteil defekt!

    ...ich war echt bedient ... natürlich dachte ich, ich hätte nen Fehler beim bestücken meiner Platine gemacht...

    also erstmal alle ICs wieder raus - Spannung direkt an die Platine gelegt -und alle IC-Sockel auf +5V durchgemessen

    - alles ok

    ...also alle ICs wieder rein - ein Labornetzteil ran - gaaaanz vorsichtig +5V drauf - und sieheda - das Board zieht gerade mal 300mA


    ..... also bitte Board direkt über die Anschlüsse versorgen - auf der Backplane ist irgendwo ein Fehler!


    nachdem das geklärt war:


    ER LEBT!



    offensichtlich hat er den Backplane-Angriff unbeschadet überlebt *Happy-Mode on*


    so - jetzt brauch ich Software!


    kann den Fred bitte mal ein Mod in die Rubrik VEB Robotron verschieben - hab gerade erst gesehen, dass wir sowas haben...

  • Shadow-aSc


    Danke Dir für den Hinweis... bin eh noch nicht so weit, da ich gerade an einer CNC Steuerung für meine kleine Proxxon MF70 arbeite... das ist eine Langzeit Baustelle und ich will das Ding endlich fertigstellen.





    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • wow - das sieht aber schon recht weit fortgeschritten aus .... für "noch" nicht fertig

    Respekt - sehr schöne Kabelbündel ... da würde mir wieder die nötige Konsequenz fehlen

  • Naja... eigentlich wollte ich das mit einem richtigen gebundenen Kabelbaum machen... aber das ist mein Prototyp... und da darf es so sein wie es jetzt ist... :mrgreen:

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • ...Backplane ist wieder "repariert" - ich hatte ja gottlob nur eine Federleiste zu tauschen - ging einigermassen ohne Gefluche ~


    somti kann ich mein Board jetzt tatsächlich schön über die Backplane versorgen und vor allem schnell abziehen, wenn nötig - und es hängen keine Kabel dran - Prima


    jetzt hab ichs aber erstmal wieder "entstückt" - also von allen ICs befreit und gestern zu unserer Firmen-Lieferung mit dazu geschmuggelt

    ...geht jetzt zum "professionellen" Waschen

    unser Anbieter verlangt gerade mal 1€ pro Platine ....ob der gross Gewinn macht?


    Bilder folgen, wenn es wieder da ist - bin gespannt

  • next Step:


    Platine ist wieder vom waschen zurück

    (idealerweise schickt meine Firma ca. 1x Monat ettliche Platinen zu einem Bestückungsunternehmen in der Gegend um Bayreuth zum waschen

    = professionelle Reinigung mit VE-Wasser und speziellem Reinigungspulver + Trocknung etc.)

    ich hab den Chef gefragt und er hatte nix dagegen - also hab ich meine Platine gleich mit weg geschickt

    Reinigung kostet übrigens 1€ !!! pro Platine - super!

    Hier das Ergebnis:


    also ich finds echt super - wie übrigens alles, was wir bislang haben waschen lassen - keine Kolophoniumreste - keine Schlieren - absolut Spitze das Ergebnis

    ... und das alles für lediglich 1€..... wie können die so günstig sein?


    tja - danach gings dann ein weiteres Mal für mich ans Bestücken

    logischerweise hatte ich alle ICs, Jumper etc. vorher entfernt -

    also alles wieder mühsam neu bestücken, hat fast 3 h gedauert - und ich brauchte tatsächlich ne Brille ... manche ICs haben so dunkle Beschriftungen

    ...die konnte ich mit blossem Auge nicht mehr lesen (bislang ging das immer noch .... ich werd ALT! )


    mein Problem allerdings mit der Tastaturbelegung hat sich durch diesen Vorgang leider nicht gebessert - nach wie vor funktionierten A, B und C nicht - erst ab D hat die PS/2 - Tastatur dann funktioniert


    AAAABER: heute hab ich dann den entscheidenden Hinweis bekommen - aus dem Forum Robotrontechnik

    auch hier hat sich wieder ein Fehlerteufel eingeschlichen - der Bestückungsdruck und auch die Dokumentation - also das *Best.pdf sind fehlerhaft

    die Jumper oberhalb des AtTiny, der die Tastatur auf die Z80PIO umlegt sind dort falsch beschrieben:


    die korrekte Jumperstellung kann man dem nächsten Bild entnehmen tokabln : auch für dich:


    Die Jumper 1,2,3 und 4 müssen - wie hier gezeigt jeweils unten nach rechts - und oben nach links gesteckt werden


    und schon kann man auch die PS/2 - Tastatur vollständig benutzen! - Juhee!

    so - jetzt kann ich endlich weiter testen -

    dann werd ich mir mal ein bischen Software besorgen für das gute Stück


    ich bring den dann selbstredend auch am 15.02- zum Treffen mit - und auch zum Waiblinger User Treff

    sprecht mich also an, falls Interesse besteht

  • Bei einem meiner Kunden habe ich mal eine Platinenspülmaschine angeschlossen.

    Im Prinzip ist die einer gewöhnlichen Haushalts-Spülmaschine ähnlich.

    Wird halt über eine entsprechende Wasseraufbereitung versorgt, und das verwendete Reinigungsmittel ist natürlich auch ein anderes.

  • jepp - wir haben neulich mal einige Platinen mit aufgeschraubten Kühlkörpern für 78xx - Spannungsregler hingeschickt


    ...die Dinger waren vollständig Silberfarben - sprich "Lackentfernt" als sie wieder kamen:tüdeldü:

  • so - heute hat dann mein Z1013 auch endlich mal einen Teil seiner Zusatzplatine bestückt bekommen: jetzt also mit USB-Fähigkeit!


    Ich werde weiter berichten, wenn die Ramdisk, Echtzeituhr, IDE-Schnittstelle, VGA-Ausgang und Neztwerk soweit sind

  • Hobi:

    erstmal vielen Dank für deine Hilfe mit dem anderen Zeichensatz

    ..jetzt würde das Bild auf dem unteren Monitor im Post oben wesentlich anders aussehen


    würdest du vielleicht hier auch deine Joystick-Bauanleitung einstellen? - oder gibts da online schon irgendwo eine Möglichkeit nachzusehen?

  • Ich habe mal angefangen meinen Joystickadapter fuer den Z1013 mittels KiCad zu zeichnen. Leider bin war das mein erster Tag. Vielleicht ist das Ergebnis noch nicht ausgereift.


    Alles was man zum Nachbau braucht sind ein SUB-D 9 male, SUB-D 15 HD male Steckverbinder und etwas Kleinfutter.


    Für Entwickler bietet es sich an die 2 Spielhebel Variante zu nehmen, ansonsten reicht auch die einfache Variante. Wer will kann an PA7 noch einen Piezo anschliessen.


    wie schon gesagt. Es ist mein erster Versuch gewesen. Über Kommentare wäre ich sehr dankbar.


    Eigentlich wollte ich den Steckverbinder, mangels Footprint, als einzelne Pins realisieren, die ich dann nach Belieben durchnummerieren kann. Leider konnte ich die Pin-nummer nicht ändern. Es stand immer 1 da. So dass ich dann hilfsweise einen 1x5 Pin-header nehmen musste.


    Wahrscheinlich bietet es sich an langfristig, den Footprint des Steckverbinders selbst einzupflegen.


  • beflügelt durch das Treffen gestern in Münchberg kann ich nun auch mal meinen aktuellen Fortschritt dokumentieren:


    ..das graue gerollte Kabel ist zum Einlesen von Wav-Files über Soundkarte

    wie man sieht, hab ich (danke nochmal an Hobi ) jetzt die Originale Folien-Tastatur zusätzlich zur PS/2 ....und sie funktionieren auch noch beide gleichzeitig :vivat:

    dadurch lassen sich ettliche Spiele deutlich einfacher spielen, weil das Layout jetzt auch zu den benutzten Tastenkommandos passt - und man nicht immer überlegen muss, welche Tasten auf der PS/2-Tastatur man suchen muss, um in welche Richtung zu laufen (z.B. Ladder)


    ausserdem noch die Joystick-Erweiterung :

    ..von der ich ehrlich gesagt bis zur Fertigstellung nicht geglaubt hatte, dass das überhaupt funktionieren könnte...


    dann kann das #Bee jetzt kommen - dadurch dass ich meinen Z1013 nur mit HCT-ICs bestückt hab, braucht der relativ wenig Leistung und kann bequem mit einer USB-Power-Bank betrieben werden (praktischerweise hat man ja auch gleich 2 USBs an Bord, dadurch, dass auf dem VDIP-Modul eine Buchse ist und auf der Erweiterungs-Platine ebenfalls eine Buchse thront

    somit kann man den gesamten Rechner mit Strom versorgen - und trotzdem noch Programme vom Stick laden - genial!

  • Hallo Shadow-aSc, der Z1013//128 funktioniert tatsächlich mit beiden Tastaturen gleichzeitig, ich hatte doch irgendwo gelesen, dass das nicht getan werden sollte, bzw. nicht funktioniert?

    Wenn das so ist, werde ich das umgehend ausprobieren, ich habe noch eine Tastatur, bestehend aus richtigen Mikrotastern als Nachbau des Originals.

    Der Monitor ist dann der originale 2.02?


    MfG manno


    Oh, ich hatte vergessen, mich vorzustellen: manno, meines Zeichens seit über 30 Jahren Sammler alter Computer, Elektronikbastler und in diversen spezifischen Foren unterwegs.:)

  • ja, funktioniert bei mir mit beiden Tastaturen gleichzeitig - sowohl mit dem Original-Monitor 2.02

    als auch mit dem Brosig-Monitor

    ..bei letzterem müssen natürlich alle Jumper beim ATTiny umgesteckt werden, weswegen ich vermutlich seeehr selten zwischen diesen beiden Monitoren wechseln werde

    Hobi hat mir dabei geholfen, bei einem Treffen in Münchberg, indem er mir ein Rom mit beiden Monitor-Versionen gebrannt hat, muss man dann nur den Jumper neben dem Z80 umstecken, der den jeweiligen Adressbereich aktiviert


    von mir natürlich auch ein herzliches Willkommen hier im Forum

  • Danke, ich werde das mal probieren. Ich habe mehrere Monitore auf 2764 gebrannt. Darunter auch Standard 2.02 und Brosig. Für die Tastaturumschaltung müsste man sich einen Mehrfachumschalter (5 Ebenen) nehmen und etwas Entsprechendes basteln. So könnte man ganz einfach umschalten.