Fehlerbehebung beim Booten / PDP 11/23+ / PDP 11/24

  • Als Brandneues Mitglied hier im Forum ersteinaml hallo miteinander .


    Nun als Neuling gibt es viele offene Fragen , vielleicht kann mir hier jemanden mit mehr Erfahrung helfen das Problem zu lösen .


    An einer CNC Koordinatenschleifmaschine ist bei uns ein PDP 11/23+ verbaut , die Platine ist Beschriftet mit M8189 5014313 C .

    Hier haben wir aufgrund des nicht bootendem System , die CPU , Floating Point und MMU getauscht .

    Jetzt lief das System 1 Tag ohne Probleme . Heute Morgen nach dem Neustart kam dann folgender Fehler .


    SYSTEM-ERROR : FAT


    MODUL.:COMMON PROC : TIO_______ ERROR: 000001



    R0/000200 R1/177564 R2/000000 R3/040146 R4/020062 R5/000002 R6/001744


    PR1/002000 PR2/002200 PR3/002400 PR4/002600 PR5/003000 PR6/003200


    Type Return


    Erneuter tausch der CPU , Floating Point und MMU brachte keine veränderung .


    Wie kann man diesen Fehler beheben ? Worauf deutet dieser hin ?


    Grüße


    MWTHEONE




  • MWTHEONE

    Changed the title of the thread from “Fehlerbehebung beim Boot / PDP 11/23+ / PDP 11/24” to “Fehlerbehebung beim Booten / PDP 11/23+ / PDP 11/24”.
  • Moin,

    liege evtl. voll daneben.

    Ist nicht die Addresse 177564 einem Printer zugeordnet?

    Hat das System sowas? Fehlt dem Papier?

    Wird die CNC Maschine evtl. über den Parallel-Port angesteuert?

    Klingt sehr interessant, bitte um update und weitere Infos über das System.

    Viel Erfolg.

    Bernhard

  • Wurden da die Betriebsspannungen vom Netzteil mal genauer angeschaut? Da würde ich mit anfangen. Die Spannungen unter Last beobachten. Messen der Spannung am besten auf der CPU Platine um alle Spannungsabfälle durch Kontakte zu berücksichtigen.


    Gruß,

    Volker

    Suche Teile und Geräte für DEC PDP8 Systeme, DEC PDP 11/40 (Unibus) und Teletype ASR-33+ ASR-35. Sowie Zubehör, Doku usw. aus dem Umfeld.

  • Ich mag ja alte Computersysteme... was mich aber doch sehr verwundert ist die Tatsache das solch ein System wie die PDP 11/23+ scheinbar noch im produktiven Umfeld eingesetzt wird. Auch wenn es nur eine Koordinatenschleifmaschine ist... bin ich doch ein wenig verwundert.

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • Die CNC Steuerung der Fa. Atek CNC 311 wurde auf diesem System aufgebaut .

    Leider gibt es diese Firma nicht mehr .

    Dadurch ist der Support + Ersatzteile schwieriger zu beschaffen .


    Den Umbau dieser CNC Steuerung auf eine Modernere können auch nur wenige Firmen .

    Wo kann ich die oben gezeigte Platine reparieren lassen oder kaufen ?


    Beschriftet ist SIe mit IMCV 11 Inca

    • Official Post

    Die Platine dürfte auf dem Markt nicht zu bekommen sein. Wenn auf der Karte die Spannungen stimmen und keiner der Tantals defekt ist, könnte man mal einen Blick auf die SRAMs werfen. Auch die EPROMs sichern wäre angeraten. Der Akku ist noch ok?

  • Da die Bausteine auf der Platine (also die ICs) wohl alle gesockelt sind, könnte man doch ggf. den RCT von slabbi für einen Test selbiger nutzen.


    Das es Timing Probleme geben kann okay, aber dann wüsste man zumindest das die ICs grundsätzlicherweise funktionieren, oder findet defekte ICs.


    Tantals wie von Schroeder angesprochen, sind dann die nächste Sache und ja, die EPROMs (deren Inhalt) sollte unbedingt gesichert werden.

    Gruß Torsten

    BFZ MFA, ZX80Core, AX81, ZX81, ZX81NU, Spectrum+, Harlequin, MSX VG8010, Amstrad NC100, Cambridge Z88, C64, C128D, Amiga 500 & 1200, Atari Portfolio, HP200LX, IBM PC5155, TP755c, TP755cx, T20, T41, T61, PS/2 (Model 40SX), PS/2E, Accura 101, Apple //e, Sharp PC1401 & PC1403H, TI59 m. PC-100c, HP48SX & HP48GX


    ::matrix::

  • Ja der Akku ist in Ordnung . Andere Bauteile müssen soweit möglich geprüft werden .

  • So das neue Netzteil ist eingebaut , keine Veränderung.


    Die Inca IMCV 11 Platine , wie muss ich mir die Funktion vorstellen?


    Ist das der Speicher wie eine Festplatte heute ?


    Der Startvorgang bzw. die Maschine lässt sich über 2 Laden / starten über PRom einschalten .


    Mann kann dann auch damit arbeiten.


    Starten über 1 Restart ist nicht möglich


    Wenn die Maschine komplett Stromlos abgeschaltet wird sind die zuvor eingegeben Daten weg .


    Starten dann auch nur über 2 PRom möglich , bei 1 Restart habe ich den gleichen Fehler wie oben siehe 1.Bild . Power Fail wird aktuell nicht mehr angezeigt.


    Für mich sieht das so aus als wäre der Speicher für die eingegeben Daten defekt .


    Durch das Laden über PRom wird dann das System immer wieder neu vom E-Prom geladen.


    Ist diese Annahme korrekt ?


    Grüße MWTHEONE

    • Official Post

    Das ist soweit korrekt.


    Die Erkennung "Power Fail" dürfte auch nur bei intakten SRAM kommen, ansonsten dürfte das System sich den vorherigen Zustand nicht gemerkt haben.

    Ich schau mir nachher mal die CPU Platine an. Das Programm läuft ja, entweder im SRAM oder im DRAM falls auf der CPU Platine vorhanden.

    Falls es im SRAM läuft könnte stellt sich Frage der Pufferung.

    Ich habe hier ein ähnliches System mit einer ähnlichen SRAM/Eprom Karte. Das schaue ich mir mal an.

  • Da die Bausteine auf der Platine (also die ICs) wohl alle gesockelt sind, könnte man doch ggf. den RCT von slabbi für einen Test selbiger nutzen.


    Das es Timing Probleme geben kann okay, aber dann wüsste man zumindest das die ICs grundsätzlicherweise funktionieren, oder findet defekte ICs.


    Tantals wie von Schroeder angesprochen, sind dann die nächste Sache und ja, die EPROMs (deren Inhalt) sollte unbedingt gesichert werden.


    Mit Slabbi habe ich mich in Verbindung gesetzt , für meine Prüfung meinte er wäre das Ausprobieren günstiger , da der Tester nicht ganz billig ist .


    Aber super Hinweis , Danke nochmals . Vielleicht muss ich ja den Tester doch noch kaufen , wenn es nicht anders lösbar ist .

  • Konntest du schon nach deinem System schauen ?


    Diese SRAM Bausteine , kann man diese einfach Tauschen ? Wenn man baugleiche bekommt ?

    Werde auf verdacht noch die Pufferbatterie tauschen , nicht das diese das ganze Problem verursacht .

  • Hi MWTHEONE,

    kannst du den Rechner anhalten, um in den ODT (Debugger) zu kommen?

    Entweder da ist ein Halt-Schalter, oder du kannst mit Break am Terminal die CPU halten (ggf. braucht es eine Brücke auf der CPU-Platine).


    Wenn der ODT läuft, kannst du ein paar Checks machen.

    Die Fehlermeldung sieht für mich so aus:

    SYSTEM-ERROR : FAT

    Fataler Fehler


    MODUL.:COMMON PROC : TIO_______ ERROR: 000001

    TIO könnte für Timeout stehen, das deutet auf einen Controller, der NICHT mehr antwortet.

    Eine graue Controller-Karte für die Steuerung wäre mein erster Verdacht.


    Die Register sagen erstmal nichts.


    Nachdem der Bildschirm schon das Menü zeigt, scheint die ROM-Karte okay zu sein. Für dieses ausführliche Menü braucht es den RAM, der scheint auch okay zu sein. Die Batterie ist erstmal nebensächlich - die braucht das Ding vielleicht nur, wenn es nach Ausfall an der letzten Stelle weiter machen soll...

  • ein Restart über 1 ist nicht möglich

    Was sollte da passieren?

    Das Menü vom Bildschirm oben kommt ja schon vom PROM.


    Wenn ich dich richtig verstehe, dann bringt "über den PROM booten" die Funktionalität der Anlage? Kommt da ein Programm zur Bedienung der Anlage, das im PROM abgespeichert ist?


    Der Lochstreifenleser - wofür ist der? Sind da die GCodes (oder was es damals gab) drauf?


    Das Handbuch sagt leider nicht viel.

    Schon witzig, was die (ich teilweise auch :fp: ) in den 70 - 80ern noch für Technologie zusammengebastelt haben :D

  • So habe heute endlich die neue Pufferbatterie erhalten und diese getauscht , der Restart 1 funktioniert jetzt wieder .


    Die alte Batterie hat aber immer noch 3 Volt , kann es sein das diese unter Last zusammenbricht ?


    @Schroeder


    Somit ist der Aktuelle stand jetzt :


    Booten über 1 Restart funktioniert jetzt wieder , nach Batterie tausch , wenn der Schalter 7 und 8 auf AUS sind .

    Booten über 2 PROM funktioniert immer noch , wenn der Schalter 7 und 8 auf AUS sind .

    Schalte ich diese Schalter 7 + 8 auf ein , kommt in beiden Bootvorgängen Fehler : SYSTEM-ERROR : FAT ......


    Zwischenfazit :


    - System ist lauffähig und speichert auch wieder die Daten , nach Batterietausch auf der IMCV 11 .

    - Power Fail wird auch wieder agezeigt , nach Batterietausch auf der IMCV 11 .

    - System bootet von PROM

    - System bootet mit Restart


    Sobald Schalter 7 + 8 auf der IMCV 11 auf Ein sind , bootet das System in den SYSTEM-ERROR : FAT ......


    Was bewirken diese Schalter ?

    Finde hier keine Erklärung dazu ?


    @Manitux


    Der Lochstreifenleser diente früher als Speicher- und Einlesegerät . Wurde aber bei uns nicht mehr benutzt .

  • Sobald Schalter 7 + 8 auf der IMCV 11 auf Ein sind , bootet das System in den SYSTEM-ERROR : FAT ......


    Was bewirken diese Schalter ?

    Ich hab in meiner Laufbahn seltsamerweise nie ein INCA Speichermodul in Händen gehabt und Beschreibung hab ich auch keine. Aus dem Handbuch geht auch nix hervor, das passt sowieso nicht zu der Karte auf dem dem Foto.

  • Gratuliere :)

    Das sah nach deiner Beschreibung nicht ganz realistisch aus.


    Ja Danke , damit hätte ich jetzt auch nicht gerechnet , vielleicht weis noch jemand was die Zwei Schalter bewirken .


    Die Maschine ist zwar lauffähig aber der Fehler ist ja nur umgangen !!!

    Nicht das im Hintergrund noch mehr kapput geht . :shock:


    Aber bis hierhin auch erstmal ein großes Dankeschön an alle Helfer ;) @Manitux @Schroeder @tokabln @gnupublic @Bernhard @slabbi