Programmierung der Olivetti Programma 101

  • Hallo, ich habe jetzt mal angefangen, Unterlagen zur Programma 101 zu sammeln, bei Gelegenheit werde ich auch die Handbücher, die im Technikum29 lagern, noch einscannen, weil genau diese speziellen Handbüchern zu bestimmten Anwendungsgebieten, die ich dort sah, wurden scheinbar noch nicht digitalisiert.


    Ich erinnere mich außerdem, mal eine Webseite (auf italienisch) gesehen zu haben, die sich sehr ausführlich mit der Programmierung der Programma 101 befasste, dort gab es auch mehrere Programmlistings für die Maschine. Ich finde sie allerdings leider nicht mehr, auch auf archive.org nicht, eine URL die ich fand und passend sein könnte, öffnet nur noch Schweinekram, auch auf archive.org, man muss dort bis ins Jahr 2016 zurück, damit die Seite (101project[.]eu) was anderes anzeigt, aber das ist auch nicht die Seite, die ich in Erinnerung habe.


    Anbei erstmal brauchbares, was ich seit gestern Abend auf diversen Seiten zusammen tragen konnte, da sind auch von mir in PDF gedruckte Webseiten dabei, welche sich mit der Programmierung der P101 befassen, auch zwei Emulatoren sind dabei. Viel Spaß damit, und wenn wer weiteres hat, würde ich mich über regen Austausch freuen.

  • 137378-pasted-from-clipboard-png


    Bei dem Wetter macht man eigentlich was anderes, so auch ich, wir haben den ganzen Tag im Garten gefaulenzt, Pool, Grillen, Eis, Cocktail, Melone, Eis... Und jetzt nach TV Gucken ("Wunderschön" über das Baskenland, da will ich jetzt wohl auch mal hin...) hab ich mal geschaut, wie man die Programma öffnet, schließlich sind rundherum keinerlei Schrauben zu entdecken. Um es kurz zu fassen, es ist genauso ein Trick wie bei den etwa gleich alten Editor und Lexikon Schreibmaschinen, wo sich die Gehäuseschrauben seitlich unter dem Wagen befinden. Bei der Programma muss man den Deckel auf dem Drucker abheben, und dann quasi von flach vorne über den Drucker linsen, und dann sieht man oben unter dem Gehäuserand rechts und links in der Öffnung zwei Schrauben, welche sich beim Aufdrehen als ziemlich lang entpuppen. Beim Rausholen und wieder Einsetzen der Schrauben muss man gut aufpassen, nicht dass die innen rein fallen, sonst hat man ziemlich gelitten, um die wieder rauszufischen.


    Jedenfalls kann man dann das hintere Gehäuseteil nach hinten weg schieben und dann werden rechts und links je eine Schraube sichtbar, die das vordere Gehäuseteil fixieren. Nach dem Lösen der beiden Schrauben liegen dann rechts und links der Maschine je eine Mutter, nach kurzer Ansicht war klar, man braucht nicht so weit raus zu drehen, die Muttern sollten auf den Schrauben drauf bleiben, das Gehäuse wird nur durch Anwesenheit der Schrauben in 2 Ösen des Gehäuseunterteils gehalten. Die beiden Gehäuseschalen sind übrigens ziemlich robust, Aluminiumguss, aber auch eine Erklärung dafür, dass die Programma rund 35 Kg wiegt.


    Das ist dann die rechte Seite, da fehlt der Antriebsriemen vom Motor vorne auf den Lüfter hinten. Er liegt da oben auf der Elektronik, das Stück was da liegt hat einen runden Querschnitt mit 3mm Durchmesser, und es ist 64 cm lang, aber wenn ich es um die zwei Räder lege, muss ich es über 5 cm spannen, damit die beiden Enden wieder aneinander kommen. Ich habe schon eine Bestellmöglichkeit für solche Antriebsriemen gefunden, weiß jetzt aber noch nicht, ob der Original-Riemen in der Länge geschrumpft ist und eigentlich länger sein müsste, oder ob man den da zu bestellenden Riemen so weit dehnen kann.


    Übrigens, so wurde mir zugechattet, habe ich hier Glück, das ist keine der ganz frühen P101, sondern eine von einem späteren Produktionsdatum, denn bei der hier sind die ganzen Laufräder für die Riemen aus Sintermetall. Oder die Räder wurden schon im Service getauscht...? Bei frühen Exemplaren hat man Plastikräder verwendet, welche zu schnell verschleißen oder gar durch Alterung brechen. Würde wahrscheinlich schwer, die zu ersetzen, es sei denn da könnte jemand was mit 3D-Druck machen...


    Die anderen beiden Zahnriemen am Drucker sehen gut aus, sie sind gut gespannt und sehen zumindestens stabil aus. Die ganzen Gummirollen habe ich jetzt noch nicht untersucht, ich weiß auch noch nicht, wo überall welche sitzen. Man beachte auch den Service-Aufkleber aus dem Jahr 1986...


    Die linke Seite, insgesamt sieht diese P101 sehr sauber aus, an dem Staubfilter haftete kaum was, auch sonst keine Staubflusen zu sehen, das könnte sich durch die Wartung im Jahr 1986 durch den Olivetti Technischen Kundendienst erklären. Den Techniker, der das gemacht hat, dem dürfte ich damals wohl gelegentlich begegnet sein. In dem Kasten hinter dem Staubfilter befinden sich 5 oder 6 Einschubplatinen mit der ganzen Elektronik drauf.


    Hier ein Blick auf die RTL-Technik (Resistor Transistor Logic), das Board hier wohl der Schreiblese-Verstärker für den oben im Bild erkennbaren Drahtschleifenspeicher (magnetorestriktiver Laufzeitspeicher) sein. Faszinierend, wie man in so einem Stück Draht 240 Bytes durch Schwingungen (!) speichern kann... Wie man sieht, die Bauteile stecken senkrecht in der Trägerplatine, und oben drauf sind reihenweise weitere Platinchen aufgelötet, um die anderen Enden der Transistoren Dioden, Wiederstände und Kondensatoren miteinander zu verbinden. Jedes der kleinen Platinchen mit den Bauteilen darunter bildet wohl je ein Logikgatter. Wenn ich das sehe, denke ich schon wieder, was für Genies müssen das da in Ivrea gewesen sein, beim Layout von Hand haben die hier in der dritten Dimension gearbeitet... Und das in der Produktion von Hand zusammen zu löten war sicher auch kein Spaß.


    Jetzt brauche ich erstmal eine Bestätigung für die Länge des Antriebsriemens für den Lüfter und dann mal weiter sehen.

  • Hab mal Nummer 2 aufgemacht...


    Das handgeschriebene Datum sagt 24.7.1972, somit knapp 3 Jahre jünger als obige (8.10.1969), auch hier ist der Antriebsriemen für den Lüfter in Einzelteilen oben drauf gelegt, hier übrigens nur 58 cm lang.


    Auch diese P101 hat einen Serviceaufkleber von 1986, außerdem fand ich ein Stück auffällig geformte Dämmmatte in der Maschine, auf der ein weiterer Serviceaufkleber von 07/1974 mit Telefonnummer des Services klebt, 0511er Vorwahl, die müsste also zumindestens 1974 im Großraum Hannover zuhause gewesen sein. Wo dieses Dämmmatten-Teil hingehört, habe ich noch nicht rausgefunden.


    Ob man da mal anrufen sollte...? Immerhin fand ich auf der Bodenplatte eine M3 Schlitzschraube, ich glaube, diese Leute können mir sagen, wo die fehlt...


    Während die andere P101 ziemlich sauber ist, diese hier ist es nicht. Aber immerhin auch hier scheinen die Antriebsriemen des Kartenlaufwerks und des Druckers in Ordnung zu sein. Leider fehlt das Plastikteil vom Ein/Aus-Schalter.

  • Hab jetzt mal die Dritte aufgemacht, oje...


    Naja gut, sie ist quasi komplett, aber der Zahnriemen am Drucker ist definitv fertig, und da einen in passender Länge und Zahnung zu bekommen wird bestimmt sportlich. Im Gegensatz zu den anderen beiden Maschinen hat diese scheinbar nie eine Wartung bekommen, sie ist auch vergleichsweise dreckig. Auf den Isolierschläuchen um die dickeren Kabel ist eine weiße pulvrige Schicht, die sich abkratzen lässt, darunter kommt aber ein einwandfreier glänzender Kunststoff zum Vorschein. Was das wohl ist?


    Die erste geöffnete sieht definitiv am besten aus und ich werde diese behalten, da bin ich mir erstmal sicher.


    Inzwischen haben sich übrigens insgesamt 5 Leute gemeldet, die eine haben wollen, dabei habe ich noch garnicht angefangen, eine anzubieten...


    Nummer 3 ist vom 21.1.1970, der Antriebsriemen für den Lüfter ist verflüssigt, mehrfach gerissen oder zerbröselt und klebt am Boden. Eine Längenmessung macht da keinen Sinn. Ich ahne schon, wie die Transportgummis im Kartenleser aussehen... Man sieht da auch den weißen Belag auf dem Kabel.



    Die ist am schmutzigsten von den drei, in der Führung vom Magnetkartenauswurf ist etwas Flugrost, der Zahnriemen für den Druckerantrieb hat sich aufgelöst, außerdem läuft er auf einem Plastikzahnrad. Man beachte auch den weißen Belag auf dem Kabel neben den beiden Sicherungen.


    Die linke Seite mit dem Luftfilter. Auch hier wieder ein Kabel vor der Backplane mit dem weißen Belag. Diese P101 unterscheidet sich von den beiden anderen neben den Plastikrädern für den Zahnriemen am Drucker noch in einem winzigen Detail - die seitlichen Schrauben zum Halten des vorderen Gehäuseteils haben keine Muttern, hier wurde tatsächlich in die Ösen am Gehäuseboden ein Gewinde geschnitten. Wie bei #2 hab ich auch in der wieder eine kurze M3-Schraube gefunden...


    Diese hier zu restaurieren wird definitv ein Spaß...

  • Auf den Isolierschläuchen um die dickeren Kabel ist eine weiße pulvrige Schicht, die sich abkratzen lässt, darunter kommt aber ein einwandfreier glänzender Kunststoff zum Vorschein. Was das wohl ist?

    Möglicherweise hast Du ja auch bereits eine vage Idee, was der weiße Belag sein könnte.

    Bin kein Chemiker, aber würde dabei an die Chemie des Kunststoffes denken, die sich über die Jahrzehnte zersetzen können.

    Es gibt Kunststoffe, denen sieht man ihr fortgeschrittenes Alter (noch) nicht an. Das sind sowieso die Guten! Aber leider sind nicht alle so.


    Meine Vermutung: es gibt Kunststoffe, deren chemische Integrität nachlässt. Bestimmte Bestandteile (oft Weichmacher) verlieren ihre chemische Bindung an den Kunststoff und entfalten unerwünschte Wirkungen. Wir alle kennen das ja bestimmt z.B. von Netzkabeln, die lange Zeit auf den Kunststoffgehäusen von Computern abgelegt waren. Die austretende Chemie reagiert mit dem Gehäusekunststoff und kann unschöne Spuren im Gehäuse hinterlassen.


    Hatte z.B. ein Flachbandkabel um ein Kleingerätegehäuse gewickelt und für 1 Jahr eingelagert. Tja, das war schon zu lange. Die beiden sind eine innige Verbindung eingegangen, deren Spuren man noch heute sehen kann. Ein anderes Beispiel: Ein altes Fotostativ aus den 70ern hat Gummifüße. Jahrzehnte waren die gut. Bis vor einigen Jahren auch ein weißer pulvriger Belag (wie bei dem Isolierschlauch) darauf zu sehen war. Die Gummifüße sind nun auch nicht mehr Gummi, sondern verhalten sich wie ausgetrocknetes Kerzenwachs. Einen der Gummifüße konnte ich mit den Fingern zerbröseln.


    Ich habe jetzt leider keinen tollen Tipp zu Hand. Vielleicht kann der Belag mit einem Tuch abgewischt werden. Wenn der Isolierschlauch ansonsten noch gut ist, würde ich weiter nichts machen. Beim saubermachen würde ich Gummihandschuhe anziehen, weil ich der unbekannten Chemie nicht trauen würde. Was im Internet über Weichmacher zu lesen ist, beruhigt nicht.


    Falls ein Kunststoff brüchig wird, hilft vielleicht ihn mit Weichspüler (50% verdünnt mit Wasser) einzureiben oder gar über Nacht einzulegen. Das ist aber auch nur ein unverifizierter Vorschlag, den ich im Zusammenhang mit der Behandlung von klebrigem Softtouchlack mal im Internet gelesen hatte.


    Und noch eines fällt mir im Zusammenhang mit agressiver Chemie ein. Ich hatte mal eine Dose Kältespray in einer meiner durchsichtigen Sunware-Kisten zusammen mit anderen Dingen, wie Kabeln und Diskettenlaufwerken jahrelang gelagert. Krude Mischung - ich weiss. Es ging erst gut, bis die Dose undicht wurde und deren Chemie die Laufwerke und die Kabel angegriffen hat. Eines habe ich daraus gelernt: nie Spraydosen in Kisten zusammen mit anderen Dingen lagern.

  • Auf den Isolierschläuchen um die dickeren Kabel ist eine weiße pulvrige Schicht, die sich abkratzen lässt, darunter kommt aber ein einwandfreier glänzender Kunststoff zum Vorschein. Was das wohl ist?

    Möglicherweise hast Du ja auch bereits eine vage Idee, was der weiße Belag sein könnte.

    Bin kein Chemiker, aber würde dabei an die Chemie des Kunststoffes denken, die sich über die Jahrzehnte zersetzen können.

    Es gibt Kunststoffe, denen sieht man ihr fortgeschrittenes Alter (noch) nicht an. Das sind sowieso die Guten! Aber leider sind nicht alle so.

    Ich kann den Beleg auf den Fotos leider nicht erkennen (vielleicht noch mal ein größeres Foto posten), aber ich hatte so einen weißen Belag schon großflächig auf den Kunsstoffteilen einen Fernschtreibers. Aber nur auf bestimmten Teilen, vermutlich materialabhängig.


    Der Belag war aber oberflächlich und ließ sich leicht abwischen. Das sah nicht so aus, als wäre das auf dem Kunststoff ausgeblüht, sondern eher so, als hätte sich das dort aus der Luft abgesetzt.


    Ich hab die Teile gereingt und gut war's. ;)


    Von den großflächigen Teilen habe ich leider kein Foto. Nur von diesem Stecker:


    i-Telex 211230 dege d

    http://www.marburger-stammtisch.de


    Douglas Adams: "Everything, that is invented and exists at the time of your birth, is natural. Everything that is invented until you´re 35 is interesting, exciting and you can possibly make a career in it. Everything that is invented after you´re 35 is against the law of nature. Apply this list to movies, rock music, word processors and mobile phones to work out how old you are."

  • die Rechner sind ja aus dem technikum29 und waren teilweise in muffiger Umgebung gelagert. Wir hatten so einen weissen "Schimmel" auf manchen Kabelbäumen, aber wie detlef auch schon schrieb, sehr selektiv nur auf bestimmten Kabeln. Lies sich mit Wasser und Spülmittel sehr leicht reinigen, der Kunststoff darunter war wie neu. Wer weiss, was da in unseren Depots so "lebt".


    Roland

  • Ich kann den Beleg auf den Fotos leider nicht erkennen (vielleicht noch mal ein größeres Foto posten), aber ich hatte so einen weißen Belag schon großflächig auf den Kunsstoffteilen einen Fernschtreibers. Aber nur auf bestimmten Teilen, vermutlich materialabhängig.


    Der Belag war aber oberflächlich und ließ sich leicht abwischen. Das sah nicht so aus, als wäre das auf dem Kunststoff ausgeblüht, sondern eher so, als hätte sich das dort aus der Luft abgesetzt.


    Das sieht so ähnlich aus wie bei dir. Ich weiß nicht was das ist, im ersten Moment dachte ich an Schimmel, aber das kann es auch nicht sein, kann sich ja von dem Plastik nicht ernähren. Sonst sind keine Spuren in der P101 drin, die nach Feuchtigkeit aussehen, außer der etwas flugrostige Kartenauswurf.

  • Das eine oder andere totgeglaubte Gerät bekommt da schon ein zweites Leben. ;)

    i-Telex 211230 dege d

    http://www.marburger-stammtisch.de


    Douglas Adams: "Everything, that is invented and exists at the time of your birth, is natural. Everything that is invented until you´re 35 is interesting, exciting and you can possibly make a career in it. Everything that is invented after you´re 35 is against the law of nature. Apply this list to movies, rock music, word processors and mobile phones to work out how old you are."

  • ich klinke mich mal in den thread ein, weil ich unsere Ausstellungs-P101 leider reparieren muss: das Netzteil macht Probleme, die 300 mA-Sicherung löst aus. Ich habe mir im Web schon die Finger wund gesucht, es muss ein "Olivetti Programma P101 technical manual" geben, leider ist nirgends ein Scan zu finden. Hat jemand die Unterlagen ?


    Zum Netzteil habe ich nur eine Zeichnung gefunden:


    OlivettiProgramma101_Schaltplan_Netzteil_P101.pdf


    die hilft mir aber nicht weiter, weil die dort gezeigte Sicherung m.E. viel größer als 300 mA sein muss (es gibt in der P101 drei Feinsicherungen: 300 mA, 500 mA und 6A, im Plan ist wohl die Umgebung der 6A-Sicherung gezeichnet)


    Gruß

    Roland

  • Die Dänen haben sich gemeldet: wg. Copyright haben sie mir leider keine Kopie der Unterlagen geschickt, mir aber mit einem Auszug (Schaltbild) sehr weitergeholfen.


    Roland


    Ich denke die Dänen nehmen aber auch gerne alles an, da ist den Dänen das Copyright so ziemlich egal.


    Ich sag es mal mit Obelix ... die spinnen die [bitte Text einfügen]

  • Ich berichte hier mal kurz, was bei meiner Programma 101 kaputt war. Die Lösung war für mich dann doch sehr überraschend:


    Problem: die Feinsicherung 300 mA nach dem Hauptschalter löst sofort aus.


    Ohne Schaltplan war die Suche schwer: alle Bauteile in dem Strang (Trafo, Netzfilter) sahen gut aus. Sehr mutig habe ich die 300 mA-Sicherung mal mit einem Amperemeter überbrückt und mit einem Regeltrafo die Spannung hochgefahren: bei 230 V mit 900 mA lief der Rechner wie gewohnt, kein Rauch, kein Qualm - ich war ratlos. 900 mA statt 300 mA, da müsste die Sicherung doch immer auslösen ?? Die 300 mA-Sicherung war korrekt, ein Aufkleber am Sicherungshalter bestätigte das nochmal. Außerdem lief der Rechner vor Wochen noch ohne Probleme.


    Dann bekam ich eine Schaltskizze des Netzteils:



    dass hier 117 V stehen ist nicht das Problem. Aber was ist "T" als Überbrückung der Sicherung ?? Es ist ein Thermoschalter am Kühlblech der 20V Spannungsstabilisierung. Er ist normalerweise geschlossen und öffnet bei Übertemperatur.


    Was hat sich Olivetti hier gedacht ? Eigentlich sollte in dem Strang nur die T-Sicherung liegen und bei Übertemperatur die Maschine abschalten. Man hat aber gemerkt, dass wegen Vibrationen die verwendete T-Sicherung immer mal wieder ganz kurz öffnet und die Maschine lahmlegt. Also hat man eine eigentlich zu schwache Sicherung parallel gelegt. Wenn T nur ganz kurz mal aufgeht, verhindert die Feinsicherung das Ausschalten, und bevor sie anspricht schließ T ja wieder. Löst T mal wirklich wg. Übertemperatur aus, brennt die 300 mA Sicherung durch und alles ist OK.


    Ein seltsames Konstrukt. Letztlich hatte bei unserer Maschine wohl wegen des Transports im Museum und Erschütterungen T ausgelöst. Die T-Sicherung hat einen winzigen Nippel, mit dem man sie mechanisch resetten muß. Dann wieder eine neue 300 mA Sicherung eingebaut und die Programma rechnet und druckt wie am ersten Tag !


    Roland