Alphatronic P3

  • Hallo miteinander,
    ich hab' eine alphatronic P3 ersteigert. Leider scheint sie etwas gelitten zu haben, die Karten lagen ziemlich wild durcheinander drin, noch fehlt der Sicherungshalter und damit die Hauptsicherung.
    Danach gehe ich vorsichtig weiter.


    Edit Toast_r: Link auf externes Bild gelöscht. Bilder bitte im Forum hochladen.


    In der Zwischenzeit habe ich mal die ROMs ausgelesen (hängt hier an) und alles wieder in einen Beitrag zum MAME-Emulator verpackt - ich hoffe, dass sich einer der aktiven Entwickler der Sache annimmt.


    http://forums.bannister.org//ubbthreads.php?ubb=showflat&Number=110034#Post110034


    Danke auch an helwie44 hier aus dem Forum für seine Alphatronic-Seite und die nette Kommunikation.


    Ich würde mich über Ergänzungen an Fotos und ROM-Dumps freuen, egal von welcher Alphatronic-Maschine.


    Ganz besonders interessieren mich:
    - Ein vollständiger Dump einer P1 und P2 (S, U), also 3x2KB ROM (vgl. helwie44), Tastatur-IC und Zeichen-ROM.
    - Bilder und ggf. Dumps von einer P4, hier besonders vom Festplattencontroller


    Nach dem Lesen der P30-threads bin ich mir nicht mehr sicher - ist das MS-DOS und das CP/M-86 für die P30 mittlerweile online verfügbar? Zur Emulation via MAME bräuchten wir dann wieder Dumps von ggf. vorhandenen ROMs (auf den Bildern von Toshi bzw. netmercer habe ich keine gesehen, dafür aber einen Haufen PALs, die man auch auslesen könnte).


    Gruß, Robert

    Files


    NCR DMV/Olivetti M20/ITT 3030/DEC Rainbow 100/Siemens PC-D/OlyPeople/MFA 8085/TA Alphatronic

    Edited once, last by rfka01: Ich habe zu spät gesehen, dass es eine eigene Alphatronik-Rubrik gibt ... lässt sich der Beitrag verschieben? ().

  • Klasse, vielen Dank!


    Software zur reinen P3 gibt es ja sowohl bei Kollege fritzeflink als auf dem FTP der Informatik der Uni Stuttgart, aber das MS-DOS habe ich bislang noch nirgends gefunden.


    LG Robert


    NCR DMV/Olivetti M20/ITT 3030/DEC Rainbow 100/Siemens PC-D/OlyPeople/MFA 8085/TA Alphatronic

  • Klasse, vielen Dank!


    Software zur reinen P3 gibt es ja sowohl bei Kollege fritzeflink als auf dem FTP der Informatik der Uni Stuttgart, aber das MS-DOS habe ich bislang noch nirgends gefunden.


    LG Robert


    Gern! Hast Du eigentlich noch andere Software für die Maschine? Roms sind bei mir eine Menge drauf, nur ausgelesen habe ich sie noch nicht.


    Gruß
    Stephan

  • Leider war bei meiner Maschine nichts dabei, von daher schaue ich jetzt erst einmal, wie weit ich mit der Hardware komme.Wenn ich die Sicherung habe, fahre sie probeweise hoch. Ich habe auch schon überlegt, ob ich sie mal an ein funktionierendes AT-Netzteil dranhänge, um zu sehen, was die Karten machen. An Software würde ich dann die Disketten von Stuttgart und von oldcomputers zurückschreiben.


    Zu Deiner Maschine: Je mehr Versionen von ROMs erhalten werden können, um so spannender und besser, finde ich.
    Du hast mal ein Bild von Deiner 8088 CPU-Karte gepostet, ist auf der 128K-RAM-Karte nur RAM, oder auch EPROM, PROM und PALs ...?
    netmercers "dritte" Karte hat ja ein Gewusel von Proms und Pals ...


    Gruß, Robert


    NCR DMV/Olivetti M20/ITT 3030/DEC Rainbow 100/Siemens PC-D/OlyPeople/MFA 8085/TA Alphatronic

  • Das MS - DOS und CPM-80 (nicht 86) wäre hier:



    ich habe EUCH im Blick... 8o


    und werde das mal auf oldcomputers festhalten ^^


    Aktuell kämpfe ich aber mit einem creatix Modem mit rockwell chips , 8-bit ISA und keiner Dokumentation am PIII portable Nachbau...

  • dlchnr, vielen herzlichen Dank für die Dumps und Scans!


    Hat denn jemand hier eine P4 oder P40?


    NCR DMV/Olivetti M20/ITT 3030/DEC Rainbow 100/Siemens PC-D/OlyPeople/MFA 8085/TA Alphatronic

  • Ich habe von MarNo84 eine P3 bekommen, die ich gerne zum laufen kriegen würde.
    Die Maschine läuft an, zeigt aber kein Bild (müsste doch eigentlich RESET zeigen, oder?), einige Zeit später drehen die Laufwerke an.
    Bei Betätigen der Reset-Taste gehen die Laufwerke aus, dann später wieder an.


    Welches ist denn nun die "definitive" Steckplatzbelegung bei der P3?


    Ich habe ja nun zwei Platinensätze zur Auswahl: #1 Video/Tastatur, CPU, 48K DRAM, 16K, Floppy
    #2 Video/Tastatur, CPU, 64K RAM, Floppy


    Wie gehe ich am besten vor, um die P3 wieder zum Leben zu erwecken? Ist ggf. jemand auf der Retropulsiv in Augsburg, den man am Abend zu einer Reparatursession bei einem Gläschen Bier einladen könnte?


    Gruß, Robert


    NCR DMV/Olivetti M20/ITT 3030/DEC Rainbow 100/Siemens PC-D/OlyPeople/MFA 8085/TA Alphatronic

  • Hallo;
    Schön wenn man mehrere Sätze von Baugruppen hat. Um die Maschine in Gang zu bekommen,
    müssen aber einige Karten genau auf dem SLOT stecken. Sonst ist das so - etwas wie im Lotto.


    Einen Überblick der Slotbelegung ist hier zu finden.
    P-30 mit MSDOS 2.0
    Um die Komponenten für den MSDOS- Betrieb nicht genutzt werden - können fehlen.


    Bei einer P3 ist eigentlich das Motherboard identisch für eine P30. Aus einer P30 wurde einfach ein weiterer
    Steckkarten - Satz ( 8088 CPU, RAM 128, ++?, Grafikkarte) zugefügt und evtl. Software TA MSDOS.


    Aus den Forum - Beiträgen könnten Toshi und netmercer den Steckplan mal hier einstellen.
    Die betreiben ja:
    a) TA cp/m 8085 - P3 Konfiguration und
    b) TA MSDOS 8088 - P30 Konfiguration


    Aus diversen Beiträgen könnte eine P3 Konfiguration so aus meiner Erinnerung arbeiten.

    #1 Keyboard /CRT
    - muss hier auf #1 sein, Keyboard und Display Anschlüsse


    #6 CPU8085 4k EPROM mit 8251
    #7 Floppy Controller

    #8 64 kB
    dyn RAM ( könnte evtl. #3 ..#5) weil nur die A und B Reihen den MC80 BUS nutzt
    Der Grund für gewisse Slot# ist die C Reihe der 96 polig. VG Steckverbindungen über das Motherboard.
    Dort führen Verbindungen zu den Komponenten wie DISPLAY, V24, KEYBOARD, FLOPPY-LW ...und was noch?


    Startbedingung:
    Ist eine P3 Maschine mit funktionierende Steckkarten und Verbindungen zum Keyboard und dem Displayvorhanden sind,
    würde ich zunächst keine Diskette ( TA cp/M ..) in das Bootlaufwerk (links als 1 oder A: später) einlegen.
    Bei POWER ON oder RESET sollte folgendes ablaufen:
    Das P3/ P30 MOS wird bei 0000h gestartet. Einige Init-Sequenzen und je nach MOS - wird ohne Meldung (bei HALS..) oder nur mit RESET (CAAP..) abgearbeitet.
    Nun wird direkt vom Bootdrive der erster Sector in den Speicher auf (4000H) geladen und gestartet.
    ABER ist keine Diskette im Drive, sollte sich nach einiger Zeit (Floppy- Wiederholungen mit ERROR) der MOS Monitor je nach bestücktem EPROM melden. Und nach dem .(Punkt) ist die Tastatureingabe frei. eine Taste irgenwas - mal zu Test - kommt eine Fehlermeldung und BELL. Klares Signal das die Tastatur arbeitet.


    Um eine Keyeingabe mal schnell zu prüfen wäre sowas brauchbar.
    .D4000,4080(cr) -- der Punkt vom MOS die Eingabe ist Dump in HEXA.
    Also erst wenn sowas geht - macht es Sinn, mit einer Diskette (TA cp/m) zu versuchen.
    Denn DISPLAY und KEYBOARD arbeiten.


    Aus dem rfka01 Beitrag - wird ein Floppylaufwerk ja angesprochen. aber!
    Zunächst bitte DISPLAY - Bereich abklären:
    Daher ist noch was beim DISPLAY (Slot# oder Kabelverbindung, Monitor selbst - Einstellungen - Kontrast, Helligkeit ..? ?) nichts zu sehen.


    Viele Grüße und viel Erfolg
    Helwie44

  • Hallo,


    da ich direkt darauf angesprochen wurde, möchte ich die mir bekannten und funktionierenden Anordnungen der Baugruppen in einer alphaTronic P3/P30 kurz darstellen:
    Wie helwie44 schon beschrieben hat, laufen die Karten für den 8-Bit Teil meiner P30 in folgenden Slots:
    #1: CRT/Keyboard Kombi (muß hier sitzen)
    #6: CPU 8085
    #7: Floppy Controller
    #8: 64K RAM


    Die Slots sind nicht alle gleichartig, so daß nicht jede Karte in jedem Slot läuft. Slot #9 hat eine Sonderstellung (I/O-Slot). Von hier besteht eine Verbindung zu einem 37-poligen SUB-D Stecker an der Rückseite der P3/P30, um Karten zu verwenden, die über Schnittstellen nach außen verfügen (z.B. IEEE488 Karte).


    Da Du in Deiner Platinensammlung auch sehr frühe RAM Karten (48K, 16K) hast, nachfolgend eine Baugruppen - Anordnung mit der frühe P3 von TA ausgeliefert wurden:
    #1: Keyboard oder CRT/Keyboard Kombi
    #2: CRT (nicht bestückt, wenn CRT/Keyboard Kombi in #1)
    #4: 48K RAM
    #5: 16K RAM
    #6: CPU 8085
    #7: Floppy Controller


    Würde mich sehr freuen eine weitere funktionierende P3 begrüßen zu dürfen. :thumbup:


    Überprüfe an Deinem Monitorausgang mal auf Wackler/Unterbrechung an der RCA Buchse, Verbindung zu Slot #1. Denn wenn beide CRT Karten kein Bild machen, glaube ich nicht, daß beide hinüber sind.


    Viele Grüße
    netmercer

  • Hallo netmercer und Herr Wiertalla,
    danke für die Informationen, damit komme ich ein gutes Stück weiter - nicht mehr heute abend, aber zumindest kann ich dann eine Ursache ausschließen.


    Gruß, Robert


    NCR DMV/Olivetti M20/ITT 3030/DEC Rainbow 100/Siemens PC-D/OlyPeople/MFA 8085/TA Alphatronic

  • Alphatronic P3 ... später P2...bis P30 Emulator-Gerippe

    Hallo,

    mit viel Einsatz hat rfka01 schon Entwickler auf dem MAME / MESS Emulationsystem angestoßen. Ein Gerippe in C++ für einen Alphatronic P3 ist schon vorhanden und jeder hat hier die Möglichkeit mit zu arbeiten.


    So waren meine ersten Tests an der P3 Emulation.


    (Huch beim Erstellen waren hier zwei Fotos - leider aber nach dem SENDEN lLeerzeile.)

    (Als 2. Versuch mit Dateianhang - was zu sehen? oder..)


    Es ist noch harte Arbeit und in die kleinen / großen Instruktionen muss man sich eingraben..

    Neue ROM/EPROM Files mit Dank von rfka01 .


    (Huch auch Bild weg—-)

    Aber evtl. mit Dateianhang.


    Der zweiter Schritt - nach einer kleinen C++ Quelle geändert ( helwie44 ). Start der ROM/EPROMs ohne Floppy-EMU Driver von rfka01 auf dem WIN7 Laptop zu sehen - nun MOS P3 Meldung mit dem Punkt. Es sind noch jede Menge an Baustellen zu bearbeiten.


    Grüße und viel Erfolg auf viele Mitarbeiter.

    Helwie44

  • Links Probleme bei gewissen Forumbeiträgen ?


    IN EINEM OBEREN BEITRAG von rfka01 erstellt wurde, wird im neuen Forum offenbar nicht einige externe Links zum ZIEL erreichen!


    Warum ist das so:

    In diesen Beispiel ist ein „&“ vorhanden.

    Aber dort wird „... &“ in den Browser übertragen. Also Kasperkram - wenn man Glück hat, landet man in einer NOT found page - also eine Ersatzseite vom Ziel-WEB.

    Erst wenn man die Zeichen „amp;“ entfernt (Zieledit) ist - arbeitet der Link richtig.

    http://forums.bannister.org//ubbthreads.php?ubb=showflat&Number=110034#Post110034


    Danke auch an helwie44 hier aus dem Forum für seine Alphatronic-Seite und die nette Kommunikation.

    Möglich bin ich nicht hier richtig - aber die Forums Profis könnten es sicher an die richtige Stelle senden.

    Vielen Dank und Grüße

    Helwie44

  • Ja der zuvor abgelegter Link arbeitet richtig den rfka01 neu erstellt wurde: Nur & enthalten, richtiges Ziel!


    Wie wurde der Link generiert.

    Ich helwie44 habe das hier so mal getestet.

    A) neu von der Webbrowser Linkzeile kopiert:


    http://forums.bannister.org//u…&Number=110034#Post110034

    (Hex Fumo geprüft)



    B) den Link aus dem Forumsbeitrag jetzt kopiert.


    Im Zitat und im ersten Beitrag sind dort. & enthalten. So wird nicht ein Aufruf funktionieren.

    Fazit: alte Links könnten bei Sonderzeichen evtl. nicht jetzt arbeiten, oder!?

  • helwie44 und ich arbeiten ja fleißig dran, die Alphatronic-Maschinen in der MAME-Emulation zum Laufen zu bringen, mit kräftiger Unterstützung der MAME-Entwickler.



    Die P3 bootet schon mal, wir kämpfen uns gerade durch die Tastenzuordnungen. Darum meine Frage bzw. Bitte:


    Hat jemand ein Progrämmsche für die P3, das die Funktions- bzw. Richtungstasten nutzt? Vielleicht ist ja was auf den öfftenlich verfügbaren Diskettenimages drauf und ich habe es bislang noch nicht entdeckt. Dank funktionierender P30 könnte ich die Tastenbelegungen direkt vergleichen.


    Danke und Gruß

    Robert


    ... der sich schon darauf freut, im Januar eine P1 dokumentieren und auslesen zu dürfen :)


    NCR DMV/Olivetti M20/ITT 3030/DEC Rainbow 100/Siemens PC-D/OlyPeople/MFA 8085/TA Alphatronic

  • Hallo rfka01 und Px Owner...


    Ich habe eine P3 / P30 DISKETTE ( SYS4-312.imd) von netmercer ( herzlichen DANKK !) in A: bootbares cp/m mit Entwicklungsprogrammen ( M80, DTT, L80, DU und +++).

    Bekannt ist ja auch die spiele.imd DISKETTE von A: bootbar.


    Nun habe ich auch eine Diskette ( SYS2-25.IMD) von netmercer mit wirklich guten TA P3 / P30 cp/m Hilfs-Testprogrammen !

    Leider ist die Diskette SYS2-25.IMD  nicht im Laufwerk A: startbar ( ?? Kopierschutz ??) - aber vom Laufwerk B: sind alle Programme ladbar!

    Zur Verwirrung sind aber einige Test-Hilfsprogramme als USER 1 oder USER 2 gespeichert! Die meisten Programme hier habe ich als KOPIE in den


    USER 0 geändert. Diese DISKETTE habe ich als SYS2-25.hIMD.imd genannt!


    Hier auf Laufwerk B:SYS2-25.hIMD.imd befindet sich ein Programm > TASTESTN.com



    Die Tasten F6 und ESC sollten arbeiten um die Bereichtests zu BEENDEN.

    Bei Fehlermeldungen mit (BELL.. arbeitet ja schön) die Funktionstaste (Cl) -> (im Moment auf PC rechts Ctrl) gelegt.

    Die begefügten .imd sind nur zum hochladen mit .txt erweitert. ( Selbst .txt entfernen) und ab geht die Post.


    Frohes probieren...

    Helwie44