Vorstellung Z1013 mit Gehäuse der "Messe der Meister von Morgen" von '87

  • Hallo Zusammen,


    vorgestern habe ich endlich den Z1013 von  MaikB bei nalkem abgeholt. Nochmal vielen Dank an Hobi für die Abholung und nalkem für die Lagerung.:):thumbup:


    Der Z1013 ist in einem extra für die "Messe der Meister von Morgen" von '87 gebauten Gehäuse untergebracht. Das Gehäuse ist aus Holz und handgefertigt, aber trotzdem sehr sauber gearbeitet und auch optisch sehr schön.


    Der Computer ist ein Z1013.01 mit 16KiB RAM von Ende 1985/Anfang 1986. Installiert ist zusätzlich der Baugruppenträger Z1013.50, das Stomversorgungsmodul Z1013.40, zwei ROM-Module Z1013.20 und ein RAM-Erweiterungsmodul von robotron Dresden.

    Weiter geht's im nächsten Post...

    Edited once, last by Magnus: Korrektur: Computer ist kein Z1013.16 sondern ein Z1013.01, da er nur ein 2KiB U2616 PROM besitzt und nicht wie beim Z1013.16 einen 4KiB U2632 ().


  • Neben der im Gehäuse verbauten Folientastatur gibt es noch eine Tastatur mit gleichem Layout aber richtigen Tasten und eine Riesa-Alphatastatur mit QWERTZ-Layout. Diese besitzt auch schon die benötigte Ansteuerbaugruppe, um die andere Tastaturmatrix an die des Z1013 anzupassen. Der kleine Nachteil ist nur, dass der Z1013 nicht mit den für die externen Tastaturen benötigten EFS-Steckverbinder ausgestattet ist, das müsste ich dann nachrüsten.


    Aber bevor das kommt möchte ich erstmal gucken ob der Computer überhaupt funktioniert. Bevor ich den Computer aber blind einschalte habe ich zunächst die aus dem Trafo kommenden Spannungen überprüft und dannach nur das Stomversorgungsmodul angeschlossen.

    Die Spannungen sind glücklicherweise alle einwandfrei. An den Fernseher habe ich den Computer allerdings noch nicht angeschlossen, den möchte ich vorher auch nochmal einer optischen Untersuchung unterziehen. Sobald ich das getan habe gibt's hier ein Update. :thumbup:


    Beste Grüße,

    Magnus

  • Also irgendwie bekomme ich den Fernseher nicht zum laufen... Ich habe einen Robotron combi-vision RF 3301. Nach dem Einschalten ist ein hochfrequentes Fiepen zu hören, Hochspannung ist also da. Allerdings ist auf dem Schirm nichts zu sehen, egal welches Band, egal welcher Kanal. Auch kein Rauschen (ich weiß nichzt, ob man Rauschen sehen soll/kann oder nicht, aber vorhanden ist es nicht). An Helligkeit und Kontrast habe ich auch wie wild rumgeschraubt, das hat leider auch nichts gebracht. Für den Z1013 sollte man ja Band 1 und Kanal 3 einstellen. Leider erscheint auch dann nichts auf dem Monitor.

    Zudem wird mit Zeit das Fiepen ein bischen lauter, und es fängt an zu knacken. Kann es sein, dass der Zeilentrafo einen Schuss weg hat?


    Aber nicht nur schlechte Neuigkeiten:

    ich habe provisorisch mal das BAS-Signal abgefangen und an einen anderen Monitor gestöpselt. Erfolg!

    Ab Adresse 8000H wird anscheinend ein Schachprogramm gestartet, ich habe aber keine Ahnung wie man das verwendet. Ich hatte auch versucht mit "J C000" BASIC zu starten, leider hängt sich der Computer immer auf.

    Und bei der Gelegnheit muss ich mich mal über diese grauenvolle Folientastatur auslassen... Ständig schreibt das Sch***teil zwei Zeichen auf einmal... >:(

    Bin ich froh, dass eine bessere Tastatur beiliegt, die werde ich demnächst mal ausprobieren. Leider müsste ich dazu vorne im Gehäuse ein Loch für den Stecker machen, da der Stecker zu lang ist und man das Gehäuse sonst nicht mehr schließen könnte.

  • Und bei der Gelegnheit muss ich mich mal über diese grauenvolle Folientastatur auslassen... Ständig schreibt das Sch***teil zwei Zeichen auf einmal...


    DAS ist ein wesentlicher Fehler aller sogenannten Kleincomputer. Das wird zwar bißchen besser in der Reihenfolge


    Z1013 < KC87 < KC85


    aber das Problem haben alle. Ein C64 Keyboard ist zwar eigentlich auch kein Highendteil und ganz gut für Sehnenscheidenentzündungen (besonders in der Urverson mit hohem Gehäuse), aber die Tasten erkennen zuverlässig den Tastendruck.


    Sehr zuverlässig sind dagegen die Selbstbautastaturen mit den Eisenbahnschaltern ...

    da scheiterts dann aber oft am Layout.

  • Bin ich froh, dass eine bessere Tastatur beiliegt, die werde ich demnächst mal ausprobieren. Leider müsste ich dazu vorne im Gehäuse ein Loch für den Stecker machen, da der Stecker zu lang ist und man das Gehäuse sonst nicht mehr schließen könnte.

    Wie wäre es denn mit einem neuen kurzen Stecker und einem langen Flachbandkabel, was dann oben aus der Modulschachtöffnung rauskommt.


    Das Gehäuse zu zersägen halte ich bei einem dermaßen einzigartigen Prototypen für etwas sehr eigenwillig - schon die Idee allein ...

  • Bin ich froh, dass eine bessere Tastatur beiliegt, die werde ich demnächst mal ausprobieren. Leider müsste ich dazu vorne im Gehäuse ein Loch für den Stecker machen, da der Stecker zu lang ist und man das Gehäuse sonst nicht mehr schließen könnte.

    Wie wäre es denn mit einem neuen kurzen Stecker und einem langen Flachbandkabel, was dann oben aus der Modulschachtöffnung rauskommt.


    Das Gehäuse zu zersägen halte ich bei einem dermaßen einzigartigen Prototypen für etwas sehr eigenwillig - schon die Idee allein ...

    Verstehe ich - ich sträube mich auch noch davor. das Problem ist, ich kann mir nicht vorstellen wie es anders möglich wäre... Da ist wirklich kein Platz damit ein Steckverbinder noch ins Gehäuse passt.

    Selbst wenn man die Hebelchen für den Flachbandverbinder weglässt, sitzt der Verbinder schon im Gehäuseoberteil. Und die Gehäusewand ist so breit wie die untere Holzkante, nicht die obere.

    Das blöde: Laut diesem Bild war wohl mal gedacht da noch ein Loch reinzusägen für den Stecker, leider hat das bei diesem Gehäuse keiner Gemacht.


    Was gäbe es denn sonst für Möglichkeiten den Port nutzen zu können, aber das Gehäuse nicht zu verändern? Hat jemand eine Idee? :grübel:

  • Warum sollte man nicht den EFS Stecker vorn einstecken?

    Wenn die Aussparung für gemacht wird, wird niemand bemerken, dass sie womöglich nachträglich vorgenommen wurde.


    Falls es schlecht gemacht wird, sieht's hält nicht mehr so schön aus.


    Notfalls kommt der Stecker oben drauf, anstelle der FF-Tastatur.


    Btw: das Schachprogramm sieht ein bisschen nach Chessy aus. Der BASIC Interpreter funktioniert bei mir auch nicht. Ich hatte Mal kurz reingeschaut, verstehe aber nicht was da so passiert.

  • Wenn, dann würde ich mir auf jeden Fall Mühe geben das so ordentlich wie möglich zu machen. Das schwierigste dürfte sein, eine passende Farbe zu finden die zum Rest des Gehäuses passt.

    Das blöde ist, ich müsste auch von der Gehäuseunterseite ein bischen was wegsägen damit der Stecker auch wirklich passt. Spätestens das müsste man dann auch wieder bemalen, sonst sieht man das Holz.

  • Was wäre wenn Du den abgewinkelten Pfostenverbinder durch einen senkrechten austauschst?

    Reicht dann der Platz nach oben?

  • Was wäre wenn Du den abgewinkelten Pfostenverbinder durch einen senkrechten austauschst?

    Reicht dann der Platz nach oben?

    Da ist das Problem, dass der Steckverbinder zwar zweireihig ist, aber die Löcher auf der Platine einen Abstand von drei Reihen haben. Und der Platz nach oben reicht auch nicht aus, um den Steckverbinder vom Adapterkabel darauf zu stecken.

  • Ich würde ja erstmal schauen, was für ein Typ Tastatur das ist.


    Je nachdem benötigst Du nämlich nur die obere Reihe der Anschlußbuchse + 2 zusätzliche aus der anderen Reihe


    http://www.z1013.de/a2_tastatur.html

    (auch mal nach den anderen Keyboards dort schauen)


    In dem Fall wäre evtl. das einfachste die Kabel unten direkt mit an die Stellen anzulöten, wo die normale Folientastatur dranhängt. Diese Lötpunkte gehen ja alle auf die obere Reihe der Buchse. Die 2 einzelnen Anschlüsse sollte man dann auch direkt an den Punkten anlöten können, wo die Buchse untere Reihe angebracht ist.


    Damit würde man sich die Sache mit dem Stecker komplett sparen. Man muß halt sauber arbeiten und darf keine Verbindungen an dem Tastaturkonnektor unten auf der Platine herstellen, wo keine sein dürfen.

  • Den Tastatur-Typ kennne ich schon:

    Es ist eine Riesa Alphatastatur mit exakt dieser Prozessor-Ansteuerung

    Das Adapterkabel habe ich auch schon überprüft, das passt auch.


    Aber nochmal ein Kabel direkt and den Computer löten finde ich auch blöd, dann hängt schon wieder ein Kabel ständig am Computer. Da die Kabellänge auch nur um die 50cm ist, müsste man das Kabel vorne durchs Gehäuse führn, das ginge dann leider auch nur durch das schon vorhandene Loch für X4.

    Letzendlich fände ich das dann aber auch irgendwie etwas "dahingepfuscht". :(

    Ein Steckverbinder wäre da irgendwie die elegantere Lösung.:/

  • Vielleicht muß es ja gar kein Stecker sein, sondern es reicht eine "Pinleiste". Bei den Maßen muß man eh bißchen aufpassen, wegen den 2.5mm Abstand. Aber eigentlich würde davon dann ja i.P. eine Leiste reichen und das Flachbankabel könnte ja auch nach hinten unter dem Board verlegt werden. Wenn da der Platz immer noch nicht paßt, kann man ja eine gewinkelte Pinleiste nehmen oder das Kabel von hinten kommend anlöten - also so, daß die normale flache Pinleiste nach hinten zum Kabel zeigt (blöd zu beschreiben, halt einfach genau andersherum angebracht als man das üblicherweise machen würde).


    Evtl. tut es ja auch sowas hier

    https://www.computerkabelversa…rbinder-14-PIN-Flach.html


    braucht man vermutlich eh 2 davon um die 2.54 vs. 2.5 auszugleichen und man würde halt mittig die Clips abfeilen und evtl. dann kleben damit es mit dem Kabel zusammenhält.