Commodore PC 10/20 - Hercules Problem

  • fanhistorie - Ja, Landmark zeigt bei allen Rechnern den Timer Channel 1 Error an


    Bezgl. Windows hat 3.0 als Systemvoraussetzung 640kb RAM und einen 8088er - das wird also erfüllt. Auf YouTube gibt es auch Videos zu sehen :)

    Und aus einer späteren 3.0 Revision wurde die 8088 Unterstützung gestrichen

  • Die Diskussion ist ein bisschen lustig. Also, mir geht es darum, dass was technisch machbar ist zu machen :D Das bringt mir den Spaß- auch wenns langsam läuft. Davon ab ist die Tatsache das Windows nicht läuft ein sicherer Indikator dafür, dass noch etwas defekt ist. Da ich das Problem auch auf dem Commodore 286er habe bin ich mir mittlerweile eigentlich extrem sicher, dass es am fehlenden Akku bzw. dein Leitungen dort liegen muss. Ggf. irgendwelche kaputten Timings alternativ.


    Auch Windows 2.0 läuft nicht bzw. startet mit fröhlichen Tönen und beendet dann im DOS Prompt.


    Ich lasse derzeit das gesamte Mainboard in China replizieren, mit dem Ziel am Ende Gerber Files, eine aktuelle Ersatzteilliste und natürlich die PCB Schemata zu haben. So kann man das Board entweder neu herstellen bei Bedarf und / oder, was auf die Dauer natürlich wesentlich interessanter sein dürfte, selbst modifizieren und erweitern. Mal schauen wie das läuft.

  • Die Diskussion ist ein bisschen lustig. Also, mir geht es darum, dass was technisch machbar ist zu machen :D Das bringt mir den Spaß- auch wenns langsam läuft. Davon ab ist die Tatsache das Windows nicht läuft ein sicherer Indikator dafür, dass noch etwas defekt ist. Da ich das Problem auch auf dem Commodore 286er habe bin ich mir mittlerweile eigentlich extrem sicher, dass es am fehlenden Akku bzw. dein Leitungen dort liegen muss. Ggf. irgendwelche kaputten Timings alternativ.


    Auch Windows 2.0 läuft nicht bzw. startet mit fröhlichen Tönen und beendet dann im DOS Prompt.


    Ich lasse derzeit das gesamte Mainboard in China replizieren, mit dem Ziel am Ende Gerber Files, eine aktuelle Ersatzteilliste und natürlich die PCB Schemata zu haben. So kann man das Board entweder neu herstellen bei Bedarf und / oder, was auf die Dauer natürlich wesentlich interessanter sein dürfte, selbst modifizieren und erweitern. Mal schauen wie das läuft.

    Mal versucht die speziellen PC-Typen bei der WIndowsinstallation anzugeben? Ist ja kein IBM-PC.

    Mit Checkit mal Speichertest und co durchlaufen lassen? HDD ok?


    Ohne die entsprechenden Chips bringt dir das sehr wenig.

  • Guten Tag

    lenny2207


    Wegen der damaligen Diskussion wegen dem evt doch "nötigen" Akku (Cmos RAM im RTC) hab ich mit "meinem bescheidenen" Halbwissen bei dem Board von Dsdata für diesen Typ mal vorläufig mich entschieden,


    Ist ein NI-MH, wie lange dieser tatsächlich funktioniert ist nicht vorhersehbar, weil er konstant geladen wird, (funktionierte zumindest mal die letzten paar Wochen)


    da wir aber noch kein Memory Refresh haben, warte ich derzeit auf weiteres Material (74S) Bausteine,

  • PC-Rath_de Doch, ist eigentlich ein 100% kompatibler. Wenn auch von Commodore, aber sind sind ansonsten stinknormale PCs (ok und zur damaligen Zeit hat ja quasi jeder irgendwelche Extrawürstchen gebaut) - aber ich hatte ja eben Windows schon laufen gehabt.


    Chips kriegt das Board natürlich auch.......


    fanhistorie - Das ist sehr interessant! Lass uns bitte unbedingt testen, was euer Gerät dann zu Windows 3.0a von Winworld sagt, kann man da ja einfach runterladen.


    Die gepflegten sauberen Boards sehen einfach immer super aus.

  • Spätestens mit der Grafikkarte und ihre Eigenheiten, die sich durch die 3-fache Kompatibilität ergibt, ist er nicht 100% IBM-PC-Kompatibel.

    fanhistorie läuft den Windows 2/3 auf deinen/m PC10-III?

  • Guten Abend

    PC-Rath_de

    lenny2207


    Ihr liest einfach nicht aufmerksam, meine zahlreichen Beiträge

    ( manchmal wohl nicht "einfachen" nachvollziehbaren, oder auch unmissverständlichen Gedankensprünge angst,


    Kurzfassung

    das Board von Dsdata war ein Totalschaden ( Batterielauge auf den Bausteinen, abgefresse Pins an den RAMs beschäftigte Vias (beschädigte Durchgangsverbindungen).....,



    mit dem Landmark Eprom kein Lebenszeichen, keinerlei Monitoransteuerung


    Dsdata hat vorab auf seinem Board noch den Quarz, Mehrere Kondensatoren ersetzt, gereinigt,


    Aktueller Stand :

    Nach seiner Freigabe habe ich soweit die doch zahlreiche Batterielauge beschädigte Leiterplatine, Bauteile durch eine Essig Essenz soweit versucht wie möglich zu neutralisiert


    Nachdem ich Verifiziertrs RAMs aus einem anderen Mainboard, original FE2010A, geflickte provisorische Leiterbahnen angelötet,

    getauscht habe,

    Initialisiert nun soweit das Board (umgangssprachlich ausgedrückt)

    läuft nun der Landmark soweit ab, Monitoransteuerung funktioniert, Bild wird dargestellt, der Timer Fehler (wie bei Lenny) auch anzeigt, aber bei Memory Refresh dann stehenbleibt,


    Da ich leider nicht aussagen kann, ob der ausgetauschte FE2010A auch korrekt funktioniert,

    wurde zuletzt bei mehreren Bekannten angefragt, ob sie diesen überprüfen verifizieren können in einem funktionsfähigen Board,

    im Gegenzug habe ich soweit noch die ggf. nötigen 74S Bausteine bestellt, (falls es doch ein Timing Problem ist


  • Ich hatte jetzt eigentlich über Lennys Windows-Problem geredet und ging davon aus, dass du als PC10-II Spezi auch selber einen/welche hast?

  • Nein,

    ich selbst habe mir erst zuletzt auch einen defekten PC10-III zugelegt als die Diskussion wegen dem FE2010A, ggf dem PR Ersatztyp hier aufkam, ob dieser auch im Pc10-III funktioniert zuverlässig funktioniert,

    Zuletzt hatte ich auch noch die Angebote von Jotrin gepostet, aber auch dort kam nur die Rückinfo aus dem Forum "zu teuer"


    Natürlich hätte ich auch einen von von deinen dir abkaufen können, die du mir damals anbotest als wir uns über die Funktionsweise RAM Parity uns unterhielten,

  • Nein,

    ich selbst habe mir erst zuletzt auch einen defekten PC10-III zugelegt als die Diskussion wegen dem FE2010A, ggf dem PR Ersatztyp hier aufkam, ob dieser auch im Pc10-III funktioniert zuverlässig funktioniert,

    Zuletzt hatte ich auch noch die Angebote von Jotrin gepostet, aber auch dort kam nur die Rückinfo aus dem Forum "zu teuer"


    Natürlich hätte ich auch einen von von deinen dir abkaufen können, die du mir damals anbotest als wir uns über die Funktionsweise RAM Parity uns unterhielten,

    Eigentlich wollte ich dir ja das defekte Board für einen Zehner oder so geben, aber das hatten wir ja schon geklärt.

    Meine sind alle weg. Ich selber würde sie jetzt nicht zu dem Preis kaufen, wenn ich wüsste, wie man die repariert...

  • Stimmt,

    aber auch bei deinem Board war nicht sicher, ob der FE2010A noch, überhaupt zuverlässig funktioniert,


    Erschwerend kommt noch hinzu, das der interne Landmark Test Ablauf nur bruchhaft dokumentiert ist, und ich nicht weiß, wie und wann der Memory Ablauf im Detail funktioniert,


    Auf den Hinweis von Schroeder würde ich daher alle 74S (3ns) Bausteine austauschen, keine LS, sondern es muss ja einen Grund geben, warum damals die schnelleren, aber auch teureren Bausteine eingesetzt wurden,

  • Weil LS im Speicherbus etwas lahm ist. Kannst ja auch 74F einsetzen, die zumindestens noch erhältlich.