Geschichte eines Alphatronic P2, der eine Reparatur (oder mehr) versucht.

  • Congratulations!


    I wonder why did they need two reset circuits... With a 555, like the PET/CBM it may have been better.

    I know that it would have been better for you to receive it working, but as you received it faulty you had to research. You have provided me with a lot of useful data that will be helpful sooner or later.


    Good job!


    EDIT:


    Beware the exploding caps!:thumbup:

    When I tried to list all retro systems I have at home, the "The message is too long, must be under 500 characters" error appears! :lol:

  • <

    Leider gibt es beim P3 System weder den Pieps, noch folgt ein Boot-Versuch mit Zugriff auf die Disketten (es ist egal ob Disketten eingelegt sind oder nicht). Ich habe schon versucht, blind ein paar Zeichen einzugeben bzw. mit "B" zu booten. Das hat leider nichts bewirkt (keine Änderung der Bildschirmausgabe, kein Zugriff aufs Laufwerk). Allerdings bin ich nicht sicher, ob "B" beim P3 überhaupt zulässig ist. Werde es noch mit "D" probieren.

    Den Keyboard Controller Chip habe ich testweise schon getauscht, das hat keinen Unterschied gemacht. Ich habe leider keinen alternativen CRT Controller Chip herumliegen, die P2 verwendet ja formal nicht das gleiche Modell (TMS9927 vs. TMS9937). Auf Basis der Datenblätter (http://bitsavers.trailing-edge…ers_Data_Manual_Jun82.pdf) konnte ich allerdings die Unterschiede zwischen den beiden Controllern nocht nicht erkennen.

    Bei meinen Tests im P2 habe ich auch die P3 Disk Controller Karte eingesetzt, das hat aber keinen Unterschied gemacht. Ob sich die Ready-Belegung zwischen P2 und P3 unterscheidet muss ich noch prüfen.

  • Ja, prima overCLK - das Endergebnis liefert nun ein sicherstes

    RESET-SIGNAL nach dem POWER ON von dem externem PSU.


    Was ist noch an welche Probleme zu lösen sind?

    Danke helwie44.


    Nächster Schritt wird der Speicher sein. Ich will alle die Tantal-Kondensatoren wechseln.

    Damit muss ich zuerst identifizieren, welche Kapazitäten und Spannungen die ursprünglichen haben.

    Vielleicht brauche ich da Hilfe. Besonders mit dem Kondensator, der verbrannt wurde. ;-)

  • Actually there is only a reset circuit (reset-in to the CPU). The problem is that different boards make different "contributions" to it, changing the characteristics of the RC net. I guess that with the original power supply or maybe with the original conditions, everything works ok, but the original RC value is already a bit too low compared with what is recommended in the 8085 documentation.


    I'm no expert into these designs, but in my opinion maybe the open-collector last inverter with its own pull-up makes not a lot of sense. This should be in some way isolated from the CPU-Board reset circuit but with the current design, any board that wants to be able to reset the system, will put a resistor in parallel to the reset RC network, hence making the rise-up time shorter and shorter.


    I'm glad you find useful the data I'm able to slowly extract from the Alphatronic system. To be honest, if the computer worked properly day one, I would have tested some CP/M programs on it and it will be now sitting there, probably I wouldn't have learn anything from it. :-)

  • Can somebody kindly tell me what is the value of C45 in the 48K board? Board model is CAAC09, and it is the capacitor in the left-down corner of the board. (The one circled in the picture).


    Thanks a lot!


  • Zur TA 48 kB dynamic memory card:

    In dem P2 Beitrag von gpospi und anderen USER im FORUM sind hilfreiche Infos zum Vortest von Baugruppen und auch zu den Kondensatoren der je 16 kB Reihen mal drei - also zu 48 kB.

    Ich denke es wird nicht notwendig alle Kondensatoren zu tauschen.

    Vielen Dank helwie44. Trotzdem denke ich, dass es besser wäre, wenn ich alle die Tantalkondensatoren tausche. Meine Feuer Erfahrung war überhaupt nicht angenehm. :abrauch:

  • Kondensatoren gekauft…

    Leider gibt es nicht im Geschäft alle, die ich brauche. Deshalb habe ich nur einige gekauft, besonders die Kondensatoren, die weniger Spannung aushalten können.


    Nachdem ich den verbrannten Kondensator getauscht habe, die Speicher-Karte eingesteckt und den Computer eingeschalt, habe ich gesehen, dass das Tastatur-Licht nur eine Sekunde leuchtet hat. Ich habe sofort alles ausgemacht um zu finden, dass es noch einen Kurzschluss gab. Ich habe die drei 16uF, 10V Kondensatoren ausgelötet: Es gab einen anderen, der sich kurzgeschlossen wurde. Ich habe die Entscheidung getroffen, alle drei zu tauschen.


    Jetzt dauert die Reset-Meldung länger, als ob der Computer den Speicher geprüft hatte. Endlich habe ich diese Linie bekommen:


    $1976 4010 BFFF


    Das sieht aus sehr gut! Aber, was mit der 16K Speicher-Karte? Ich habe die auch eingesteckt und jetzt habe ich diese Meldung bekommen:


    $1976 4010 FFFF


    :hüpf:


    Nächste Haltestelle: Das Laufwerk-Kontroller. :coffeepc:

  • overCLK herzlichen Glückwunsch zur Wiederbelebung Deiner Maschine!


    Wäre es möglich, dass Du die ROMs sicherst (dumpst) und zur Verfügung stellst?


    Bei den P2's die ich bislang in den Händen hatte, waren es drei Firmware-ROMs zu je 2KB (bei Dir glaube ich gelesen zu haben, dass es zwei sind, 4KB und 2KB), ein Zeichen-ROM mit 2KB und der Inhalt des Tastaturcontrollers (z.B. 8041) mit 1KB.


    Herzliche Grüße

    Robert

    Files


    NCR DMV/Olivetti M20/ITT 3030/DEC Rainbow 100/Siemens PC-D/OlyPeople/MFA 8085/TA Alphatronic

  • Ich habe im Laufwerk-Kontroller auch einen Kondensator getauscht (der war kurzgeschlossen)


    Mit der Laufwerk-Karte eingesteckt ist etwas anders:


    - An der Anschaltung sieht es aus, dass nichts passieren. Vielleicht die Reset-RC-Glied hat sich noch mal geändert, wenn die Laufwerk-Karte eingesteckt ist?

    - Wenn ich die Reset-Taste drückt, dann fängen sich die Laufwerke Motoren um zu drehen.

    - Nach etwa 10 sekunden, kommt die Reset-Meldung und das ist alles.


    Jetzt brauche ich eine CP/M Floppy-Disk zu schreiben. Wie könnte ich es an schnellsten/einfachsten machen.

  • Hallo Robert. Vielen Dank! Es war eingentlich einfacher mit aller Unterstützung, dass ich hier gefunden habe. :-)


    Aber ja! Das muss ich unbedingt machen. Leider glaube ich, das mein Programmiergerät diese EPROM modell nicht unterstützt. Aber vielleicht kann ich ein Arduino-Programmiergerät zuhause machen. :-)


    Ich will wieder auf diese Thema kommen, wenn ich die andere Problemen gelöst habe.


    Viele Grüße

    Manuel

  • Ja - Hallo overCLK - offenbar sehe ich eine MOS Meldung von 48 kB Memory.


    Mit $1976 4010 FFFF


    Ich denke zunächst wenn die P2 richtig mit Floppy arbeitet - würde ich mich um die EPROMs als File zu kümmern. Das wird schon dann bekommt rfka01 ( Grüße von helwie44 ) und alle die Files.


    Der Ablauf sollte normal sein bei einer P2.

    RESET

    MOS xxxx yyyy (etwa wie die EPROMs aufgeteilt sein können)


    $1976 4010 FFEF ( da sollt xxEF stehen - evtl. übersehen?)

    .


    Nun nach dem .Punkt sollte die Tastatur frei sein.

    Mach doch mal z.B. etwa mit Display/Dump

    .D0,100(cr) oder weitere MOS Befehle aus meine Beschreibung ( WEB).


    TA P2 cp/m (von mir helwie44 - als IMD holen und im PC erstellen mit IMD!


    Ist eine cp/m 4300h TPA Diskette - siehe bei einigen Beiträgen an/von gpospi / helwie44 dort ist leicht ein IMD -File zu downloaden. Dieses sollte auf eine 5 1/4 Zoll DISK DD SD (benutzt) normal 40 Track, mit 16 Sectoren von 256 Byte und einseitig erzeugt werden.

  • Ich habe mit der P3 einen kleinen Erfolg: Habe heute nochmals alle P3 Karten an die P2 Backplane angeschlossen, ausgenommen Tastatur&CRT Controller. Die Tastatur, der Tastatur-Controller sowie die Video-Karte stammen also weiterhin von der P2. Die Floppy Laufwerke habe ich von der P3 übernommen. Beim Einschalten muss ich "RESET" drücken, dann erscheint (ohne eingelegte Disk) das korrekte MOS Menü und ich kann z.B. Speichertests durchführen. Das System piepst übrigens nicht.

    Das "Allover" Kopierprogram (ftp://ftp.informatik.uni-stutt…lphatronic/p3/allover.imd) konnte ich erfolgreich starten. Im Lauf des Kopiervorganges tritt allerdings ein Disk Error auf. Das kann aber durchaus berechtigt sein, da ich ja gebrauchte DS/DD Disketten verwende.

    Alle anderen Boot-Disks der Uni Stuttgart liefern allerdings nur einen "Disk Error" beim Bootprozess.

    Das System verhält sich mit dem P2 Floppy Controller genau gleich, d.h. die Controller-Logik sowie die Laufwerksanschlüsse (Verbindungen auf der Backplane bzw. beim Floppy Kabel) unterscheiden sich zwischen P2 und P3 wohl nicht. Der einzige Unterschied dürfte also im Controller-EPROM auf der CPU Platine liegen.


    Im nächsten Schritt werde ich also die Tests im P3 Chassis samt P3 Backplane und dem kombinierten Tastatur&CRT Controller wiederholen. Bildschirmausgabe gibt es da definitiv nicht, weil der Video-Teil defekt ist. Aber vielleicht bootet das System doch das "Allover" Programm. Immerhin habe ich nun eine nachweislich funktionierende Diskette.




  • Oje!, Ich habe gedacht, dass es schon fertig war. :-)

    Es wurde nicht übergesehen. Mit die 48K Karte bekomme ich BFFF. Mit beiden Karten eingesteckt bekomme ich FFFF.


    Gute Idee! Wenn ich die Probleme mit den Laufwerken löschen kann, dann wäre es einfacher, die EPROM dort zu schrieben.


    Heute kann ich nicht dieses Thema weiter untersuchen. Aber es sieht aus, dass noch Fehler gibt bei den Laufwerken (oder dem Kontroller):


    -Beim Reset braucht den Computer etwa 10 Sekunden, um etwas am Bildschirm zu zeigen (Timeout des Laufwerk-Kontrollers?)

    -Immer wenn man die Reset-Taste drückt, alles sieht als ob den Computer gefriert würde. Aber etwa 10 Sekunden später steht der Computer wieder im Betrieb.

    - Keine der Laufwerk-LED leuchten.

    - Es sieht aus, dass nur der obere Laufwerk umdreht (noch nicht komplett sicher darüber)


    Morgen untersuche ich dieses Thema weiter.


    Wenn ich alles richtig gemacht habe:

    IMDcpm4300h Disk dort holen und die .txt auf dem eigenen PC ändern / löschen. Nur für die Übertragung im FORUM.


    Grüße und viel Erfolg

    Hellwie44

    Vielen Dank! Ich habe es selbst früher gefunden, und einen CP/M Disk damit geschrieben.

  • 48 kB RAM Meldung mit zwei ram card?

    Hallo overCLK - eigentlich ist irgendwas nicht mit den Speicherkarten in Ordnung.

    Mit einer 48 kB card und dann sehen ich nur 4010 BFFF vom Reset MOS - da fehlen ja die oberen 16 kB !! Evtl. ist eine Reihe ( 16 kB mit 8 Memory-chips) der 48 kB nicht ansprechbar, oder?

    Wie sieht die extra 16 kB Ram Karte aus? Früher gab es bei TA 3 mal 16 kB Karten Ram um 48 kB zu realisieren. Die Karten haben ein Switch 4 Bit obere Addressen zu selektieren.

    Das muss du genau mal untersuchen. Sonst können durch die fehlerhaften Überlagerung ( zwei Karten := 48 k davon 16 kB undefiniert und eine extra 16 Kb Karte!?!) ander Probleme im System bestehen.

    Oder habe ich das nicht richtig aus dem Beitrag #100 verstanden?

  • 48 kB RAM Meldung mit zwei ram card?

    Hallo overCLK - eigentlich ist irgendwas nicht mit den Speicherkarten in Ordnung.

    Mit einer 48 kB card und dann sehen ich nur 4010 BFFF vom Reset MOS - da fehlen ja die oberen 16 kB !! Evtl. ist eine Reihe ( 16 kB mit 8 Memory-chips) der 48 kB nicht ansprechbar, oder?

    Wie sieht die extra 16 kB Ram Karte aus? Früher gab es bei TA 3 mal 16 kB Karten Ram um 48 kB zu realisieren. Die Karten haben ein Switch 4 Bit obere Addressen zu selektieren.

    Das muss du genau mal untersuchen. Sonst können durch die fehlerhaften Überlagerung ( zwei Karten := 48 k davon 16 kB undefiniert und eine extra 16 Kb Karte!?!) ander Probleme im System bestehen.

    Oder habe ich das nicht richtig aus dem Beitrag #100 verstanden?

    Hello Helmut,


    If his card set is the same of mine it is not jumper-configurable, so addresses are hardwired.


    Regards

    When I tried to list all retro systems I have at home, the "The message is too long, must be under 500 characters" error appears! :lol:


  • Das Ergebnis des MOS Befehl:


  • Plotzlich hat sich etwas geändert. Am Reset macht der Laufwerk einen schrecklichen und lauten Klang, als ob er die Track Null suchte. Es kommt hin and zurück einige Male ohne gutes Ergebnis.


    Ich habe einige Fotos genommen. Jetzt möchte ich ihn pützen (besonders die Sensoren) und ein bisschen einfetten.




  • Ok, thanks jlopez and overCLK,


    Ja ich erinnere mich, weil solche Memory Konfiguration etwa ähnlich bei ein netmercer P2 ist.

    Wenn die 48 kB Karte ( weiter Entwicklung) ok ist - sollten die Anfangs - Address auf 0000h beginnen und die unteren 16 kB bei einem RESET ausgeblendet werden.

    Vom MOS Start sind dann von 4000h bis BFFFh ( 32kB) zu sehen/benutzbar. Und dann die 16 KB dazu extra Karte (wahrscheinlich von C000h bis FFFFh) - somit 48 kB MEMORY für TA BASIK- Standard TA oder cp/m mit 4300 TPA arbeiten können.


    Das bedeutet doch ( vorhanden sind 64 kB Memory - intern) wenn das BANKING ( über 78h PORT) per 64 kB cp/m mit einer üblichen TPA 0100h arbeiten/ laufen könnte.


    NUR der Floppybetrieb muss jetzt doch ordentlich arbeiten!


    Wie sehen die Test dazu aus?

  • Yes, no jumpers or simllar in my 16K card


  • Ich sehe gerade - das ein LW-Floppy geht!- prima endlich!!.

    Starten die 4300H cp/m Programmen - einfach mal etwas probieren.


    Wenn schon eine cp/m 0100h Diskette bereit liegt - würde ich gerne sehen, ob diese Systeme starten???


    Normal macht das BASF Laufwerk mit einem HEAD-LOAD mit einem lauten Klack!

    Das hatte irgendwann TA schon genervt - daher gab es ein Hardware-Patch um falls eine Diskette im Laufwerk ist und ein Select/ Zugriff erfolgt, bleibt der Headload aktiv bleibt.


    Noch zur WARTUNG bei Floppylaufwerken.

    Bitte vorsichtig die Oberfläche der Read/Write Köpfe behandeln. Und wenn etwas ganz wenig nur Nähmaschinenöl einsetzen.

  • Die Laufwerke sind offenbar eine "Schwachstelle", bei mir sind auch zwei gar nicht nutzbar (sie positionieren den Lesekopf nicht) und das dritte Laufwerk ist eher unzuverlässig. Manchmal liest es die Boot-Disk und manchmal streikt es ebenfalls. Deshalb werde ich wohl demnächst einen Gotek-Laufwerksemulator einbauen.

    overCLK: Super, dass der P2 Rechner nun wieder funktionsfähig ist!

  • helwie44: Ich habe ja jetzt aus der P3 auch eine 64K RAM Karte, diese funktioniert grundsätzlich im P2 System. Ich würde daher auch gerne das CPM 0100h testen. Kannst Du hier vielleicht wieder ein IMD-File hochladen (das ist die einfachste Variante um eine entsprechende Boot-Disk zu erzeugen)?

  • Ich sehe gerade - das ein LW-Floppy geht!- prima endlich!!.

    Starten die 4300H cp/m Programmen - einfach mal etwas probieren.

    Ich habe die Anwendungen im CP/M Disk mal probiert. Es sieht aus, dass alle funktionieren. Was noch kann ich probieren, dass zur Verfügung steht?


    Wie könnte ich jetzt die ROM sichern? Gibt's eine Weise, sie vom CP/M im Floppy speichern?


    Nun brauche ich die Reset-Taste drücken, um ein richtiges Reset zu bekommen. Dass finde ich komisch, weil der Laufwerk-Kontroller keine Verbindung mit B14 (Reset-In) hat. Ich werde es nochmal mit dem Oszilloskop analizieren.


    Wenn schon eine cp/m 0100h Diskette bereit liegt - würde ich gerne sehen, ob diese Systeme starten???

    Wo kann ich so einen CP/M finden? Ich probiere es gerne! :-)


    Normal macht das BASF Laufwerk mit einem HEAD-LOAD mit einem lauten Klack!

    Das hatte irgendwann TA schon genervt - daher gab es ein Hardware-Patch um falls eine Diskette im Laufwerk ist und ein Select/ Zugriff erfolgt, bleibt der Headload aktiv bleibt.


    Noch zur WARTUNG bei Floppylaufwerken.

    Bitte vorsichtig die Oberfläche der Read/Write Köpfe behandeln. Und wenn etwas ganz wenig nur Nähmaschinenöl einsetzen.

    Ja, das stimmt! Am Anfang hatte ich Sorgen, etwas schlechtes passiert ist. Aber dann habe ich der grosse Elektromagnet gesehen. Aber ja, der Klack ist schrecklich. :-)


    Ja, ich habe Nähmaschineöl benutzt, der ein bisschen einzufetten. Einer funktioniert gut, der andere nicht.