8250 LP - Laufwerk dreht viel zu schnell

  • Ich habe mit meinem petSD+ diese Probleme nicht. Startet jedesmal zuverlässig.

    Verwendete Firmware-Version: Nodiskemu V1.0.0Alpha0-20180530-F1F0322.

    Hmm, hab das LW nicht hier- da sehe ich mal nach.

    Ich muss teilweise FÜNFMAL Reset drücken, bis die Mühle läuft. So gefühlt jedes 20. Mal einschalten läuft es aber gleich los. :D

    Hab das Teil damals mit programmiertem Atmega gekauft.

  • (mal ganz ehrlich... die Petdisk sitzt direkt am Edgeconnector, und sie selbst schreibt ja nur bis zum Pet selbst und kommuniziert nicht mit dem Drucker am Ende der Kette, was soll sie da treiben?

    das ist ein bus, somit sind doch alle geräte parallel und auch die signale.

    jedes gerät am bus muss doch mitlesen um festzustellen ob es angesprochen wird.

    und dein petdisk muss doch die parallel verlegten signale doch auch schaffen zu treiben.

    oder glaubst du, der drucker am ende der kette, erkennt ein signal am anfang der kette und hällt sich dann raus?


    die signale, die dein petdisk, zum pet schreibt, gehen wirklich nur zum pet und nicht parallel zu allen anderen am bus?


    gruß

    helmut

  • Welches Gerät sagt denn dem Drucker am Ende der Kette, dass er jetzt nicht angesprochen ist? Macht das jemals die Petdisk selbst? Oder nicht eher der PET, der mit der Petdisk (oder einem anderen Gerät am Bus) kommunizieren möchte?

    Und auch die anderen Geräte am Bus hören und nicht hochohmig sind und damit current sinken, dann ist der Unterschied immer noch eher gering. Die Bustreiber können ca 48mA treiben, der Atmel 40mA. Das mag bei einem voll ausgebauten Bus mit 15 Geräten genau der Unterschied sein (oder auch nicht). - ich kanns nicht testen, da ich nur 4 Peripheriegeräte habe (2 Doppelfloppies, zwei Drucker) und momentan auch nur 2 GPIB-Kabel.


    Und wie gesagt, wer jetzt kauft bekommt eh die Version 2 mit Bustreibern, damit ist diese Geschichte eh... Geschichte. :)

  • Die Bustreiber können ca 48mA treiben, der Atmel 40mA.

    mit 40mA zu rechnen, ist unmöglich, der arme atmega. frag mal microchip oder atmel, die würden dir eine predigt halten.


    laut daten blatt absolute maximum pro i/o pin 40mA, ok, aber......lese mar bitte auch weiter und die notes.


    wie hoch ist dann der garantiert ausgegebene low pegel bei 40 mA? da finde ich nichts darüber.


    wenn schon im datenblatt bei 20mA 0,9V steht, dann liegt der weit darüber

    und schon bei 20 mA liegt es über den 0,8V für ttl pegel am bus!

    ich vermute mal ein ausgegebenes low liegt dann bei ca. 1,5V.

    und ganz zu schweigen von der erkennung des high pegels am bus, an dem atmega eingang.


    im datenblatt steht bei absolute maximum, der strom über vcc und gnd darf die 200 mA nicht überschreiten!

    also der ganze atmega darf die 200 mA mit seinem eigenem verbrauch und der summe aller i/o ports und den anderen signalen nicht überschreiten.


    dann steht da, zwei I/o ports zusammen, manche noch mit anderen signalen dürfen 100 mA nicht überschreiten.

    wenn du nun 100 mA durch sagen wir mal 16 pins (zwei ports) teilst kommst du auf 6,25 mA absolute maximal pro port.


    selbst wenn du von den ganzen 16 i/o ports, eines atmegas, nur lecherliche zwei pins mit 40 mA treibst
    und die anderen 14 i/os gar nicht benutzen würdest.

    hättest du nie den garantiert benötigten ieee488 pegel am bus.


    und der arme atmega.


    gruß

    helmut

    Edited once, last by axorp ().

  • das Problem mit dem petdisk könnte daran gelegen haben, dass beide auf der gleichen Adresse reagiert haben?


    Wenn die config zerschossen ist könnte das ja sein oder?


    Ich bevorzuge ja auch standard-konforme Treiber aber ich hab zugegeben da auch noch nie Probleme gehabt den Bus als normales TTL mit normalen 74ls06/7 zu betreiben. Zugegeben aber eher mit wenigen echten Devices.

  • ich hab zugegeben da auch noch nie Probleme gehabt den Bus als normales TTL mit normalen 74ls06/7 zu betreiben.

    7406 und 7407, das sind ja keine normalen TTLs.


    die sind ja für den bus geeignet, die benutzt ja commodore auch.

    die können ja genug treiben und sind open collector.

    ob die nun 40 mA oder mal im extrem fall 48 mA treiben müssen, macht denen nicht viel aus.

    die können eine menge vertragen, dafür sind die ja gebaut.


    hier geht es um das direkte treiben eines ieee488 buses mit microcontroller ports, die dafür garnicht geeignet sind

    und der arme microcontroller um das x-fache überbelastet wird.


    nehmen wir mal die daten pins, am ieee488 bus. 8 x 48mA = macht 384 mA nur alleine für die 8 port pins.


    dann kommen die handshake leitungen noch dazu, mit auch jeweils 48 mA.

    gehen wir mal davon aus, das nur drei gleichzeitig aktiv sind. 3 x 48 = 144 mA


    macht mit den datenleitungen zusammen 528 mA am bus.

    da alles parallel geschaltet ist, ist es wohl klar, egal wo am bus gesteckt, ob am anfang oder am ende.


    für zwei ports, also 16 pins, sind absolut maximal nur 100 mA beim atmega erlaubt.

    die 100 mA sind wirklich das absolute maximum und man sollte es auch nicht so benutzen!


    wie kann man nur denken, ob nun 100 mA oder 528 mA, ist doch egal :2teufel:


    gruß

    helmut

  • Die Rechnung ist aber komplett falsch aufgezäumt und für die Sache nichtssagend. Das wären max-Werte, die die Bustreiber gerade so KÖNNTEN. Offensichtlich ist dies NICHT die Last die der Bus wirklich verschlingt. Wie viel unter diesem Maximalwert das liegt.. keine Ahnung.

  • Mal wieder in die andere Threadrichtung: Die zentrale Laufwerksblende hatte einen abgebrochenen Schrauben.. dings. Im Gegensatz zu denen auf der Oberseite der Blende stehen die unteren komplett frei in der Luft und sind damit anfällig durch zu hohes Drehmoment abzuscheren.

    Also flugs den Original-"nuffell" mit Plastikkleber wieder angeschweißt, und auf die schnelle drei Versteifungen konstruiert, gedruckt und eingeklebt.


  • Ich habe das selber mal probiert mit einem ATmega328 als Device direkt am IEEE-Bus. Solange nur der PET am Bus war, hat alles prima funktioniert.

    Sobald noch eine Floppy dazu kam, war Ende. Der ATmega hat es nicht mehr geschafft, die ATN-Leitung runterzuziehen*.

    Ich habe dann ein 75160/75161-Päärchen dazuzwischen geschaltet und schon hat es funktioniert.


    Das hat mich einige Tage gekostet, weil ich auch dachte, der ATmega hätte mit dem Bus kein Problem. Daher hatte ich nur einen Logikanalyser am Bus um die Kommunikation zu kontrollieren. Der hat mir vorgegaukelt, die Pegel wären ok, aber die waren so daneben, dass sie nicht mehr zuverlässig erkannt wurden.


    Also nicht theoretisieren, sondern einfach mal selber ausprobieren. ;)


    * EDIT: Ne ist Quatsch. Das Device zieht ja nicht an ATN. Dann waren es andere Leitungen, wo die Pegel nicht passten. Ist halt auch schon 4 oder 5 Jahre her.

    • i-Telex 7822222 dege d

    • technikum29 in Kelkheim bei Frankfurt

    • Marburger Stammtisch

    Douglas Adams: "Everything, that is invented and exists at the time of your birth, is natural. Everything that is invented until you´re 35 is interesting, exciting and you can possibly make a career in it. Everything that is invented after you´re 35 is against the law of nature. Apply this list to movies, rock music, word processors and mobile phones to work out how old you are."

    Edited 3 times, last by detlef ().

  • würde es ohne teuere treiber funktionieren,

    dann hätte commodore an diesen ICs ganz ganz ganz bestimmt gespart!


    denn commodore musste die iec625 / ieee488 ICs auch teuer einkaufen.

    auch die 7406, 7416, 7407 oder 7417 kosteten gegenüber den normalen ttl ICs eine menge mehr.


    und ich hätte damals mir die auch gerne erspart, bei meinen verschiedenen platinen.

    die zu hunderten und manche zu tausenden verkauft wurden.


    gruß

    helmut

  • Naja, die Microprozessoren konnten damals nicht so hohe Ströme wie die ATmegas. So ein oller PIC oder ein 8048 schafften damals 5mA.

    Deswegen dachte ich ja auch, dass der ATmega das hinbekommt. Klappt aber nicht.

    • i-Telex 7822222 dege d

    • technikum29 in Kelkheim bei Frankfurt

    • Marburger Stammtisch

    Douglas Adams: "Everything, that is invented and exists at the time of your birth, is natural. Everything that is invented until you´re 35 is interesting, exciting and you can possibly make a career in it. Everything that is invented after you´re 35 is against the law of nature. Apply this list to movies, rock music, word processors and mobile phones to work out how old you are."

    Edited once, last by detlef ().

  • ja, aber nur alle pins eines atmegas zusammen dürfen nicht die 200 mA überschreiten.

    zwei ports nur max. 100 mA. alle pins zählen da mit, nicht nur die io-ports.


    so kommt man auf ca. 5 mA pro port. wenn man den atmega nicht überlasten möchte.

    alles muss ja über die beiden dünnen bonddrähte vcc und gnd und die entsprechend wohl kleine chipfläche abgeleitet werden.


    gruß

    helmut


    edit.....

  • * EDIT: Ne ist Quatsch. Das Device zieht ja nicht an ATN. Dann waren es andere Leitungen, wo die Pegel nicht passten. Ist halt auch schon 4 oder 5 Jahre her.

    ja, das ist die einzige leitung, die die peripherie geräte nicht treiben. (ifc (reset) normal auch nicht, wir aber oft benutzt)