Reparatur / Pflege von einem Apple II plus.. funktioniert noch nicht richtig / Floppy Controller etc...

  • Hallo ich habe hier einen schönen Apple II plus... den ich schon alleine wegen der Tastatur haben wollte..


    der Rechner geht auch sofort an...


    Leider klappt derzeit die Floppy-Driver Karte nicht.. (Floppy leuchtet auch nicht auf)..

    bzw. weiß ich garnicht genau ,,.. wie ich richtig testen kann.. ?!

    Habe bisher auch nur eingeschaltet und nach einem Reset mal ein kleines Basic Programm eingegeben...


    sieht von innen so aus.. PS: die Controllerkarte ist natürlich dann noch auf den zweiten Slot von rechts gewandert...


    PS: ganz links ist die Language Karte.. soll ich die erst einmal ausbauen.. bzw. was macht die Überhaupt..

    PPS: welche Karten sollte man sonst noch so haben ? Seriell ? oder "mehr Speicher" ? und der II plus kann ja keine 80 Zeichen (ohne entsprechende Karte?)


    habe meinen letzt Apple II(e) vor über 4 Jahren zuletzt eingeschaltet..

    VG Micha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • PR#6 hast Du versucht, um von der Floppy zu booten?


    80-Zeichen-Karte empfiehlt sich sicher, und vielleicht eine Super Serial Card oder ein Apple2-RPI-IO, damit Du Daten in die Büchse und auf die Floppy bekommst.

    Habe: TI-99/4A + PEB, Sharp MZ-800, Apple IIe, Symbolics MacIvory 2, ZX Spectrum, Macintosh IIfx, C64, VAX 4000-600, VAX 4000-105A, VAXStation 4000/90A, VAXStation VLC, Digital Personal Workstation 500au, Schneider CPC 464, CBM 3032 Biete: Atari 800XL, TI-99/4A, Atari 1040STfm Suche: 1/2'' Bandlaufwerk SCSI, Reparaturbedürftiges 8+16bit

    Retrocomputing Slack @hanshuebner@mastodon.social

  • PR#6 hast Du versucht, um von der Floppy zu booten?

    wenn ich den Rechner ohne Diskconrtroler starte... kommt normal der Cursor und ich kann Basic eingeben..


    wenn ich den Rechner mit Disc-Controller auf Slot 6 (also zweiter von rechts, bei der 0-7 Zählweise) einschalte.

    dann bleibt der Rechner zuerst "stehen" wenn ich dann CTRL-Reset drücke... kommt fast ganz unten ein Cursor.

    Wenn ich dann wieder PR#6 eingebe zuckt er wieder mit Streifen...


    nach Reset sind die Streifen auch wech..

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Da ist ganz schön Dreck in den Slots - den hast du vorher rausgemacht?

    naja... soweit es ging... corona da ist wohl mal eine:zombie: "Mäuse-Familie" :cat2: irgendwann eingezogen...

    so wie ich die karte rein "rutschen" lasse, bilde ich mir ein die Kontakte sind ausreichend...


    ich muss wahrscheinlich erst einmal das Floppy und die Controller-Karte an meinem funktionierendem Apple IIe Gegentesten ?

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Achso... hat der Apple II plus sonst noch einen SELBSTTEST ?..


    und CTRL+RESET ist "normaler" Reset ? das ist richtig ,.. denke ich.. ?


    ich denke, das Hauptaugenmerk sind jetzt auch die Spannungen...

    PS: was kann man denn am Teststecker (4 polig) unterhalb vom RAM "messen" ? oder tun.. ?


    und wo kann ich (ausser am Netzteilstecker) die Spannungen noch am besten nachmessen ?


    Danke mfG. Micha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • wenn ich den Rechner mit Disc-Controller auf Slot 6 (also zweiter von rechts, bei der 0-7 Zählweise) einschalte.

    dann bleibt der Rechner zuerst "stehen" wenn ich dann CTRL-Reset drücke... kommt fast ganz unten ein Cursor.

    Das ist völlig normal. Hast Du am Controller auch ein Laufwerk angeschlossen? Hörst du Klackern des Steppers für die Kopfpositionierung?


    Das AUTOSTART ROM versucht vom Floppy-Laufwerk zu booten wenn es einen Disk II Controller findet. Wenn kein Laufwerk angesteckt ist, merkst du davon nichts und der Rechner scheint zu stehen.



    ) die Spannungen noch am besten nachmessen ?

    Direkt an den Slots, die liegen alle vier Spannungen an. Aber Vorsicht, dass du da keinen Kurzschluss verursachst. Pin 25/26 sind die an der Rechnerrückseite.



  • der Rechner geht auch sofort an...

    Entstörkondensatoren im Netzteil sind Testobjekt #1 möglichst vor dem 1. Einschalten nach langer Zeit. Die fliegen Dir sowieso früher oder später um die "Ohren". 2. Testpunkt sind die vier Spannungen auf der Hauptplatine. BTW Schaltnetzteile aus dieser Zeit (es sind die allerersten Großserienschaltnetzteile!) testet man nie ohne Last.


    PS: die Controllerkarte ist natürlich dann noch auf den zweiten Slot von rechts gewandert...

    Die korrekte, übliche Slot-Bezeichnung hast Du in Deinem folgenden Beitrag gelernt :) Alles andere ist unüblich.


    PS: ganz links ist die Language Karte.. soll ich die erst einmal ausbauen.. bzw. was macht die Überhaupt..

    Wenn alles funktioniert, dann besteht eher kein Grund diese Karte auszubauen. Die Funktion ist die Speicherweiterung von 48kB auf der Hauptplatine um 16kB auf der Karte in Slot 0 auf 64kB RAM. Das ist wichtig für ProDOS, CP/M und das p-System.

    PPS: welche Karten sollte man sonst noch so haben ? Seriell ? oder "mehr Speicher" ? und der II plus kann ja keine 80 Zeichen (ohne entsprechende Karte?)

    Kommt drauf an! Was möchtest Du mit diesem Apple II machen?


    Ich könnte Dir meine Interessen am Apple II schildern sowie meine Ausstattung(en). Nur würde Dir das nicht weiterhelfen.


    Einfach nur Karten kaufen und reinstecken, damit man sie hat, halte ich für nicht zweckmäßig. Eine Z80-Karte ist nur sinnvoll, wenn Du Dich mit CP/M beschäftigen möchtest, mehrere Diskettencontroller nur, wenn du mehr als zwei Laufwerke anschließen möchtest, Speicherkarten nur, wenn Du sie einsetzen kannst, AD-Wandler nur, wenn Du selbst hacken möchtest, um mit analogen Werten zu spielen, usw.


    Gruß, Ralf

  • Das ist völlig normal. Hast Du am Controller auch ein Laufwerk angeschlossen? Hörst du Klackern des Steppers für die Kopfpositionierung?

    nein.. es klackert garnichts.. ich weiß ja auch nicht.. ob die Floppy überhaupt funktioniert...


    Direkt an den Slots, die liegen alle vier Spannungen an. Aber Vorsicht, dass du da keinen Kurzschluss verursachst. Pin 25/26 sind die an der Rechnerrückseite.

    danke.. dann sind die Spannungen recht gut, bzw. o.k. nur die +12V,.. sind mit +11,8V etwas niedriger als der soll..


    Wenn alles funktioniert, dann besteht eher kein Grund diese Karte auszubauen.

    Kann ich die Language Karte irgendwie "testen" oder waren erkennt man.. dass die funktioniert ?

    (ich kann derzeit ja noch keine extra Software per Floppy einspielen)...


    Kommt drauf an! Was möchtest Du mit diesem Apple II machen?

    erstmal soll das Kerlchen normal laufen :) und ich bin dann ein Fan von RS232.. in Verbindung mit Modems...

    aber bei 40 Zeichen.. ist es "ganz schön retro" :)

    aber trotzdem als "Terminal" per RS232 an meinen Apple1-clone fände ich schon cool...


    Danke fürs helfen, VG Micha (GN)

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Natürlich nicht vergessen den Floppy Controller in den Slot 6 zu stecken (2.te von rechts) und es dann noch mit PR#6 versuchen - falls das nicht klappen sollte:


    kannst Du es gern zu mir schicken und ich prüfe es dann.

  • nur die +12V,.. sind mit +11,8V etwas niedriger als der soll.

    Das liegt voll im grünen Bereich.


    Kann ich die Language Karte irgendwie "testen" oder waren erkennt man.. dass die funktioniert ?

    Nicht wirklich. Einen eingebauten Selbsttest hat der IIer nicht und ohne Floppy kriegst du keine Testprogramme rein. Theoretisch kannst du übers Cassetten-Interface etwa laden, aber realistisch betrachtet ist wohl eher Test und Reparatur des Disk II Controllers und des Floppy-Laufwerks angesagt.

  • nein.. es klackert garnichts.. ich weiß ja auch nicht.. ob die Floppy überhaupt funktioniert...

    Irgendwo hattest Du geschrieben, daß du einen IIe hast. Gegentest solcher Komponten mit diesem Rechner!


    dann sind die Spannungen recht gut, bzw. o.k. nur die +12V,.. sind mit +11,8V etwas niedriger als der soll..

    Das ist ein guter Wert, wie bereits geschrieben. Im Stromlaufplan finde ich statt 12,0V sogar einen Sollwert von 11,6V,


    Kann ich die Language Karte irgendwie "testen" oder waren erkennt man.. dass die funktioniert ?

    (ich kann derzeit ja noch keine extra Software per Floppy einspielen)...

    Nein, nicht ohne etwas Code im Bereich der unteren 48kB, denn der Monitor ("CALL -151") liegt parallel zum Speicher der Language Card.


    Der einfachste Test ist der Start eines Betriebssystems, das die Language Card braucht und benutzt, also ProDOS oder das p-System. Das geht nur mit Diskettenlaufwerk (oder anderem Massenspeicher).


    und ich bin dann ein Fan von RS232.. in Verbindung mit Modems...

    aber bei 40 Zeichen.. ist es "ganz schön retro" :)

    aber trotzdem als "Terminal" per RS232 an meinen Apple1-clone fände ich schon cool...

    Zu Zeiten des Apple II konnte sich kaum jemand ein Modem leisten. Das paßt zeitlich nicht. Wenn Du selbst mit AT-Kommandos umgehen möchtest, ist das allerdings kein Hinderungsgrund :) Es gab sogar interne Modemkarten für den Applebus.


    Wenn's um eine Terminalemulation geht, dann ist eine 80-Zeichenkarte sicher erwünscht, also suche Dir eine Videx Videoterm(-kompatible), denn diese haben fast alle anderen Apple II auch. Zur Terminal-Software: eine fertige, mehr oder weniger kommerzielle oder was Selbstgeschriebenes? Im ersten Fall suche Dir die Software und finde heraus, welche Seriellkarten diese unterstützt. Die häufigste Karte ist die Super Serial Card (SSC) von Apple oder die baugleichen Taiwan-Nachbauten. Die sind heutzutage allerdings begehrte Kaufobjekte. Eine kleine Auswahl des damaligen Angebots findet sich hier. Willst Du selbst schreiben, dann ist's fast egal, solange einer der üblichen Seriellchips der damaligen Zeit drauf ist (6551, 6850, 8250, 3801).


    Gruß, Ralf

  • Ganz so unüblich war BBSing mit Apple II nicht, aber natürlich eher in den USA. EIn verbreitetes Terminalprogramm war ASCII Express.

    Habe: TI-99/4A + PEB, Sharp MZ-800, Apple IIe, Symbolics MacIvory 2, ZX Spectrum, Macintosh IIfx, C64, VAX 4000-600, VAX 4000-105A, VAXStation 4000/90A, VAXStation VLC, Digital Personal Workstation 500au, Schneider CPC 464, CBM 3032 Biete: Atari 800XL, TI-99/4A, Atari 1040STfm Suche: 1/2'' Bandlaufwerk SCSI, Reparaturbedürftiges 8+16bit

    Retrocomputing Slack @hanshuebner@mastodon.social

  • Zu Zeiten des Apple II konnte sich kaum jemand ein Modem leisten. Das paßt zeitlich nicht.

    Hallo Kollegen.. danke für die Infos und auch Unterstützung...


    zum Thema "Modem".. ich möchte auch kein internes Modem in den Apple IIplus/Apple IIe einbauen,

    sonder nur eine "serielle" Karte und damit dann ein externes Modem ansprechen ... oder

    auch direkt mit RS232 (quasi Nullmodem-Kabel) auf meinen Apple1-Clone gehen..


    Für den Apple1 habe ich mir eine Rs232 Karte selbst aufgebaut... und mit dem richtigem IC (max232) kein Problem...

    Für den Apple II muss ich es noch schaffen...


    soll dann SO aussehen: https://youtu.be/hDf-tA_cFWE?t=68

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Hier in .de verhinderte die Bundespest den "Fortschritt". Die Gesprächskosten waren immens. Ende der 1980er gab's den ersten einigermaßen bezahlbaren Tarif für Ferngespräche: nachts zwischen 2 und 5Uhr. Zuvor waren Mailboxanrufe außerhalb des eigenen Ortsnetzes (23Pfennig für 8min) unbezahlbar.

  • ich sammle ja alte Modems und Akkustik-Koppler...
    ich habe auch "ältere" Modems.. :)


    z.B. sowas:


    aber erst einmal muss die Kiste laufen :D

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • ich habe auch "ältere" Modems.. :)


    z.B. sowas:

    Da steht "9600" drauf, also 1990er Jahre. Die Modems aus der Apple-II-Zeit hatten 300Baud. Wer sehr reich war, konnte sich Mitte der 1980er ein 1200Baud-Modem anschaffen. Aber er durfte sich nicht erwischen lassen.

  • Da steht "9600" drauf, also 1990er Jahre. Die Modems aus der Apple-II-Zeit hatten 300Baud. Wer sehr reich war, konnte sich Mitte der 1980er ein 1200Baud-Modem anschaffen. Aber er durfte sich nicht erwischen lassen.

    jau.. sollte nur ein "Beispiel" für eine "Große" alte Kiste sein.. (dieses 9600"baud" US-Norm war übrigens von 1984/1985)

    ich bin auch 1985 mit 300baud gestartet.. mit einem "nicht-ganz-FTZ-zugelassenem-Modem",..

    weil ich schon damals ein Autodial wollte und die Koppler sogar noch teurer waren..


    wie gesagt.. es geht mir persönlich mehr um die RS232 ... da könnte ich auch mein Terminal Silent700 von 1977 mit 300baud anschliessen..


    will jetzt noch nicht auf die Schnittstellen-Karten "driften"... werde als nächstes die Floppy Gegentesten und berichten,,,


    thanxs.. Micha

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • Kann ich die Language Karte irgendwie "testen" oder waren erkennt man.. dass die funktioniert ?

    (ich kann derzeit ja noch keine extra Software per Floppy einspielen)...

    Du kannst es mit diesem kleinen Testprogramm hier machen: RE: Benötige etwas Hilfe bei einem SK-747 (Apple II Clone)


    Du kannst auch schauen wieviel RAM überhaupt von Deiner Maschine erkannt werden - ich hatte da mal Folgendes dazu gefunden:

    AppleSoft Basic has a function called FRE which returns a value representing the free memory available. According to the AppleSoft wiki - Memory Management/Use if the system has more than 32K, that FRE will return a negative number, and that you should then add 65536 to that value:

    If the free memory is greater than 32K, it will be returned as a number less than zero; add 65536 to that to get the real number.

    To verify, I tried this out on an online Apple II emulator:

    Code
    ]PRINT (FRE(0))
    -18449
    
    ]PRINT (FRE(0)+65536)
    47094
    
    ]

    Now while this might not return the total system RAM, remember that the operating system has a memory footprint itself. Another limitation here is that AppleSoft Basic can't see beyond the 64K RAM that it's designed to run on. But you'll at least be able to see if the first 64K is good.


    :)Franky

  • Hallo Franky...

    danke für den Hinweis... insbesondere den Hinweis zu der CURSOR Steuerung werde ich mal ausprobieren..

    wenn das klappt.. sollte die Language Karte ja erst einmal funktionieren...


    Beim RAM Speicher kommt derzeit mit einem "einfachem" Print FRE(0) aber keine 48k (eher 32k)

    hatte ich ja schon nach einem kleinem Basic Programm getestet:

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • so... nachdem geklärt war (durch meinen Test am Apple IIe) dass die Floppy Controller Karte generell funktioniert und auch

    die Floppy selbst... geht es zur "Demontage" und Reinigung vom Apple II plus..


    +


    ich finde solche "Zeitzeugen" mit "Analog-Zeitstempel" immer super.. 40 Jahre..



    so ist auch etwas der Staub und Dreck (oder eher Mäuse-Pippi)


    PS: kann man diese Plastik Platinenhalter heutzutage noch gleichwertig nachkaufen (Reichelt&Co ?)

    die "Hälfte sind jetzt schon abgebrochen" bevor ich die Platine entferne...


    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • PS: kann man diese Plastik Platinenhalter heutzutage noch gleichwertig nachkaufen (Reichelt&Co ?)

    die "Hälfte sind jetzt schon abgebrochen" bevor ich die Platine entferne...

    Ja, das kann man - bei meinem Apple ][ Clone waren auch die meisten vom Transport kaputt (+zerbrochener Deckel+runtergeschleuderter Tastenkappen von der Tastatur+ausgbebrochener Messinggewinde im Gehäuse... :( )


    Ich habe diese hier als Ersatz genommen: https://www.ebay.de/itm/292394127558 (20 x Sicherungsstift Abstandhalter für Leiterplatten 4,8mm, Becker GmbH)


    :)Franky

  • danke... sind bestellt :)


    Ich habe echt ein Problem damit,.. wenn ein Gerät nach "Mäuse-Pippi" riecht...


    Da ist ganz schön Dreck in den Slots

    und ich sollte ja die Expansionsstecker sauber machen ;) :)

    also los:


    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • ich suche mal später nach den Stöpseln... :) vielen Dank...


    ich bin derzeit noch beim Motherboard...

    +


    und habe Dank natas das 115V Netzteil zum 220V Netzteil umgebaut... (ist nur eine Brücke)

    +


    und die Steck-Ports sehen wieder "perfekt" aus :)

    Meine Sammlung: CBM4032,CBM610,VIC20, C16, Cplus, C64, SX64,C128D, LT286-C, Amiga 1000, C= PC1+10+20+40

  • ich bin derzeit noch beim Motherboard.

    Und läuft es auch noch nachdem alle Chips draußen waren? Da hab ich schon schlechte Erfahrungen gemacht.


    Ich musste auf einem Board dieser Revision mal die beiden Elkos erneuern, den zwischen Slot 0 und 1 und den neben dem Stromversorgungsanschluss.


    115V Netzteil zum 220V Netzteil umgebaut.

    Es sollte die korrekte Sicherung für 220V Betrieb drin sein.


    Schau mal unter dem Dämpfungsferrit, ob da ein Entstörkondensator lauert. Ich sehe links vom Ferrit so eine rote Ecke. Vielleicht wurde da schon ein RIFA durch einen WIMA ersetzt. Es muss ein X2 Typ mit genügend Spannungsfestigkeit sein, dann ist alles gut. Die Elkos sehen alle noch flach aus und Spuren von ausgelaufenen Exemplaren sehe ich nicht. Meiner Erfahrung nach sind diese Netzteile deutlich besser als ihr Ruf.


    pasted-from-clipboard.png