PC's von Schneider und Amstrad

  • Ich denke, das wird auch bei mir so sein, allerdings bin ich in Urlaub bei den Eltern.


    Mit der Steckerbelegung Netzteil meinte ich von EuroPC, da so ein Netzteil dabei ist. Aber das Zeug habe ich zuhause eh. Es geht nur wegen Gegenstück bestellen und Molex-Atapter bauen, laut Schaltplan wird das auch mittels Masse-Kontakt aktiviert.


    Zumindest sollten die Infos ausreichen, um mal eine CF anzuschließen. Pin 20 des IDE wurde ja auch zur Aktivierung der IDE genutzt, bei den DOM und einige CF-Ataptern als Spannungsversorgung verwendet. Ideal wäre eine 32MB-CF, aber gibt es nicht mehr.

  • Ich stelle mal den Link so rein: http://oldcomputer.info/keep/c/museum/pc/Schneider_EuroPC

    Jedenfalls habe ich nur das ServiceManual zur FD/HD, also die Schaltpläne gefunden. Die sind ja am Anfang des TREADs. Mich interessiert eher eine BDA zur HD20.


    Immerhin, die HD brauch nicht viel, 2A auf 5s und wenn sie läuft, 0.75A an der 12V, die 5V sind eher pilleballe, weil 0.5A. Also bringt es schon was, die HD erst mal mit einem Normalen AT-Netzteil zu testen, ob diese anläuft.

  • Zumindest sollten die Infos ausreichen, um mal eine CF anzuschließen. Pin 20 des IDE wurde ja auch zur Aktivierung der IDE genutzt, bei den DOM und einige CF-Ataptern als Spannungsversorgung verwendet. Ideal wäre eine 32MB-CF, aber gibt es nicht mehr.

    Hab meine auch gebraucht gekauft. Verwende 2x32MB und ich könnte locker das doppelte an Software installieren, aber ich möchte keine Laufwerksorgie und schon gar nicht ein anderes als das originale OS. (3.3)


    Ich habe noch die Platte aus dem Tandy1000 RL/HD, die sollte auch in dem EuroPC HD20 laufen, da die XT-Interface hat.

  • Wie gewünscht, hier ein paar Bilder der HD20:

    Links die Fehlerübersicht und rechts die LED, wahrscheinlich an der Platte nur angelötet

    Links der Stromanschluss, von der Platte geht weg der Lüfter und rechts der PWON-Stecker, mit dem die Einheit eingeschalten wird.

    Hier noch mal der Typenaufkleber, mit Angaben für die aufgenohmene Leistung.

    Ich habe gerade eine 32MB-CF, das ist eine Typ 1 gekauft. Mal sehen, ob diese am Atapter spielt.

  • .

    Hier noch mal der Typenaufkleber, mit Angaben für die aufgenohmene Leistung.

    Vorsicht, die Miniscribe 8225XT hat kein AT-BUS/IDE-Interface, sondern XT-Bus. Das ist nicht kompatibel, nur so ähnlich. Leider ist mir bisher kein Ersatz für diese Festplatten bekannt, wäre schön, wenn es da was gäbe, ich hätte selbst diverse Systeme, wo ich eines Tages die mechanischen Platten wohl tauschen muss, weil sie sicher irgendwann nicht mehr gehen.

  • Vorsicht, die Miniscribe 8225XT hat kein AT-BUS/IDE-Interface, sondern XT-Bus. Das ist nicht kompatibel, nur so ähnlich. Leider ist mir bisher kein Ersatz für diese Festplatten bekannt, wäre schön, wenn es da was gäbe, ich hätte selbst diverse Systeme, wo ich eines Tages die mechanischen Platten wohl tauschen muss, weil sie sicher irgendwann nicht mehr gehen.

    Etwas weiter oben hatte ich laut über einen Lösungsansatz aus ARM-µC und SD-Karte nachgedacht. Für die STM32-Familie gibt es fertige Bibliotheken für SD-Karten inkl. FAT-Treiber und für XTA sollten grob überschlagen schon die 72MHz von den billigen 2-Euro-Boards reichen. Die Teile und ein Testsystem hätte ich da, aber wieder einmal zu wenig Zeit für den Kram.

  • Zudem ich am GIDE des KC85 auch eine DOM und anderes IDE dran hab. Der Rechner hat auch nur 4Mhz. Also bin ich mit der Einteilung nicht so sicher, es könnten auch Befehlssätze sein.

    Die beiden KC85 booten auch von den HD's, die Teiber sind im ZBIOS eingebaut.


    Also sollte die CF eigentlich auch funktionieren.

  • Also, ich habe das System mal mit DCP gestartet und lasse das HDINIT drüber rennen. DCP ist zwar eine inoffizielle DOS3.3-Kopie, aber der EC1834 war ja auch inoffiziell...


    Festplatte läuft an! Nur das Netzteil dazu nicht. Da muss ich noch schauen. Zur Zeit ein AT-Netzteil dahinter. Das Ding stand wohl lange im Schrank ohne Benutzung. Der letzte E-Check-Kleber ist von 2018.


    Der Lüfter ist Tatsächlich direkt an die Festplatte gelötet.

  • Das HDFORM.EXE habe ich wieder gefunden, das war bei den Schneider-Disketten für den Euro-AT dabei.Das basiert aber auf dem Phönix-BIOS. Das hat aber bei 144 Fehlern aufgehört. HDINIT.COM marschiert aber durch. Dann habe ich ein MAXTOR-TOOL gefunden.


    Das Problem dürfte der Integritätstest sein, der recht scharf ist. Deswegen brechen die Programme einfach ab. Von den Werten ist das die Festplatte Typ 2, laut dem AMI-BIOS, was viel in den 286er zu finden ist.

  • Vielleicht nicht die Köpfe selbst aber der Anschluss an das Flachband-Folienkabel im Innern der Platte.
    Da hatte ich bisher schon 2 HD20 bei denen die hauchdünnen Drähtchen der Köpfe abgerissen waren.

    Lies sich mit feiner SMD Lötspitze aber recht gut wieder anlöten und läuft seither problemlos.