Akku für Compaq ProLinea 3/25zs

  • Hi !


    Ich versuche gerade, einen Compaq ProLinea 3/25zs wieder in Betrieb zu nehmen ... den Rost am Netzteilgehäuse hab ich inzwischen ziemlich beseitigt, jetzt ist der -natürlich- tote Akku dran. Der ist zum Glück in einem separaten Kästchen ( Rayovac No. 840, Alkaline 4,5 V ) und auch nicht ausgelaufen - und man kann den sogar noch kaufen :


    https://www.amazon.com/4-5V-Al…attery-Pack/dp/B000PCCBMS


    Aber soooo viel ist mir das nu doch nicht wert ...


    Kann man da auch ne x-beliebige Batterie mit 4,5 Volt dranhängen ? Oder sogar nen Akku ? Schön wäre ja ne möglichst kleine Batterie, die in das Original-Batteriegehäuse passt ...


    MFG


    Cartouce

  • Irgendwas auslaufsicheres mit 3-6V halt. Akku ist keine gute Idee, da diese Tiefentladung meist gar nicht gut finden und mit Siff belohnen. Wenn da 'ne Alkalibatterie drin war/ist, wird da auch keine Ladeschaltung drin sein.

    Früher hab ich einfach eine Taschenlampen-Flachbatterie an das Anschlusskabel drangelötet. Aber die bekommt man ja mittlerweile auch fast nicht mehr.

    Meist nehme ich da heutzutage 2xCR2032 in Reihe, das ist bei frischen Batterien zwar mit 6,4V hart an der Grenze, die meisten Uhrenchips vertragen aber laut Datenblatt bis zu 7V Batteriespannung. Im Einzelfall einfach mal nach dem Datenblatt des Uhrenchips googlen.

  • Schön wäre ja ne möglichst kleine Batterie, die in das Original-Batteriegehäuse passt ...


    Guck mal bei conrad.de . Die habe allerlei Akkus und Batterien in Spezialbauformen (lang-dünn, kurz-dick etc.) mit und ohne Lötfahnen und in allen erdenklichen Spannungen. Könnte durchaus sein, daß sich da was Passendes findet. Suchbegriff wäre z.B. "Emmerich" oder "Tadiran".

  • Schönen Abend, ich würde diesen etwas älternen Thread gerne wieder reaktivieren, da ich aktuell vor dem gleichen Problem (gleicher PC) stehe und somit wollte ich mal nach der finalen Lösung fragen.


    Wenn die Rayovac 4,5V Alkaline original verbaut sein sollte, so sollte es doch eine Pufferbatterie sein (kein Pufferakku), dann hätte ich kein Problem eine nachzubauen.


    Aber eine solche war nicht in meinem 3/25ZS verbaut, der Platz für eine Batterie war leer. Siehe nachfolgendes Fotos, und sah unberührt aus, will heißen evtl. war eine solche erst garnicht verbaut. Die Lötstellen sehen nicht so aus, als wäre dort eine angeschlossen gewesen. In der Jumperbelegung gibt es auch eine Möglichkeit zwischen interner und externer Batterie zu jumpern (P9).



    Damit stellt sich mir die Frage ob bei nachfolgendem Foto das eingekreiste Bauteil (runde braune Tonne) eine Batterie ist? Es enthält ein Plus-Symbol.



    Ich bin am Rätseln was das sein könnte. Auch auf der Platine selbst ist ein Plussymbol zu sehen. Daher dachte ich eine Pufferbatterie.


    Vielleicht kam es bei Cartouce ja zu einer Lösung des Batterieproblems und er/du kann mir weiterhelfen.


    Bis dahin noch einen schönen Abend

  • Danke für die rasche Antwort, das erklärt mir schonmal zumindest das.


    Danke an Euch beide.


    Jetzt bleibt nur noch die Frage ob es wirklich nur eine Pufferbatterie einzubauen gibt,

    oder einen Pufferakku.


    Hab mir im Netz schon einen Wolf gesucht. Handbuch keines gefunden, nur die Jumperbelegung.

  • Also man findet wirklich erstaunlich wenig ...


    Mir ist noch ein PDF beim https://www.arvutimuuseum.ee/computers/ über den Weg gelaufen.

    http://www.arvutimuuseum.ee/computers/list.shtml?031

    Da steht immerhin eine IBM Teilenummer mit drin für die Batterie, die es aber in 3.3 und in 4.5V gibt. Mit der Nummer kann man aber wahrscheinlich auch heut' noch das "exakte" Bauteil bekommen.


    Nötig ist das aber sicher nicht. Du kannst ja mal von dem Jumper mit dem man interne und externe Batterie umschaltet ausgehend die Leiterbahn anschauen. Eine davon müßte an der von Dir fotographierten Stelle enden. Die andere dort, wo man die externe Batterie anschließen kann. Der mittlere von den drei Jumperstiften sollte dabei wahrscheinlich dann direkt zu dem Chip führen, in dem die Uhr sitzt. Diese verliert nämlich wohl beim Umstecken ihr Datum, d.h. wenn die Spannung wegfällt, weshalb der Jumper einfach nur eine "Weggabelung" für die Spannung ist, mit der man entweder links oder rechts auf Mitte legt.

    Und wenn man dann schon die Wahlhat, dann würde ich da nicht auf dem Board was auflöten was im Zweifelsfall auslaufen kann, sondern schön - wie oben schon vorgeschlagen - einen Batteriehalter montieren oder eben eine spezielle Batterie mit Lötfahnen, die man dann an den "extern" Anschluß dranhängt und schön irgendwo im Gehäuse befestigt, wo sie auslaufen kann, ohne was zu beschädigen.



    Ach und eine Treiberseite gab es noch

    fr.pcdrivers.guru/hp-compaq-pr…25zs/download-674408.html

    Kann ja auch mal hilfreich sein, zumindest wenn man ihr vertraut.

  • Danke für die Infos, die Teileliste hatte ich inzwischen gefunden, ich werde es mit der 4,5V Alkaline Batterie probieren.


    Ich habe schonmal die Leitungen an die Batterieposition gelötet, so lange, dass ich dann die Batterie im Gehäuse weit entfernt von der Platine unterbringen kann. Fotos folgen.

  • Ich bin jetzt mal wieder einen Schritt weiter, habe ein Batteriegehäuse für 3x 1,5V AA verwendet, komme somit auf die 4,5V der Rayovac 840, mit langen Kabeln um die Batterie weit entfernt von der Platine im Gehäuse zu platzieren. Den Pluspol konnte ich auf der Unterseite der Platine verfolgen, also die Leitungsbahn, allerdings nicht die andere Leitung.


    4,7V kommen an der Plus-Leitung an. Den Minuspul musste ich aber direkt an der Lötstelle der Batterien anlegen um zu messen.


    Habe allerdings immer noch einen 601 Diskette Control Error, bekomme ich einfach nicht in den Griff.


    An der Stiftleiste des Floppyanschlusses auf der Hauptplatine ist ein PIN abgebrochen. Also Diskettenlaufwerk ganz abgestöpselt, gleiche Fehlermeldung. Kommt die Fehlermeldung etwa grundsätzlich wenn kein Diskettenlaufwerk angeschlossen ist, bzw. nicht richtig angeschlossen ist?


    Daher bin ich am Überlegen. Löte ich die defekte Stiftleiste neu auf?

  • Bist Du Dir sicher, daß der abgebrochen ist ?

    Manchmal gibt es auch so seltsam modifizierte Stecker/Buchsen insbesondere in PC GErätschaft von Herstellern mit großen "Auflagen", d.h. sowas wie Compaq, die sich das leisten konnten 50000 Stück Stecker ohne Pin XY zu bestellen. Oft hat sowas nur den Hintergrund irgendwas zu verhindern, z.B. den internen Einbau eines zweiten Floppylaufwerks, wahrscheinlich damit man ein externes kaufen mußte, was es dann als Zubehör sicher gab.


    Großer Vorteil der Fehlermeldung: Die kann man rausbekommen ! Also was sie meint. Handbücher und Servicehandbücher kann man evtl. noch bei HP.com zu finden hoffen. Allerdings findet man da kaum noch was, seitdem da eine moderne "Wolke" mit zugehörigem Interface die Abfrage bildet.


    Manchmal hat es aber auch gar nichts zu bedeuten, der Error, sondern bedeutet evtl. nur, daß Dein CMOS noch immer keinen Strom abbekommt.

    https://www.unrelatedshit.com/…ror-what-it-really-means/

  • Tja, mit dem abgebrochenen PIN ist natürlich nur eine Vermutung. Sicher bin ich mir nicht, kann leider keine Abbildungen im Netz finden die meine Vermutung bestätigen oder entkräften. Werde mal weiter recherchieren. Vielleicht muss ich auch nochmal die Batterie-Zuleitungen prüfen.



    Es gibt ein Youtube-Video, fälschlicherweise mit 3/24zs bezeichnet, bei dem ist die Platine in ausgebautem Zustand zu sehen.


    An Stelle 0:42 lässt sich ein Blick auf Floppy und Harddisk-Anschluss werden, dort sollten die PINs des Floppyanschlusses komplett sein.


    https://www.youtube.com/watch?v=uNO5SImHr-4


    Und nochmal an Stelle 0:52. Die PINs sind alle komplett, alle 34.

  • Fehlender Masse-Pin (3) am Floppy-Port => Völlig normal, dient dazu, daß ein entsprechend kodierter Stecker nicht falschherum aufgesteckt wird.

    Fehlender Pin 20 am IDE-Port => auch völlig normal, gleiche Funktion.

  • Was mich verwundert, das dann überhaupt ein Stift(rest) zu sehen ist. Müsste dieser dann nicht komplett fehlen.


    Auf dem Youtube-Video sind alle PINs vorhanden. Wenn dieser aber prinzipiell keine Funktion hat, dürfte es doch nicht am Floppyanschluss liegen.


    Der Fehler verwundert mich eh, würde ja heißen, dass ohne Floppy kein Betrieb des PCs möglich wäre.


    Ich schaue nochmal nach der Stromversorgung. Auf der Platine sind ja drei Stellen für den Pluspol vorgesehen. Muss ich die dann alle drei verdrahtet haben,

    also mit entsprechender Batteriefassung?


    Ich habe derzeit einfach ein Kabel für Minus und ein Kabel für Plus (mittlerer Pluspol) angeschlossen.

  • Der Pin am Floppy-Port sieht für mich so aus, als wenn hätte den jemand nachträglich abgekniffen, um ein kodiertes Kabel (kein Loch an der Stelle) aufstecken zu können.


    PS.: Warum hast Du die Bilder wieder entfernt? Lass die doch bitte drin, das können für den nächsten mit einem ähnlichen Problem wertvolle Informationen sein.

  • Hole ich nach, die Fotos mit dem Harddisk-Anschluss sollten nicht zu Verwirrungen führen, deshalb wieder rausgenommen, bei diesem Anschluss ist mir der fehlende PIN bekannt.


    Hole ich nach, wenn ich auch wieder weiter gekommen bin mit meinem kleinen Projekt.

  • Also ich komme nicht weiter, interne wie externe Batterie 4,5V bringen mich nicht weiter. Den fehlenden PIN am Floppyport hatte ich überbrückt. Keine Änderungen. Die Fehlermeldung bleibt: 601 Diskette Control Error.


    Hier noch Fotos der Platine wie versprochen.