Atari 1040 STE Platine Rev 5.1

  • Atari Rechner sind für mich absolutes Neuland. Für einen bestimmten Zweck habe ich mir nun einen 1040 STE zugelegt. Ich habe ihn geöffnet, weil irgendwelche Partikel darin herumrappelten und auch weil ich den RAM aufrüsten möchte. Die Partikel stellten sich als Bruchstücke abgebrochenen Plastiks an Gewindebolzen o.ä. heraus. Nicht schön, aber unkritisch.


    Auf der Platine fand ich dann einen huckepack aufgelöteten Chip und ein paar nach Bastelei aussehende Drähte. Muss das so sein? Welchen Zweck könnte das haben? Ist das eine Umbau, eine Reparatur oder gar Atari Serienstandard?


    Sollte ich irgendwas prophylaktisch überprüfen, wenn ich den ST schon so weit zerlegt habe?


    Installiert sind vier gleiche RAM Riegel mit 256KBit Chips. Welche Riegel muss ich kaufen, um auf 4MB aufzurüsten? Auf welche Specs muss ich achten?


    Danke für Eure Tipps.


    VG Albert


  • Oh, da sitzt der Sound-Chip, ich hatte an den DMA-Controller gedacht.


    Auf jeden Fall geht da ein Kabel an den Soundchip Pin 22, das ist der Clock-Eingang. Diese Erkenntnis und ein bischen googeln lies mich das hier finden:


    https://www.atari-forum.com/viewtopic.php?t=23020


    Also möglicherweise fehlt auf deiner Platinenversion eine Verbindung, die mit diesem "Clockpatch" ab Werk nachgerüstet wurde. Im englichen Forum ist was im Zusammenhang mit Genlock zu lesen, aber das kann ich mir nicht vorstellen. Genaues werden wir vielleicht nicht rausbekommen. Aber es ist ab Werk und du bist nicht alleine.

  • Den Patch habe ich schon in STEs gesehen. Ich gehe davon aus das es von Atari gemacht wurde.

    Wenn ich mich nicht schwer irre, wurde der 74LS164 in späteren Layouts auf die Platine verfrachtet.


    Aber fragt mich nicht was für was der Patch da ist.

    Ständige Interessen: Atari 16/32 Bit - Atari Lynx / weitere Interessen: C64 - Atari 2600/7800 - Sega Mega Drive - Casio Digital Diary SF/CSF (alle Reihen - die sammle ich nicht nur, ich benutze auch) / Psion Serie 3/a/c/mx

    Zu neu für den Verein: Nintendo DS (komplette Reihe)

    Derzeit wieder im Fokus: mein Atari Lynx FlashCard Projekt.

  • Das ist so dermaßen schäbig gelötet, daß man kaum glauben mag, daß Atari das so ausgelierfert hat.

    Hat trotzdem Jahrelang funktioniert. ;)


    Gut, mein Anspruch erfüllt es auch nicht. (OK, habe ja auch Jahrelang Beruflich gelötet.)


    Und im Vergleich mit vielem was die User eingebaut haben und auch heute noch einbauen, ist es nicht so schlecht.

    Da habe ich von Leuten, die behaupten das sie löten können, schon einiges gesehen was nicht mal ansatzweise so gut war wie das von Atari "schäbig" ist.


    Und in dem Fall würde ich sagen, "never change a running system!"

    Ständige Interessen: Atari 16/32 Bit - Atari Lynx / weitere Interessen: C64 - Atari 2600/7800 - Sega Mega Drive - Casio Digital Diary SF/CSF (alle Reihen - die sammle ich nicht nur, ich benutze auch) / Psion Serie 3/a/c/mx

    Zu neu für den Verein: Nintendo DS (komplette Reihe)

    Derzeit wieder im Fokus: mein Atari Lynx FlashCard Projekt.

  • Und in dem Fall würde ich sagen, "never change a running system!"

    Das sowieso.


    Mein allererstes Aha-Erlebnis war zum Jahresende 1985 der Blick in einen neu gelieferten IBM PC-AT mit wahnsinnigen 640kB RAM. Kosten des Geräts: um die 15.000DM. Käufer war ein behördenähnliches Institut, das vor Jahresende noch Budget versenken mußte und folgerichtig das Gerät noch nicht mal gleich brauchte. Aber zur Technik: alle DRAM-Chips waren doppellagig gelötet und mit Hilfe von grünem Draht geeignet in einem dritten Layer verbunden. Bei der Preisgestaltung und dem Anspruch der Firma IBM fand ich das frech.


    Im Jahr 1989 hatte ich diese Lösung in einem Hobby-Projekt selber gewählt. Die Erweiterungsplatine, um einen Mac512 zu einem Mac Plus mit 2MB zu konvertieren wäre einlagig gegangen. Aber wir wollten die 4MB-Lösung:

    http://www.ralf-kiefer.de/Mac/RAM_SCSI/W004.jpg

    Geht doch :)

  • Nochmal zu meinem tollen STE. Sinn der Anschaffung war eine Plattform für OS-9 / 68K zu bekommen. Dafür benötige ich wohl einen anderen Massenspeicher als das eingebaute Floppy Drive. Empfehlungen laufen eindeutig in die Richtung UltraSatan. Bei der Suche nach Infos dazu bin ich auf die Seite http://joo.kie.sk/?page_id=250 gestoßen und musste leider feststellen, dass meiner zu den ab Werk kaputten STE mit dem bösen DMA Chip "C025913-38" gehört. Eine Lösung für das Problem habe ich nicht finden können. Heißt das, dass ich den Rechner verschrotten kann oder gibt es eine Möglichkeit, einen OS-9 tauglichen Massenspeicher daran zur Mitarbeit zu bewegen? Die 4 MB RAM hab ich natürlich schon bestellt...

  • Hallo,


    Der Patch kommt so von Atari, das kann ich bestätigen. Mein STE aus 1989 (immer noch erste Hand ;) ) hat diese Fädelei auch.



    Boardrevision ist ebenfalls 5.1 , ich habe noch ein STE-Ersatz-Board liegen (Rev. unbekannt, aber eines der letzten) da ist der

    Patch tatsächlich in das PCB versenkt worden.



    Die Funktion davon: Verzögerung des Sound-Frame-Int-Signals als MFP-Timer Input.

  • Boardrevision ist ebenfalls 5.1

    Ah ja, das klingt ja beruhigend, dass ich nicht allein auf der Welt bin mit so einem "schäbig gelöteten" Board ;)


    Hat Dein Board - oder auch beide - dann auch den bösen DMA Chip "C025913-38" eingebaut? Damit kann man ja angeblich nicht mal zuverlässig Disketten formatieren. Stimmt das?


    Hast Du an dem ASCI Port irgendwelche Massenspeicher erfolgreich in Betrieb?

  • und musste leider feststellen, dass meiner zu den ab Werk kaputten STE mit dem bösen DMA Chip "C025913-38" gehört

    Also verschrotten musst du garnix. Es gibt da durchaus Chancen, das zu fixen:


    http://www.exxoshost.co.uk/atari/last/DMAfix/index.htm


    Alternativ versuchen über jenen Exxos, oder über Best den richtigen DMA-Chip zu bekommen. Oder den STE gegen einen STFM tauschen, für OS-9 brauchst du eh nicht die Spezialitäten des STEs.

  • Hat Dein Board - oder auch beide - dann auch den bösen DMA Chip "C025913-38" eingebaut? Damit kann man ja angeblich nicht mal zuverlässig Disketten formatieren. Stimmt das?

    Das neue Board hat den "guten" C398739-001

    Das alte hatte einen C025913-38. Disketten waren bei mir nie ein Problem. Bei ACSI-Betrieb sollte es nur bei schnellen Platten Probleme geben. "Leider" hatte ich ein ICD-Quantum LPS Gespann dran, damit gab es wirklich Schwierigkeiten. Ich habe irgendwann einen C398.. gekauft und den alten ausgelötet und der neue ist nun gesockelt.::solder::

    Der genannte Fix ist mir bekannt, hatte ich vor dem Kauf auch versucht. Hat bei mir aber nicht geholfen :(

  • Also verschrotten musst du garnix. Es gibt da durchaus Chancen, das zu fixen:

    Moin, Moin. Also ich bin gestern mindestens dreimal weggedöst beim Versuch der ellenlangen Beschreibung zu folgen. Als Atari Neuling und nicht Elektronik Profi kann ich das kaum nachvollziehen. Was ist denn die Essenz? UltraSatan beschaffen und es drauf ankommen lassen? Vielleicht funktioniert es ja trotz STE mit angeblich von manchen für böse gehaltenem, aber nicht wirklich ursächlichem DMA Chip ohne Probleme? Falls es dann doch nicht klappt, dem STE eine CMOS CPU verpassen? Wenn ich das alles richtig kapiert habe, ist ja scheinbar das miese Platinenlayout in Verbindung mit impulsartigen Strömen der hohen Verbraucher namens CPU und ROM die Ursache. Ist das so richtig interpretiert?

  • Moin,


    meine bescheidene Meinung: ich würde zunächst gar nichts machen und es darauf ankommen lassen. Möglicherweise tritt das in Deinem Szenario überhaupt nicht auf. Wieviele STEs waren im Umlauf? Und richtig viel Echo gab es zu dem Thema nicht. Wenn Du von der SD-Karte ab und an ein Backup auf einem PC o.ä. machst, gibt es keinen üblen Datenverlust, wenn doch etwas sein sollte. Dann kann man immer noch handeln.


    Falls Du irgendwo den C3* auftust, löte ich Dir auch einen Sockel in das Board ;)

  • [...], für OS/9 [...]

    Es handelt sich um OS-9/68k. <klugscheiß_off> :)

    Denn so wäre OS/9 = 0,111 * OS

    Dagegen OS-9/68000 = OS - 0,000132. Das ist schon recht nahe dran an 1,0 für ein perfektes Betriebssystem.

    Für die aus der Welt der verdrehten Bytes gibt's OS-Halbe. Diese Rechnung überlasse ich deren Pentiümmern.


    SCNR, Ralf

  • Das man auf dem Rechner kein OS/9-386 laufen lassen kann, ist klar.

    Im Jahr 1989 brachte Microware das OS-9000 auch(!) für die verdrehte Welt wie z.B. den 80386.

    Ansonsten handelt es sich beim OS-9/68k für den ST um die V2.3 aus dem Jahr 1987.

    Ansonsten empfehle ich Dir einen Blick auf die Web-Seite von Microsys, dem heutigen "Hüter" des OS-9 in Europa. Ganz unten findest Du eine Aufstellung der aktuell unterstützten CPUs.

  • Heute habe ich mich erstmal um meinen 1040 STFM gekümmert, falls der besser geeignet sein sollte für OS-9 als der STE. Der STFM hat eine Diskette geschluckt und blockiert (mehr zur Floppy nach den Bildern). Also habe ich das Ding erstmal komplett zerlegt und auch hier wieder eine Platine mit schludriger Löterei vorgefunden. Ist das evtl. auch wieder eine Atari "ab Werk" Optimierung?




    Verbaut ist wie beim STE ein Epson SMD-380 Floppy. Nach Entfernen des Blechmantels war ich geschockt. Die Blechteile sahen aus als hätten sie Wasser gesehen und hatten an allen Ecken und Kanten weiße Ablagerungen, die wie Kalk aussahen. Der Mechanismus war total verklemmt, unbeweglich. Habe mir gedacht "Versuch macht kluch", wegschmeißen kannst du es immer noch. Also komplett zerlegt bis ich die Blechteile in der Hand hatte. Die habe ich im Ultraschallbad mit warmem Wasser und Zitronensäure sauber geschüttelt. Das hat tatsächlich die Ablagerungen beseitigt. Nach Zusammenbau habe ich vorsichtig alle Gleit- und Drehstellen mit etwas Teflon-Spray eingesprüht. Ich hätte es ja nicht geglaubt, aber das Floppy läuft wieder, liest, schreibt formatiert und der Auswurf geht auch wieder :) Ich hab es leider verpennt Fotos zu schießen.