IBM 5160 Reparatur

  • Hallo Leute,


    ich kümmere mich gerade um 2 x IBM 5160 und einen IBM Color Display Monitor CGA 5153.


    Netzteil ist OK ... und läuft an.


    Bei dem ersten IBM 5160 sind


    - eine SEAGATE ST-250R Festplatte (RLL)
    - Printer Adapter
    - IBM Monochrome Display and Printer Adapter
    - IBM Colour Graphics Adapter Card EC429
    - Floppy Disk Controller Card
    - RLL Controller Card
    - IBM Asynchronous Communications Adapter Card
    - 2 x 5.25" 360K Floppylaufwerke


    eingebaut. Die Karten sind alle ISA 8-Bit natürlich.


    Fragen:


    Beim Einschalten hat sich 1 Tantal Elektrolyt-Kondensator mit einem schönen Funkenflug von der CGA-Grafikkarte "verabschiedet". Hat die Grafikkarte eurer Einschätzung/Meinung nach ggf. einen größeren Schaden genommen ... oder abknipsen bzw. ersetzen reicht?


    Der Schreib-/Lesekopf der Festplatte (läuft hörbar an) scheint festzustecken. Von welcher Richtung aus müsste ich vorsichtig vorgehen ... um diesen zu lösen? Wer kann mir eine behutsame Vorgehensweise empfehlen?


    Die beiden Floppylaufwerke zeigen keine Reaktion. Warum ... weiß ich noch nicht!?


    Auf dem CGA-Monitor erscheint nichts, obwohl dieser OK zu sein scheint. Er geht ordnungsgemäß an und Helligkeit/Kontrast lassen sich regeln ... bei Einschalten des IBM reagiert der Monitor auch ... mit einem schwarzen Bild.


    Letzte Frage:


    Gibt es im IBM 5160 eine externe CMOS Batterie? In meinem IBM 5162 gibt es eine ... im IBM 5160 kann ich keine finden.


    Es gibt also mind. 2-3 Fehlerquellen gleichzeitig, was die Sache nicht gerade einfacher macht.


    Bin für jeden Tipp & Hinweis dankbar.


    Gruß,


    Erik

  • Die abbrennenden Tantalelkos verursachen normalerweise keinen anderen als den sichtbaren (Brand-)Schaden.


    Ich würde beim Testen systematisches vorgehen empfehlen:
    Erstmal nur das Mainboard mit Grafikkarte, alle anderen Karten raus.
    Wenn das läuft, jeweils eine der anderen Karten mit rein, und einzeln testen.
    So kann man nach und nach alle Komponenten durchprüfen.


    Wieso sind da sowohl MDA als auch CGA drin?
    Funktionieren die überhaupt zusammen?
    MDA bzw. HGC mit EGA oder VGA klappt, soviel ist klar.
    Aber MDA oder HGC mit CGA - Da habe ich Zweifel.

  • Hallo Christian!


    - abbrennende Tantalelkos ... OK ... muss ich mir nachher im Detail ansehen ... bin gerade bei dem zweiten IBM 5160 dran
    - systematisches Vorgehen ... :thumbup:´... ist klar ... das mache ich sowieso -> alle Karten raus ... soll ich erstmal nur 1 Boot-Diskettenlaufwerk (a:\) drin bzw. angeschlossen lassen?
    - alle Komponenten nach und nach durchprüfen ... OK ... mach ich
    - MDA und CGA? Das habe ich mich auch gefragt ... :grübel: ... du hast zurecht Zweifel. Da wird nur noch 1 Grafikkarte drinbleiben, die andere kommt raus.


    THX!


    Ist aber schon Wahnsinn, was da für alte, schöne Hardware eingebaut ist ... der andere IBM 5160 ist innen auch fett bestückt (6 Karten etc. pp.) ... gerade geöffnet.


    *staun*


    Wo und wie hält der IBM 5160 denn seine System-Konfigurationsdaten fest ... weißt du das? Scheint mir, alles hätte er alle Daten "verloren". Ich muss dann auf jeden Fall mal in den Handbüchern nachlesen ...


    Gruß,


    Erik

  • Der XT (5160) hat weder NVRAM zum Speichern der Konfiguration, noch ein BIOS-Setup.
    Die Konfiguration erfolgt über Jumper sowie BIOS-Erweiterungen auf den Erweiterungskarten.
    Einige Festplattencontroller speichern die Festplattendaten auf der Platte. Das Controller-BIOS liest diese dann beim Systemstart aus.


    Den ersten Versuch würde ich nur mit einer Grafikkarte machen und erst bei Erfolg den Floppycontroller einstecken.

  • Die abbrennenden Tantalelkos verursachen normalerweise keinen anderen als den sichtbaren (Brand-)Schaden.


    Hochgehende Tantals machen das gerne aufgrund interner Kurzschlüsse, d.h. sie werden niederohmig, und da sie oft als Puffer für die Versorgungsspannung dienen, fließt dann einiges an Strom durch, der sie dann explodieren lässt. Das hat bei mir schon Leiterbahnen gekostet, die einfach durchgeschmolzen sind. Ok, das war ältere Technik (unlackierte Platinen), aber das würde ich mal prüfen. Entweder Sichtkontrolle, oder durchmessen. In dem Fall die ja direkt am 5V und GND, d.h. Du müsstest von den 5V- und Masse-Kontakten der Karte einen Durchgang bis zu den Tantal-Anschlüssen haben.


    Dummerweise können diese Schäden theoretisch auch auf dem Mainboard passieren, aber die Leiterbahnen dort dürften dicker und damit unempfindlicher sein.

  • In dem anderen IBM 5160 steckt im zweiten ISA-Slot hinten links eine GeTeMed GmbH Berlin Uhrenkarte RTC01 <<285>> mit einem VARTA MEMPAC S 2.4V 100 mAh ... 3 x darf geraten werden, wie 1/3 des Slots ausschaut ... 8| ... schön giftgrün angedünstet & korrodiert ... hat mal eben 1 1/2 Stunden gekostet, um dass wieder einigermaßen zu entfernen und zu reinigen ... wieso sind es bei mir immer Uhrenkarten in Slot 2 ... schon das dritte Mal in diesem Jahr ... *grummel*

  • MDA sollte doch den gleichen Speicher wie die Hercules belegen also schön mit CGA tun? Da kann man dann auch schön 2 Monitore dran betreiben. Da legt man dann z.B. paar Aktienkurse drauf und sieht bei jedem Treffen gleich ganz doll wichtig aus! :P

  • Das mit den unterschiedlichen Grafikkarten ist wirklich nicht einfach ... komplizierte Materie ... da muss man echt aufpassen!


    http://www.minuszerodegrees.ne…s/5150_5160_cards.htm#cga


    http://www.minuszerodegrees.ne…s/5150_5160_cards.htm#ega


    Bloss gut, dass es diese Seiten gibt ... insbesondere dann wenn man nur den IBM 5153 Monitor hat ... und einem dann auch aus Rechner Nr. 2 eine IBM Enhanced Graphics Adapter Card (EGA) in die Hände fällt, die ganz anders konfiguriert ist, aber auch an einem 5153 betrieben werden kann ... da kann man sich - ohne es zu wissen - die Grafikkarte und/oder Monitor abschiessen. Echt nicht lustig!


    Na ja ... jetzt habe ich halbwegs den Durchblick und kann weitermachen ... :thumbup:


    Christian:


    MDA und CGA gehen doch zusammen in 1 IBM ... anscheinend:


    "The MDA and CGA cards can coexist in the same system, and this was very useful in older workstations to take advantage of each card's respective strengths. IBM intentionally designed these cards so their resources do not conflict. The MDA card must be designated as the primary display in the PC to prevent damage to the IBM 5151 Display. This is accomplished in a PC or XT or Portable by setting SW1 block switches 5 and 6 to Off. The On position on the dipswitch blocks for any of these motherboards is always toward the power connector, the Off position is toward the ISA slots."


    Gruß,


    Erik

  • HURRA ... der zweite IBM 5160 läuft jetzt ... der Monitor ist auch super OK ... gestochen scharf & hell ... DOS bootet von einer alten, pechschwarzen IBM TYPE 13 20MB Festplatte ... XT-Tastatur ist dran (ich Depp!) ...


    Willkommensbildschirm beginnt mit "Hallo Kerstin!" ... Rest folgt ...


    :thumbsup: :thumbsup: :thumbsup:

  • Der Willkommensbildschirm (wortwörtlich):


    "Hallo Kerstin!!!!


    Ich hoffe es geht dir gut, mir auch!!!


    Ich, der erfahrenste Olympia-Special-Trainingscomputer aller
    Zeiten, noch vor Deepsort, stehe dir nahmslos zur Verfügung!


    Stichtag ist der 1. Mai 1993. Also, Training, Training,
    Training, und nochmal Training. Aber vergiß nicht, "dabeisein
    freisein, highsein" ist alles.


    Du mußt meine kleinen Aussetzer entschuldigen, da ich, genau
    wie du, nicht mehr ganz taufrisch bin. Wir Alten verstehen
    uns da doch, oder?


    Wähle aus:
    1) Blockout 2) Arkanoid
    Viel Erfolg


    Wichtig !!! Vor Transport: Festplatte parken !!!!
    Befehl: PARK [und einfach ausschalten]"


  • Ui,


    mach davon mal ne Sicherung auf Disks oder so ;-)
    Sowas in der Richtung hat einer meiner Victos PCs auch xD wirklich mal ein Persönlicher Computer :thumbsup:


    Grüße,
    Marcus (der jetzt mit Frauchen Netflixt)

  • mach davon mal ne Sicherung auf Disks oder so ... der jetzt mit Frauchen flixtnet

    :D ... tja ... 1 x in der Woche musst du ran ... nee, im Ernst ... das ist ja nur in der autoexec.bat so reingeschrieben ... der Rechner muss jetzt erstmal 2 Stunden ununterbrochen laufen ... so eine Art "Belastungstest" ... der stand ja über 20 Jahre ohne Strom in einem Lager von meinem Abikumpel ... muss erstmal in Ruhe schauen, jetzt wo der schon mal läuft.


    Der andere IBM macht mir mehr sorgen ... ich glaube, dass da die RLL-Festplatte oder ggf. mehr hin ist! Mal sehen ... :thumbup:


    Gruß,


    Erik

  • Wie schon Toast_R schrieb, würde ich immer zuerst alle Karten entfernen und nur die Grafikkarte im äußerst linken Slot ( von vorne betrachtet ) einstecken und das System damit testen. Erst wenn der Rechner damit augenscheinlich fehlerfrei läuft ( er müsste nach dem Speichertest ins eingbaute Basic springen ) mit einer eventuellen Speichererweiterung und anschließend den Floppies weitermachen. Wenn er davon fehlerfrei eine DOS-Diskette booten kann, kämpft man sich zum Festplattencontroller vor... usw.
    Auf den damaligen All-in-One Speichererweiterungen ( Uhr+Ser+Par ) von Fremdherstellern waren auch gerne Akkus verbaut, die hier zerstörerisches Werk sowohl auf dem Erweiterungsboard, als auch auf dem Mainboard verrichten.
    Und beim Testen immer die korrekten Jumpereinstellungen auf dem Mainboard beachten. So habe ich ( bis auf defekte Platten ) alle meine IBM 51xx Systeme wieder in Gang setzen können. Her und da musste mal ein Kondensator ( auf einer Erweiterungskarte ) getauscht werden, weil ein Kurzschluss den Systemstart verhinderte.

  • Wieso sind da sowohl MDA als auch CGA drin?


    neben dem bereits erwähnten Mehrbildschirmbetrieb, gab es auch Tools um den Speicher der MDA-Karte als UMBs zu verwenden - allerdings macht das wohl mehr Sinn in Verbindung mit VGA/EGA.


    ich glaube, dass da die RLL-Festplatte oder ggf. mehr hin


    Inwiefern hin? Spur 0 Fehler? Head 0 Fehler? Defekte Sektoren? Headchrash auf EINER Platte?


    Sofern es eine Platte mit Schrittmotor ist, bekommt man die wahrscheinlich wieder zum laufen.
    Spurverstellung, Kopfamputation (ggf. mit Umverdrahtung z.b. um Kopf 2 zu Kopf 0 zu machen) und Formatierungstricks (z.b. Partition um ein paar Spuren nach hinten schieben damit das Dateisystem in eine fehlerfreie Lücke rutscht) - alles schon gehabt...

  • Hallo Leute!


    Ich habe alle Karten aus dem IBM 5160 (Nr. 1) ausgebaut und den geplatzten Tantal E.-K. auf dem Mainboard direkt bei den ISA-Slots am Slotblech gefunden.


    Frage in die "kleine Runde": Kann ich den einfach abknipsen und den Rechner dann testweise anschalten?


    Eine Antwort um diese Uhrzeit wäre super ... ;)


    Gruß,


    Erik

  • OK ... erstmal THX ... schon abgeknipst die geplatzte Tantalperle. Der erste Rechner gibt jetzt auch ohne Karten (außer Grafikkarte) weiter keinen Mucks von sich ... bis auf den Lüfter vom Netzteil ... und die Festplatte summt leise vor sich hin. Jetzt muss ich doch alles zerlegen und tiefer einsteigen und prüfen, was ich mit meinen Mitteln so prüfen kann.


    Notfalls bräuchte ich dann doch eure "Profihilfe" hier im Forum ... mal schauen, wie weit ich heute komme.


    Momentan habe ich noch nicht mal ein Bild ... auf dem Motherboard ist übrigens alles richtig gejumpert, doppelt und dreifach überprüft.


    :grübel:


    Gruß,


    Erik

  • Vielleicht wärs mal ganz hilfreich, ein Diagnostic ROM einzusetzen. Auf MinusZeroDegrees gibts das von Supersoft/Landmark, das hat mir schon einige Male geholfen. Hier der Link: http://minuszerodegrees.net/su…soft%20Landmark%20ROM.htm. Auch dieser Link ist interessant: http://minuszerodegrees.net/failure.ht


    Vielen Dank ... gleich mal schauen ... nicht, dass glatt die CPU hinüber ist ... ich muss mir aber erstmal das Netzteil und nochmal die Versorgungsspannungen ganz genau ansehen ... ;)

  • Aus der c64 Welt kämen jetzt die Standard-Ratschläge...


    - Wird ein Ram warm?


    - Hast Spannung, GND und Reset an der CPU?

    Rechner ist mittlerweile komplett zerlegt ... Gehäuse entrostet & gereinigt, Motherboard (64-256KB System Board; es gibt da 2 Varianten) war total siffig & vestaubt & korrodiert an den gesockelten IC-Beinchen ... auch alles sauber gemacht.


    Der Tantal auf C56 gehört zur +12V Versorgungsleitung für die ISA-Slots.


    Es gibt 3 Hauptfehlerquellen:


    - Netzteil
    - Kurzschluss auf dem Motherboard
    - defektes RAM in Bank0


    Die Reparaturschritte sind hier genau und sehr gut beschrieben:


    http://www.minuszerodegrees.ne…C/minimum_diag_config.htm


    Fehlerbild:


    - Netzteillüfter läuft kontinuierlich ... aus dem Lautsprecher kommt "NO BEEP".


    Folgende DRAMs sind vorhanden, die ich gerade aber alle herausgezogen habe:


    Bank 0: 9 x MK4564N-15 Mostek NMOS
    Bank 1: 9 x MK4564N-15 Mostek NMOS
    Bank 2: 9 x MCM6665AP20 Motorola NMOS
    Bank 3: 9 x MCM6665AP20 Motorola NMOS


    Das sind alles vom Typ her 4164 DRAMS, die ich noch einzeln säubern und prüfen muss. In Bank 0 (Mindestbestückung) werde ich dann 9 gute, geprüfte, gleiche DRAMs einsetzen. Gleichzeitig prüfe ich heute abend +5V/-5V/+12V/-12V an den P8/P9-Steckern auf dem Mainboard. Ggf. schließe ich das funktionierende Netzteil aus dem anderen IBM 5160 an, um den Fehler weiter einzugrenzen -> d.h. Fehler muss auf dem Motherboard liegen.


    Dann kommen noch alle Tantal Capacitors in Betracht, die äußerlich OK aussehen, aber trotzdem einen Kurzschluss haben können.


    Mal sehen heute ... ;)


    Gruß,


    Erik