Olivetti SNX 140/S - der Umrüst-Thread

  • Diese SNX 140/S habe ich gestern bekommen, ein toller PC, aber kann noch besser werden...


    Eckdaten:

    - Pentium 166

    - PCI/EISA Bussystem, jeweils 3 Slots, die mittleren beiden sind "shared", können also nicht gleichzeitig bestückt werden

    - 32 MB RAM, aufrüstbar mit 6 weiteren PS/2 Slots

    . 512 kB Trident Grafikkarte onboard (lässt sich per EISA-Setup abschalten)

    - Adaptec AIC-7850 Wide SCSI Controller onboard

    - 8 GB SCSI Platte, installiert ist Windows 2000 Pro (möchte ich als Dualboot erhalten)

    - 1.44 und 1.2 Mb Floppy

    - keine IDE-Interfaces


    Installierte Erweiterungskarten:

    - 2-Port USB PCI-Karte mit VIA Chipsatz

    - 100 MBit PCI Netzwerkkarte


    Spezfikationen und Beschreibung im Anhang. Olivetti hat die SNX-Serie laut Doku tatsächlich als "Server" klassifiziert, deswegen die magere Grafikkarte. Ich will aber daraus eine zeitgenössische Workstation machen, spieletauglich, wo aber die begrenzte Anzahl Slots enge Grenzen setzt.






    Was will ich erhalten:

    - Netzwerk

    - USB (aber gegen eine vorhandene NEC USB 2.0 PCI Karte tauschen, für die es 98SE und 2000 Treiber gibt)

    - Windows 2000


    Was will zusätzlich ich haben?

    - Bessere PCI-Grafikkarte (onboard lässt sich abschalten)

    - möglichst gute Soundkarte (wegen der begrenzten Anzahl Slots und einfacherer/besserer DOS-Unterstützug am ehesten eine ISA-Karte (ein gewisser Fundus ist vorhanden)

    - Dual Boot mit MS-DOS bzw. Win 98SE, zweite Platte würde Platz finden, und es sind ein paar Wide-SCSI-Platten im Fundus

    - Internes ZIP Laufwerk (SCSI LW vorhanden), könnte über einen zusätzlich vorhandenen EISA-SCSI-Controller erfolgen (Adaptec 1740, 2740, etc, vorhanden)


    Ansonsten ist die Kiste ganz nett, ich glaube, 32 MB RAM ist auch erstal ausreichend, wenn sich aber mehr fände, was da rein passt, hätte ich auch nichts dagegen.


    EISA Setup Disketten sind vorhanden und millionen EISA CFGs füt alles mögliche an Karten auch.

  • So, ich habe mal im Fundus gewühlt und verschiedene PCI Grafikkarten gefunden. Welche ich davon nehme, hängt davon ab, welche in dem PC am meisten Sinn macht (ausgewogendes Leistungsverhältnis zwischen Grafikkarte und Pentium 166 (evtl. auf 200 aufrüsten, wenn ich einen für Sockel 5 auftreiben kann?)), und wo noch Treiber aufzutreiben sind.



    - ATI 3D RAGE II+DVD mit Composite+S-Video Out. wiewviel RAM die hat, weiß ich nicht mehr, vielleicht 4 MB

    - S3 Virge/DX, wieviel RAM die hat, weiß ich auch nicht mehr

    - Weitek P9100 mit IBM RAMDAC, 4 MB, die hat ein gutes VESA-BIOS, einst habe ich die zusammen mit einer Voodoo 1 betrieben, das war ein tolles Gespann. (2 Stück vorhanden)

    - Cirrus Logic CL-GD5434, die ist auf 4 MB aufgerüstet

    - Diamond FireGL 1000 mit 3DLabs Permedia/Glint-Chipsatz, IBM RAMDAC

    - MSI MS-4411 auch mit 3DLabs Permedia/Glint-Chipsatz, TI RAMDAC


    Welche davon passt am Besten, und wo finde ich Treiber? (Win 9x+2000) (ich werde nachher selber mal googeln aber vielleicht hat ja jemand was parat)

  • Erste seltsamme Erfahrung: Das EISA-Setup erkennt die NEC USB 2.0 PCI Karte nicht, die VIA-USB-Karte dagegen wird als "Serial Controller" erkannt und ich kann die Ressourcen einstellen. Allerdings Windows 2000 findet die NEC Karte und bindet sie auch korrekt ein, IRQs waren damals ja immer so ein Problem, das hat aber geklappt. Aber das BIOS meldet bei jedem Rechnerstart einen Konfigurationsfehler, der sich mit dem EISA-Setup nicht bereinigen lässt. Also habe ich wieder zur VIA-Karte zurück gewechselt, dann müssen halt mehr USB-Geräte per Hub dran. Seltsammerweise läuft die jetzt problemlos.

  • Vorerst habe ich mich bei dem Rechner für die Weitek P9100 entschieden. Erstaunlicherweise, ich bin ja der Meinung gewesen, die Karte wäre ein echter Exot, habe ich für diese die meisten Treiber gefunden, alle erdenklichen Windows-Geschmackrichtungen von 3.1, 9x über NT 3.5x bis XP, OS/2, Linux und für diverse DOS-CAD-Software, und auch den tollen DOS-VESA-Treiber habe ich gefunden. Fündig bin ich geworden bei einem, der Treiber für die Dsystems Papillio gesammelt hatte, und genau das ist die mir vorliegende Karte, als ich die Webseite gefunden habe, fiel mir diese Name wieder ein. Allerdings bevorzugt Windows 2000, den Treiber für die Diamond Viper PCI, und damit geht die Karte. Damit stellt Win 2K den Desktop in 1024x768, 1280x1024 und 1600x1200 dar, die ersten beiden geannten Auflösungen in 32 Bit, die letzte nur noch in 16 Bit. Allerdings ist der kleine EIZO-TFT gerade mal todesmutig, der hat nämlich nur 1024x768 Bildpunkte, bekommt die anderen beiden Auflösungen aber unter Protest irgendwie auch noch erkennbar hin. Morgen kümmere ich mich als nächstes um die Soundkarte.


    Mit Leselektüre, falls es wieder mal etwas länger mit Plug&Pray dauert...


    1600x1200 stellt er unter Protest auch irgendwie erkennbar noch dar!


    Für die anderen Grafikkarten habe ich auch diverse Treiber gefunden, aber längst nicht so üppig...


    Randnotiz: Man kann zwar im EISA-Setup die Onboard-Grafikkarte abschalten, Windows 2000 findet sie aber trotzdem, wenn auch mit (!) Ausrufezeichen im Gerätemanager. (An/Aus im EISA-Setup ist egal, sie wird immer mit (!) gefunden)


    Jetzt zocke ich erstmal Solitaire... (Gute Nacht!)

  • Ich bin gerade etwas ratlos... eisapc  Shadow-aSc  escimo  Schroeder  Richi  Toast_r und wer sich sonst zu EISA berufen fühlt...- habt ihr eine Idee?


    Ich habe heute Abend (Nacht!) mal wieder an dieser SNX rumgebastelt. Soundkarte läuft, ich habe mich für eine Soundblaster 16 Vibra PNP CT2890 entschieden. Das war einfach. Karte rein, EISA-Setup gestartet, es erkennt die PNP-Karte ohne nach einer CFG-Datei zu schreien, fragt in welchem Slot sie steckt, und sie bekommt gängige Ressourcen (IRQ 5, DMA 1+7, 220h, usw.). Auch Windows 2000 erkennt die Karte sofort, auch den integrierten IDE-Controller.


    Dann will ich einen weiteren SCSI-Controller haben, damit ich extern SCSI-Laufwerke oder vielleicht sogar so ein externes SCSI-Gehäuse an dem PC anschließe zu können, ohne den onboard SCSI-Bus nutzen zu müssen, wegen Terminierungs-Problemen, SCSI-ID-Konflikten usw., die ich da vermeiden will. Da nur noch ein EISA-Slot frei ist, entscheide ich mich natürlich für EISA, zur Wahl habe ich diverse, wobei ich den Zweikanal Olivetti-Adaptec und den Tekram DC810 für die LSX5020 aufheben möchte. Somit steht ein Stapel Adaptec AHA 1740 und eine einzelne 2740 Karte zur Verfügung. Bei den 1740 habe ich die Auswahl zwischen zwei ziemlich verschiendenen Versionen, die eine wird vom EISA Setup als "AHA-1740 Early Revision" erkannt, und die andere schlicht als AHA-1740.


    Alle drei Controller verhalten sich gleich, sie lassen sich nach Laden des entsprechenden CFGs im EISA Setup konfigurieren, und wenn ich da das BIOS der Controller einschalte, meldet sich das nach einem Reboot auch und meldet, dass keine Platten angeschlossen sind und somit das BIOS nicht installiert wird. Da diese EISA-Controller aber vom Mainboard-BIOS gestartet werden, bevor der Onboard-SCSI-Controller startet, habe ich das BIOS der Controller im Setup abgeschaltet, damit sich keine später mal angeschlossene Platte (extern) in der Bootreihenfolge vor die interne Platte davor mogelt.


    Soweit alles gut, aber jetzt kommt das komische. Windows 2000 findet alle drei Controller-Typen nicht! Keine unbekannten Geräte, schlicht nichts. Die in EISA-Setup eingestellten Ressourcen (IRQ, DMA, IO) bleiben im Gerätemanager schlicht frei. Was könnte das sein? Die einzige Idee, dir mir gerade kommt, wären falsche Versionen der CFG-Dateien, für beide, eigentlich alle drei Controller, habe ich verschiedene Versionen der CFG-Dateien, die zwischen 1991 und 1994 datiert sind. Ich habe jeweils die Neuesten genommen. Muss ich die jetzt echt alle durchprobiert, ihr wisst vielleicht, wie lange das (von Floppy, und dann 2000 booten...) dauert...


    Oder ist das was anderes? Wie geschrieben, das EISA-Setup erkennt die Controller, und wenn deren Option-ROM eingeschaltet ist, melden die sich auch beim BIOS-POST. Unterstützt Windows 2000 diese Controller vielleicht nicht?


    Ein paar Bilderchen...


    EISA-Setup Mainboard Ressourcen


    Soundblaster-Ressourcen im EISA-Setup


    1740 Early Revision im EISA Setup. Beim anderen 1740 sieht es genauso aus, nur dass der Text "Early Revision" fehlt. Ohne EISA-Setup zu durchlaufen sind die nicht gegeneinander austauschbar, auch wenn beide die selbe CFG/OVL Datei benutzen.


    Der 2740, er wird hier als Hewlett-Packard Controller angezeigt.


    Oben: Adaptec AHA-1740 (davon hab ich 4, einer davon ist sogar ein 1742 mit Floppycontroller)

    Unten: Adaptec AHA-1740 Early Revision (davon hab ich 3)


    Der 1740 ist schwer reinzufuddeln, weil er die komplette Baulänge ausfüllt


    Der 2740 macht da eindeutig die schlankere Figur. Aber mir wäre der 1740 eigentlich lieber, denn da habe ich so viele davon...


    Windows 2000 beschnüffelt den Soundblaster...


    Soundblaster vollständihg erkannt. Aber das Problem ist nur, im WIndows 2000 Gerätemanager taucht weder einer der 1740 auf, noch der 2740 auf. Der angezeigte AIC-7850 ist der Onboard-PCI-SCSI-Controller des SNX-140/s PCs. (das müsste im Prinzip ein AHA-2940 sein)


    Jede Idee ist willkommen, vorzugsweise will ich einen der 1740 darin haben. Der 2740 hat auch einen Floppycontroller (per Jumper ausgeschaltet), der sich wenn eingeschaltet, auch im EISA-Setup als sekundärer Controller einstellen lässt, was ich in einer LSX 5020 noch gebrauchen kann...

  • Genau das gleiche habe Problem habe ich mit einem ISA Adaptec parallel mit einem Tekram. BIOS vom ISA ist deaktiviert, Win 98 SE erkennt den falsch. Ich muss vorher den ASPI Treiber laden.

    Hast du die ASPI Tools für 2000? EZ-SCSI 5.01 verwende ich.

  • soweit ich weiss - muss selbst, wenn du 2 oder mehrere Controller im System hast - die SCSI ID trotzdem eindeutig sein

    ..zumindest bin ich damit immer bislang am besten gefahren - haben die beiden Controller vielleicht zufällig die gleiche ID (7) ?


    bei Win2000 weiss ichs nicht ganz genau, aber bei WinNT 3.x bzw. 4.0 wars immer so, dass bereits bei der Installation die SCSI-Controller mit eingetragen werden wollen ....ich weiss nicht, wie oft ich mein NT4 installiert hab, bis das so lief, wie ich das wollte.....


    vor allem, NT4 fragt ja nicht nach - sondern "erwartet", dass man genau zum richtigen Zeitpunkt .... ich glaube F4? - drückt, damit man ihm dann den SCSI-Treiber "geben darf"


    ich hab mich am Schluss für son ne SCSI-Slotblende entschieden:

    https://www.ebay.de/itm/SCSI-A…4e00ae:g:hfkAAOSw0eNdalMm


    ..sowas z.B.


    ich hab nämlich auch diverse externe SCSI-Gerätschaften

    achso - und SCSI bitte nicht "hotpluggen"

    schön brav Rechner aus- dranhängen - neu starten

  • Das ASPI-Gedöns für 2000 mal zu istallieren ist eine Idee, kann man sowieso gebrauchen. Hat jemand einen Download-Link? (Edit: Hier )


    Die SCSI-ID hat damit sicher nichts zu tun, ich hatte früher mal in meiner LSX aus Spaß 4 SCSI-Controller drin (hab ja genug, und leere Slots sind schlechte Slots...), eine "doppelte" SCSI-ID beim Hostadapter spielt keine Rolle, solange man nicht die SCSI-Busse miteinander verbindet.


    Das Einbinden des SCSI-Treibers zum "richtigen" Moment bei der Installation ist eine andere Sache, da gehts ja um den Treiber fürs Bootlaufwerk. Windows 2000 sollte aber alle Adaptec ISA/EISA-SCSI-Controller automatisch erkennen. Ich teste nochmal mit dem 2-Kanal-EISA und dem Tekram, ud wenn ich dran komme (in einer Kiste im Regal hinter viel anderem Zeuch gelagert) auch mal mit einem Olivetti ESC-1 (Original SCSI-Controller in der LSX-5010/5020 bzw. CP-486) und einen AHA-1540A/C gegen.

  • Das Ganze ist sehr misteriös. Ich habe inzwischen auch den Tekram DC810 und den Olivetti-Adaptec-2740T und den Olivetti ESC-1 aus der LSX5020 getestet. Letzterer geht garnicht, wenn der drin steckt, bootet der SNX nicht, nachem der POSt durchgelaufen ist, aber das war zu erwarten. Der ESC-1 ist sehr speziell und läuft nur in der LSX5010/5020. Auch der Tekram und der 2740T werden unter 2000 nicht gefunden, vom EISA-Setup aber schon, und auch das Tekram-BIOS erscheint beim POST.


    Zuletzt habe ich jetzt einen popeligen AHA 1540CF reingesteckt, auch der erscheint unter Win 2000 nicht, obwohl ich ihn auf freie IRQ, DMA, IO gestellt habe, und im SCSI-BIOS der ganze Selbsttest mit DMA-Test zum System-RAM wunderbar funktioniert.


    Ich glaube, ich tausche die Soundblaster mit dem SCSI-Controller im EISA-Slot...

  • hmmm - bin echt gespannt, ob dus hinkriegst

    ich hab ein SyQuest-Laufwerk, das gerne ganz allein am Bus hängt - sonst macht es Zicken - aber bei dir hängt ja eigentlich gar nix an den Controllern ... und trotzdem melden die sich nicht bei Win2000?

  • Vermutlich lädt Windows den Treiber nicht, so lange keine SCSI Geräte dranhängen? Ich hatte damals den 1740 als Zweitcontroller im Deskpro /XL und nur einen Scanner dranhängen. Das BIOS braucht es dann auch nicht, wenn nicht die Bootplatte daran hängt reichen die ASPI Treiber (ASPIEDOS.SYS und ASPIDISK.SYS). OS war glaub ich auch 2000, oder sogar noch NT. Im EZ-SCSI Tool sollte der Controller aber auftauchen.

    Interessanterweise ist die Funktion den SCSI Bus bei laufendem OS zu Scannen bei den Bandlaufwerken in der Systemsteuerung versteckt.


    Die SCSI ID ist egal, da es ja ein separater Bus ist, da darf ruhig jeder Controller für sich die ID 7 haben.


    Der ESC-1 hat vielleicht auch ein spezielles BIOS, ich bin mir nicht sicher ob ein 1740 mit Alpha BIOS noch in einem PC läuft.


    Das dein 2740 als HP Produkt angezeigt wird, dürfte am cfg liegen.


    Der Warnung vor Hot Plug von SCSI bei nicht explizit dafür vorgesehenen Komponeten kann ich mich anschließen. Ein Kumpel hat sich damals damit seinen Controller geschrottet. PS/2 kann da übrigens auch eine Mimose sein.

    eisapc

  • Ich habe nochmal nachgesehen, wenn ich in der Systemsteuerung auf Hardware gehe und dort hinzufügen, manuell auswählen, SCSI und dann Adaptec, dann bekomme ich keine EISA-Karten angezeigt, nur PCI und ISA. Ich habe gestern Abend nochmal gesucht und Adaptec EZSCSI Version 5 und 6 gefunden. 5 ist für NT und bringt aktualisierte Treiber für NT mit, auch für AHA-17xx und 27xx, aber 2000 will die nicht. EZSCSI 6 ist von 2002 und hat keine Treiber dabei. Auch sonst finde ich keine 2000er Treiber für die EISA-Controller von Adaptec. Für mich sieht das momentan so aus, als ob Adaptec und Windows 2000 keine EISA-SCSI-Controller (zumindestens von Adaptec) supportet.


    Ich habe noch zwei EISA-Netzwerkkarten, mit denen mache ich mal einen Gegentest, wenn auch die von Win 2000 nicht erkannt werden, vernute ich, dass Windows 2000n (Pro) in Bezug auf EISA irgendwie "gerupft" ist. Oder hat hier irgendjemand einen EISA-PC mit EISA-Karten und Windows 2000 am Laufen?


    Ich schnappe mir mal eine andere Platte und installiere da mal testweise 98SE.

  • Ich habe ziemlich sicher noch auf mehreren EISA Maschinen W2K installiert. Bei den Adaptec Controllern bin ich allerdings auch nicht 100% sicher, da ich meist RAIDcontroller eingesetzt habe. Besagten Deskpro /XL muss ich halt erst mal im Keller suchen. Einen Proliant 850R oder 2500 hab ich dagegen noch in der Wohnung stehen.

    eisapc

  • Vermutlich lädt Windows den Treiber nicht, so lange keine SCSI Geräte dranhängen?

    Also bei meinen PCI-Adaptec-Teilen installiert das BIOS sich nur, wenn SCSI Devices am Bus erkannt werden.


    Die Probleme mit dem AHA-1542CF könnten auch auf ein wenig bekanntes Detail zurückzuführen sein, dass das Teil ein BIOS-RAM enthält: das BIOS wird entsprechend der konfigurierten Werte gepatcht ins auf der Karte enthaltene RAM kopiert, wg. schnellerem Zugriff.

    Das wiederum impliziert einige Kleinigkeiten: Shadowing darf (wenn überhaupt) erst nach dem BIOS-Initialisierungsdurchlauf eingeschaltet werden.

    Und da könnte ich mir vorstellen, dass das mit EISA Probleme macht. Wie sieht es denn aus, wenn man es mit einem 1542B versucht?


    Überhaupt, EISA ist damals ganz an mir vorbeigegangen... es war genauso eine Totgeburt wie MCA. Habe selbst nie mit sowas zu tun gehabt.

    Der interessante Erlebnisbericht von 1ST1 veranschaulicht mir deutlich nachfühlbar, was für ein Horror das EISA-Gedöns gewesen sein muss... vielen Dank 1ST1 !

  • Der Hostdadapter muss von Windows immer gefunden werden, egal ob das BIOS eingeschaltet ist, oder nicht, sofern er Ressourcenmäßig keine Konflikte hat (was bei einer EISA-Karte nahezu unmöglich ist, sofern man alle Ressourcen auch von reinen ISA-Karten anmeldet). Wenn das nicht tut, muss das mit Eigenheiten von Win 2000 (Pro) zu tun haben. Deswegen will ich ja mal 98SE installieren, das verhält sich wahrscheinlich anders. Gute Erfahrungen hatte ich einst mit Win 95, OS/2 Warp 3, NT4 und Linux (Suse 5.x, Slackware) gemacht, ja und mit Netware 3.x, allerdings war das noch ein reines EISA-System (LSX 5020) und kein PCI/EISA-Mischsystem wie dieser SNX.

  • Überhaupt, EISA ist damals ganz an mir vorbeigegangen... es war genauso eine Totgeburt wie MCA. Habe selbst nie mit sowas zu tun gehabt.

    Der interessante Erlebnisbericht von 1ST1 veranschaulicht mir deutlich nachfühlbar, was für ein Horror das EISA-Gedöns gewesen sein muss... vielen Dank 1ST1 !

    EISA und MCA waren für damalige Verhältnisse ja schon ein deutlicher Fortschritt was die Resourcenverwaltung anging. Wenn ich mich dagegen an so Verrenkungen mit ISA PnP unter DOS oder den Resourcenkonflikten unter DOS erinnere. Das war dann das pure Grauen.


    Gerade der Exotenstatus und die daraus folgende Ablehnung durch die breite Masse macht die Geräte aus heutiger Sicht doch deutlich spannender und interessanter.

    Gut die Suche nach passenden cfg-Dateien oder Referenzdisketten ist mitunter recht aufwändig, aber das kann die Suche nach den Treibern für PCI oder ISA-Karten auch sein.

    eisapc

  • Kann das sein, daß die von Windwos 2000 garnicht mehr unterstützt werden?

    Folge mal hier den entsprechenden Links. Demnach hört der Spaß da bereits bei NT 4.0 auf.


    Ansonsten würde immer erstmal versuchen, den Treiber selbstbestimmt zu installieren, egal ob Windows das jetzt für 'ne gute Idee hält, oder nicht.

    Systemsteuerung -> Hardware -> Gerät hinzufügen -> Neues Gerät hinzufügen -> aus Liste Auswählen -> Datenträger (sofern man den Treiber hat).

  • Gut die Suche nach passenden cfg-Dateien oder Referenzdisketten ist mitunter recht aufwändig,

    Was CFG-Dateien angeht, einfach mich fragen... Ich habe über 30.000 (allerdings für viele Karten quasi viele mehrfach, da verschiedene Dateiversionen vorliegen).


    Ablehnung durch die breite Masse

    Das war eher eine Kostenfrage... EISA- und MCA-Systeme waren damals schon teuer. Bei MCA kommt erschwerend dazu, dass man viele Erweiterungen dafür garnicht oder nur sehr schwer und teuer bekommen hat, eine Soundblaster dafür zu bekommen, ging schon damals mächtig ins Geld.

  • W2K geht, definitiv und ist auch bei Adaptec "confirmed".

    Hast du da mal einen Link? Betrifft das viellecht nicht die Pro, sondern nur den Server?

    Das hatte ich selber am laufen, bei dem Rechner habe ich vor wenigen Wochen Windows 98 SE darüber gebügelt. Da hatte ich übrigens das gleiche Problem wie Anfangs mit W2K. Da war Pro drauf, glaube ich ... Asche auf mein Haupt!

    Soundblaster war eine CT1600.

    Auf einer der Adaptec Seiten steht wo, das es bis 98SE und W2K mit den EZ-Tools 5.01 geht und die habe ich benutzt.

  • So, ich bin mal einen winzigen Schritt weiter gekommen... Im SNX läuft eine EISA-Netzwerllarte. Also, EISA geht auch unter 2000. Eine 3Com 3c579 Etherlink III EISA. Ich habe noch eine zweite EISA-Netzwerkkarte, aber für die habe ich noch kein CGF File gefunden. (!COG9001.CFG), das muss ich aber mal gehabt haben, denn die hatte ich damals in meiner LSX am Laufen.


    Ich habe eine Diskette im Bestand, da müsste das CFG für die Cogendt-Netzwerkkarte in einem Unterordner drin sein, aber die DIsk bekomme ich nicht eingelesen, nach jedem Versuch ist das Laufwerk so verwirrt, dass es keine anderen Disketten mehr lesen will (mit mehreren Laufwerken getestet) - erst nach einiger Weile, diversen Leseversuchen, Reboot, usw. irgendwann gehts dann wieder, sowas hab ich noch nicht gesehen... (Die Diskette sieht eigentlich noch gut aus, keine Schleifspuren und Laufgeräusche...)

  • So, noch ein Schritt weiter... duckduckgo war mein Freund, mit dieser Suchmaschine fand ich einen FTP-Server einer taiwanischen Uni, wo es einen Cogent-Ordner (im Adaptec-Ordner) gab. Und es ist erstaunlich, was alles doch noch im Kopf hängen bleibt, denn alls ich dort den Dateinamen em932.exe sah, hat es sofort klick gemacht und ich wusste, da drin werde ich fündig...


    ftp://ftp.dyu.edu.tw/pub/Hardware/vendor/ADAPTEC/cogent/



    Taraaaa, !cog9001.cfg, die Netzwerkkarte ist im EISA-Setup angemeldet. Jetzt gleich schaue ich, ob die Karte auch unter Windows 2000 funktioniert.


    Edit: Nein, ich habe keine Win2K Treiber für die Cogent-Karte, nur NT4. Aber gut, das ist Vorarbeit, die noch noch brauchen kann, wenn ich die beiden LSX wieder aufbaue, denn da brauche ich ja auch Netzwerkkarten. Und da kommt garantiert kein 2K drauf, sondern NT 3.51 oder 4, und OS2 Waro 3 und Win 95 läuft auch darauf.

  • So, Schnauze voll von EISA-SCSI mit Win 2000... Manchmal muss man einfach pragmatisch sein, jetzt ist ein Adaptec 1540CF drin, mit einem CFG für den 1540B im EISA-Setup angemeldet und manuell über den Hardwareassistenten von Win 2000 hinzugefügt. Zwar ein bischen schade, ich hätte gerne wenigstens eine echte EISA-Karte drin gehabt, aber es geht halt mit Win 2K nicht. Den Tekram DC810 hätte ich unterbringen können, der geht ja auch mit Adaptec 154x Treibern, der ist mir aber als Zweit-Controller im SNX zu schade, der kommt wieder in die schnellere von den beiden LSX rein, da kommt der Cache-Controller besser zur Geltung. Der 1540CF kann genau wie ein 1740 10MB/s, zumindestens auf SCSI-Bus-Seite, ob er das auch über ISA schaufeln kann, werde ich sehen, und wenn nicht, auch nicht so schlimm.


    Ich will mit dem Rechner weiter kommen, das ist mir erstmal wichtiger. Als nächstes schaue ich mal, wie ich eine zweite Platte da hinein bekomme. Dazu werde ich sicherlich die SCSI-Verkabelung verändern müssen.


    Juchuu, 2 SCSI-Controller...!


    Jetzt die Frage, wie gehe ich am schlauesten vor, um da MS-DOS bzw. Win 98SE parallel zum vorhandenen Win2K auf eine andere Platte zu installieren? So herum habe ich das noch nie gemacht, normalerweise immer erst DOS (Win 9x) und dann NT/2K. Momentan geht meine Idee in folgende Richtung: Die 2K Platte erstmal abklemmen, DOS/Win98SE auf der anderen Platte komplett installieren, und dann beide Platten dran, Win2K auf SCSI-ID 0, DOS/Win9x ID 1. Und dann den Win2K Bootmanager passend konfigurieren. Toast_r - ich glaube du hattest da was erwähnt?

  • von Partition Manager gibts nen tollen Bootmanager - der kann sogar Platten bzw. Partitionen "hiden" - also verstecken

    so hab ich das gemacht

    damit ist dann auch sichergestellt, dass das jeweilige Windoof immer auf "C" installiert ist und zugreifen kann


    ...aber den genauen Namen kann ich grad nicht sagen

    den kann man aber immerhin jederzeit installieren - der hängt sich in den MBR soweit ich weiss

  • Naja, wenn die Win2K Platzte ID 0 ist, und die Win98 Platte ist ID 1, wird es unter Win2K keine Vertauschung geben. Und da Win98 NTFS nicht lesen kann, wird die FAT32-Platte auch C: bleiben. Da mache ich mir keine Sorgen. Ich weiß nur nicht, was mit Win9x passiert, wenn es auf einer Platte an Adresse 80h installiert wird, und der Adaptec dann, wenn auch die 2K Platte da ist, die auf einmal zu 81h wird.

  • Kannst du nicht im BIOS des onboard Adaptec einstellen von welcher ID er booten soll?

    Das wäre doch das einfachste.

    Hat W2K nicht auch bereits einen Bootmanager der W9x starten kann?

    Das Verwirrspiel mit 80h und 81h wird erst perfekt wenn du einen IBM Controller mit mehreren Platten verwendest, der bootet nämlich von ID6.

    Da hab ich mal viel Spass mit Lilo gehabt, oder war das doch schon Grub.

    eisapc

  • Nein, der Onboard hat kein BIOS. wp man mit STRG+A rein kann. Man kann nur im EISA-Setup ein paaar Parameter davon ändern.


    Ja, der W2K Bootmanager kann das, aber ich hätte da gerne noch Erfahrungswerte, bevor ich anfange...

  • GRUB4DOS

    Das schaue ich mir mal an. Ich hoffe, das braucht keine Linux-Partition mit Grub.


    Aber erstmal brauche ich ein passendes SCSI-Kabel, damit ich die Win2K-Platte ganz nach oben über das CD-ROM bauen kann, das ist aber schon unterwegs. Die Win2K Platte ist nämlich "halbe Bauhöhe" und versperrt mir somit unten 2x 3,5-Laufwerksschächte. Eigentlich wollte ich ja das CD-Laufwerk wegen der Frontblendenfarbe tauschen, aber jetzt bleibts doch drin, denn das ist ein Laufwerk, was flacher ist, als seine Frontblende, somit kann ich die dicke Platte gerade so noch darüber platzieren. Und dann habe ich unten Platz für eine normalflache 3,5er SCSI-Platte und ein SCSI-ZIP-Laufwerk (oder das 230er Fujitsu-MO-Drive).