Bastelprojekte (Computer bezogen)

  • Heute wurde mein AGP-Test-PC fertig (fast nur defekte Teile):

    • Gehäuse 12mm OSB-Platte, kommen noch Beine dran zum Stapeln, "schonend" mit Senkkopf-Holzschrauben fixiert
    • Mainboard S478 AGP 1x/2x/4x startet nur, wenn Ecke angehoben (hat der Praktikant beim Abziehen der IDE-Kabel herausgefunden)
    • 256/512MB NoName-RAM (OK, aber wertlos)
    • 80GB HDD mit nutzbaren 40GB vor defekten Sektoren, per HPA abgetrennt
    • Seagate 400W Netzteil mit Wiedereinschalt-Problem
    • Celeron 1,7 GHz (wertlos)
    • Arctic-Fan (ok, der ist wirklich geil und darauf vergeudet, kommt 70mm Kühler drauf)
    • DVD-Brenner (liest nur noch CDs)
    • 1,44MB Floppy (OK, aber nur DS1, keine Jumper = nix besonderes)

    Heute schon Amiga Disketten mit gesichert.

    Ich überlege mir noch die Laufwerke + Netzteil mit Lochband zu fixieren, sowie eine Win 98 SE HDD einzubauen

    Ein sehr schöne 'Ratte': "Mainboard S478 AGP 1x/2x/4x startet nur, wenn Ecke angehoben (hat der Praktikant beim Abziehen der IDE-Kabel herausgefunden)". Lass mich raten, du hast etwas Grünes druntergetackert, damit das Board läuft ? Ein Green PC, sozusagen. So ein defektes NEtzteil vollendet natürlich den semiprofessionellen Anspruch.

  • Genau, ein 5mm Fenstereinbau-Abstandsklötzchen.

    Es ist dahingehend defekt, dass es nachdem es eingeschaltet war, einen Power-Cycle braucht um wieder einzuschalten. Weiß man das, ist das kein Problem.

    Normalerweise werden solche Boards beim Testen immer viel strapaziert und können von defekter Hardware defekt gemacht werden.

    Spaßigerweise sind meine bisherigen Testobjekte (Sockel 7 Board mit abgebranntem Spannungsregler, ein Maxdata mit vergesslichem BIOS, ein Pentium 4 ohne Onboard-USB und 2 Belinea-Bildschirme mit defekten Elkos/Streifen) langlebiger wie jegliche normale PC-Komponente.

    ::solder::Ich "darf" beruflich basteln...

  • Heute der erste Basteltag nach dem Urlaub:

    Prototyp Schaltung für den Junior Computer ][ Floppy Controller. Nach etwas Ratlosigkeit, weil erst mal wirklich gar keine Signale aus dem Controller kommen wollten, dann der Gedankenblitz - Reset-Eingang am Controller Chip ist nicht invertiert, sprich der Chip war die ganze Zeit im Reset Modus.

    Nach der Änderung funktionieren nun schon mal Seek und Recalibrate über manuell im Monitor eingegebener Befehle. Heute Abend dann eventuell mal eine kleine Routine zum Lesen eines Sektors schreiben.


  • ... auch schön, wenn der Urlaub wieder vorbei ist und man wieder basteln kann.
    Welchen FDC Chip hast da denn im Einsatz ?

    mfG. Klaus Loy

  • Welchen FDC Chip hast da denn im Einsatz ?

    Den GM82C765B. Der ist recht gut erhältlich und mit dem WD37C65C Anschluss- und Befehlskompatibel. Das Datenblatt sollte man von Letzterem nehmen, da das für den GM82 in echt krudem Englisch verfasst ist und ein paar Fehler drin hat. Das vom WD37 ist zwar auch nicht ganz fehlerfrei, aber immerhin rollen sich einem beim Lesen nicht gleich die Fußnägel hoch.

  • Aus meinem Gefrierschrank kommen 400MB/s, jedoch nur kurz. Aber langsam und von vorne:


    Kundin 1:

    "Der Computer den ich bei ihnen gekauft habe zeigt immer Boot-Fehler und sagt ich sei nicht menschlich"

    "Machen sie mir doch bitte mal ein Foto davon" :/

    Des Rätsels Lösung: so oft auf Links geklickt, bis ebay einen "Bot-Fehler" rausgeschmissen hat, weil es das Verhalten für unmenschlich empfand.


    Kundin 2:

    PC geht immer wieder an/aus, geht dann für 5 Minuten, stürzt dann ab und bleibt im BIOS.

    Medion alles klar angst

    BIOS Batterie nach nur 3 Jahren leer, gemessen und ausgerechnet hätte sie 11 Jahre laufen müssen.

    Neue Batterie = An/Aus-Fehler behoben.

    Trotzdem läuft der PC immer nur 5 Minuten stabil. BTX-PC mit Grafikkarte nur über "Super-Silent" Netzteillüfter gekühlt. Alles wird ordentlich warm und besonders die NVMe-SSD hinterm Arbeitsspeicher.

    Diese SSD läuft nur noch bis 30°C und hängt sich dann weg.

    Also neue SSD rein (HP 512GB): will er nicht. Crucial P2 rein: nimmt er.

    Kunden-SSD Kühler verpasst und im Backofen 50°C 20 Minuten entfeuchtet, Entfeuchterpäckchen in die Mikrowelle 100W 10 Minuten, zusammen mit USB-Adapter und Kabel in eine Tüte, dicht abkleben, abkühlen lassen und in den Gefrierschrank direkt unter den Kühler vom Schnellfrosterfach (Ja ich habe den PC mit 3 Küchengeräten repariert).

    1 Stunde warten und SSD auslesen: Bei 400MB/s hat der tatsächlich 80% kopiert und ist dann wieder abgeschmiert.

    Wieder 1 Stunde warten, auf 100MB begrenzen, Kühlschrank einen Spalt aufmachen und Klimaanlage auf 20°C, damit der Kühlschrank mir nicht verreckt (Süd-Küche hatte 30°C)

    Tada: alle Daten gesichert und verifiziert.

    Tüte aklimatisieren lassen, Kühler an neue SSD angebaut, 92mm Lüfter eingebaut (die von Xilence für ~2€ sind super leise) und fertig...

    ::solder::Ich "darf" beruflich basteln...

  • Ich bin gerade am übernächsten IBM-Kompatiblen für die CC zugange, einem Laser 486/3 : Akku auslöten. Ich glaube, die CR2032 kann ich ohne viel Tamtam an EXT.BATT anklemmen.


    Das Netzteil sagt akut auch keinen Mucks, es pfeift nur leise, der Lüfter läuft nicht an. Mein vorhandenes NOS-Ersatznetzteil macht ohne Last das gleiche. Der Stecker passt sowieso nicht, eher an Pentiumboards. Da muss auf dem 486er Mainboard noch etwas klemmen und ich muss mal das Doppel-Labornetzteil vorsichtig zum Einsatz bringen.

  • Habe mir mit einem Forenmitglied eine Apple + SCSI Kleinanzeige geteilt (wer was bekommen hat, könnt ihr sicherlich erraten).

    VK wollte eigentlich nur Abholung, habe aber den Versand für uns beide organisiert. War super eingepackt.


    Soweit laufen die meisten Sachen. Ein HDD-Gehäuse groß wie ein Computer und eine 5,25" doppelte Bauhöhe HDD war für mich dann aber auch neu (Bilder von der HDD morgen)


    --------------------------

    Ich bin gerade am übernächsten IBM-Kompatiblen für die CC zugange, einem Laser 486/3 : Akku auslöten. Ich glaube, die CR2032 kann ich ohne viel Tamtam an EXT.BATT anklemmen.


    Das Netzteil sagt akut auch keinen Mucks, es pfeift nur leise, der Lüfter läuft nicht an. Mein vorhandenes NOS-Ersatznetzteil macht ohne Last das gleiche. Der Stecker passt sowieso nicht, eher an Pentiumboards. Da muss auf dem 486er Mainboard noch etwas klemmen und ich muss mal das Doppel-Labornetzteil vorsichtig zum Einsatz bringen.

    Musst du messen. Es sollten ca. 60-100µA fließen und kein Strom, wenn eingeschaltet. 3-4x Micro/Mignon oder 6V Lithium Fotobatterie (CRP2?) ist eigentlich üblich. Kannsta uch den Akku durch DECT-Telefon-Akku ersetzten oder 3x Eneloop.


    Klingt nach kurzgeschlossenem Tantal, mit Labornetzteil gibt das schönes Feuerwerk. Durchgangsprüfung an allen Spannungen und du hast das Problem gefunden! AT Netzteile immer mit schwarzen Kabeln zusammen anschließen.

    Der erwähnte Stecker ist der AUX Stecker für Sockel 5 Systeme und hat da nix zu suchen.

  • Mach doch mal morgen im Sonnenlicht schöne Aufnahmen von der Syquest im Hintergrund.


    Wegen der Platte: Das ist bestimmt "normale" / "einfache" Bauhöhe ...

    kommt einem nur heute irgendwie so groß vor. Ich hatte mal halbhohe Seagates. Irgendwas um 5kg das Stück. Und die gab es auch als 9GB SCSI Variante, wo sie dann nochmal doppelt so dick waren. Kurz davor kommt historisch dann Trommelspeicher.

  • Schön, das mit der Alufolie.

    Erzählst du mir mal, was für eine Folie du genommen hast? Eine Selbstklebefolie mit leitendem Klebstoff?

    3M Aluklebeband. 10m x 50mm 1x im Jahr bei Aldi/Lidl 3-4€. Super um Lüfterkugellager öldicht abzukleben und zum einfachen Schirmen.

    Spezielle Klebetechnik beachten, Klebstoff leitet natürlich nicht.


    Mach doch mal morgen im Sonnenlicht schöne Aufnahmen von der Syquest im Hintergrund.


    Wegen der Platte: Das ist bestimmt "normale" / "einfache" Bauhöhe ...

    kommt einem nur heute irgendwie so groß vor. Ich hatte mal halbhohe Seagates. Irgendwas um 5kg das Stück. Und die gab es auch als 9GB SCSI Variante, wo sie dann nochmal doppelt so dick waren. Kurz davor kommt historisch dann Trommelspeicher.

    Ich warte noch auf das Netzteil, dann gerne.

    So dick wie 2x CD-ROM aufeinander. Nachgeschaut: hast recht: volle Bauhöhe schimpft sich das.

    Halbe Bauhöhe kenne ich ja von den MFM-Platten. Noch etwas schlanker von den Quantum Bigfoot.

    ::solder::Ich "darf" beruflich basteln...

  • Spezielle Klebetechnik beachten, Klebstoff leitet natürlich nicht.

    Was meinst Du mit spezieller Klebetechnik?

    Es gibt durchaus Tapes mit leitfähigen Klebstoffen. https://www.parker.com/literat…B%20Conductive%20Tape.pdf

    deswegen frag ich.

    Ja, aber das kostet Geld ;)

    Wenn du Seiten oder Ecken umfaltest, sodass die leitend aufliegen und dann überklebst reicht das vollkommen.


    Ca. 30€ pro Rolle mit Porto, das ist vergleichweise günstig, wenn man bedenkt, was andere verlangen...

    3M 1181 Kupfer-Klebeband leitfähig
    Kupfer + Kleber leitfähig - Abschirmband 0,070 mm stark, Acrlyatkleber
    shop.regio-tape.de

    ::solder::Ich "darf" beruflich basteln...

  • Ein HDD-Gehäuse groß wie ein Computer und eine 5,25" doppelte Bauhöhe HDD war für mich dann aber auch neu

    Echt jetzt? So ein Gehäuse hab ich auch noch rumstehen, gabs mal für nen 10er originalverpackt. Und Ziegelsteinfestplatten hab ich doch schon auf Fotos von dir gesehen? Ja, gabs nicht nur als St506 und ESDI, sondern auch mit SCSI.

    1ST1

  • Echt jetzt? So ein Gehäuse hab ich auch noch rumstehen, gabs mal für nen 10er originalverpackt. Und Ziegelsteinfestplatten hab ich doch schon auf Fotos von dir gesehen? Ja, gabs nicht nur als St506 und ESDI, sondern auch mit SCSI.

    Dann willst du nicht wissen, was 4er und 8er SCSI-Gehäuse zwischenzeitlich kosten.

    Das waren aber alle MFM und meineswissens auch nur halbe Bauhöhe...

    ::solder::Ich "darf" beruflich basteln...

  • So ein SCSI-Gehäuse vergammelt hier auch auch im Keller. Sind die selten und teuer? :sabber:

    Ich dachte nicht, dass das noch jemand brauchen kann.

    • i-Telex 7822222 dege d

    • technikum29 in Kelkheim bei Frankfurt

    • Marburger Stammtisch

    Douglas Adams: "Everything, that is invented and exists at the time of your birth, is natural. Everything that is invented until you´re 35 is interesting, exciting and you can possibly make a career in it. Everything that is invented after you´re 35 is against the law of nature. Apply this list to movies, rock music, word processors and mobile phones to work out how old you are."

  • So ein SCSI-Gehäuse vergammelt hier auch auch im Keller. Sind die selten und teuer? :sabber:

    Ich dachte nicht, dass das noch jemand brauchen kann.

    Hebe es für mich auf ;)


    Das waren aber alle MFM und meineswissens auch nur halbe Bauhöhe...

    Habe eine ganze Kiste Rodime 10x und 20x und danach die ersten fetten (>>100MB) MFM Platten hier. Alle volle Bauhöhe

  • So ein SCSI-Gehäuse vergammelt hier auch auch im Keller. Sind die selten und teuer? :sabber:

    Ich dachte nicht, dass das noch jemand brauchen kann.

    Hebe es für mich auf ;)

    Gerne. :thumbup:

    • i-Telex 7822222 dege d

    • technikum29 in Kelkheim bei Frankfurt

    • Marburger Stammtisch

    Douglas Adams: "Everything, that is invented and exists at the time of your birth, is natural. Everything that is invented until you´re 35 is interesting, exciting and you can possibly make a career in it. Everything that is invented after you´re 35 is against the law of nature. Apply this list to movies, rock music, word processors and mobile phones to work out how old you are."

  • Aber zurück zum Thema:

    Habe gestern die Beifang MicroVAX 2000 das erste mal eingeschaltet. (Beifang, weil die kam mit dem 8 Kanal Lochstreifen Leser/Stanzer mit).

    Festplatte ST251 geht noch und fängt nach einer Weile mit Seeken an - hört sich an, wie wenn das was bootet. Nach einer Weile tritt dann Ruhe ein.


    Dann eine Schnittstelle gesucht, wo die vielleicht was ausgibt. Am kombinierten 15-DSUB Video/Tastatur/Maus Anschluss kommt tatsächlich was auf dem AUX-RS232 raus. Bootet VMS bis zum Login.

    Wer bitte denkt sich sowas aus? (Ja, DEC natürlich...)


    Da ich natürlich keine Ahnung von Username/Passwort habe, kam ich da nicht weiter und habe einfach abgeschaltet und ein gescheites Kabel gelötet...


    Danach nochmals eingeschaltet und nun dies:


    Leider zuverlässig wiederholbar :(

  • Das waren aber alle MFM und meineswissens auch nur halbe Bauhöhe...

    Ich habe zuhause eine 80 MB große MFM-Platte liegen (wirklich kein RLL oder ESDI), die habe ich für eine M24 mit "Sidecar" reserviert, original hat Olivetti da eine "billige" 10MB Fullsize Platte rein gesteckt. Ich muss nur noch den richtigen MFM-Controller haben, bei dem ich die "gigantischen" Parameter dieser Platte eintragen kann.

    1ST1

  • Das waren aber alle MFM und meineswissens auch nur halbe Bauhöhe...

    Ich habe zuhause eine 80 MB große MFM-Platte liegen (wirklich kein RLL oder ESDI), die habe ich für eine M24 mit "Sidecar" reserviert, original hat Olivetti da eine "billige" 10MB Fullsize Platte rein gesteckt. Ich muss nur noch den richtigen MFM-Controller haben, bei dem ich die "gigantischen" Parameter dieser Platte eintragen kann.

    Ich verstehe Bahnhof...

    Hast du kein BIOS, wo du das eintragen kannst, brauchst du eine Karte mit Bootrom. Da sind die meistens Fest vorprogrammiert. Du müsstest das also umprogrammieren.

    Oder du schmeißt gleich eine XT IDE Karte rein. Das mit den riesen Laufwerken würde ich mir nicht mehr geben

    ::solder::Ich "darf" beruflich basteln...

  • XT IDE nett aber kein Vergleich zu einem richtigen Männer-Ziegelstein. XTs haben kein "BIOS", sondern da regelt das das BIOS auf dem Controller, meistens per Jumper mit vordeifinierten Typen und die Jumper auf den MFM-Controller enthalten meistens nur Plattentypen mit bis zu 40 oder schon seltener 60 MB - 80 MB MFM ist für damalige PCs schon arg exotisch. Die Kapazität ist auch bei RLL schon selten und wurde erst mit ESDI (und IDE), das es nur für ATs gab, gängiger.

    1ST1

  • XT IDE nett aber kein Vergleich zu einem richtigen Männer-Ziegelstein. XTs haben kein "BIOS", sondern da regelt das das BIOS auf dem Controller, meistens per Jumper mit vordeifinierten Typen und die Jumper auf den MFM-Controller enthalten meistens nur Plattentypen mit bis zu 40 oder schon seltener 60 MB - 80 MB MFM ist für damalige PCs schon arg exotisch. Die Kapazität ist auch bei RLL schon selten und wurde erst mit ESDI (und IDE), das es nur für ATs gab, gängiger.

    Das weiß ich doch, aber nicht ob du da einen XT oder AT hast.

    Dann musst du mal schauen, ob du eine XT-Karte bekommst mit diesen Werten oder ob es ein EPROM für diese Karte gibt, dass das kann.

    ::solder::Ich "darf" beruflich basteln...

  • Dann musst du mal schauen, ob du eine XT-Karte bekommst

    Muss ich nicht, denn es gibt tatsächlich MFM-Controller für XTs, bei denen man beim Lowlevel-Format der Platte die Parameter per Tastatur eingeben kann. Das Controller-BIOS ließt dann später beim Einschalten/Reset die Daten wieder aus der formatierten Platte aus. Einen solchen WD-Controller habe ich, der ist in einer M24SP verbaut, in der schon eine exotische Platte von Mitsubishi (Gesundheit!) (von den CHS-Daten ein ganz krummer Hund mit 5 Köpfen) verbaut ist, die sonst kein Controller unterstützt.

    1ST1